Detailer's Magic

Fractal Design Detailer is the amazing 3D paint program. With Detailer, you can paint directly on 3D models,
adding color, texture, shine, and reflection effects. It’s the closest thing to actually holding an object in your
hand and painting on it.

Detailer is easy to use. It allows you to create intricate, realistic surface maps while bypassing much of the
technical gauntlet that makes most 3D programs seem difficult.



Detailer for 2D and 3D

Detailer is an incredible bridge between 2D and 3D. It complements both 2D paint programs and 3D
modeling programs.

If you’re a 2D artist, Detailer helps you create depth shading and oblique views of your subject. After creating
a Detailer rendering, you can create a 2D collage right in Detailer. You may also take renderings into Fractal
Design Painter or any other 2D art program and composite them with other images. Detailer renderings
include an 8-bit mask, so compositing is smooth and easy.

If you’re a 3D artist, Detailer is a one-stop shop for creating texture, bump and other surface maps on your
3D models. Detailer provides a direct-manipulation environment for detailing 3D surfaces. There’s no more
bouncing your surface maps back and forth between your image-editing and 3D rendering applications.



Importing/Exporting Models

Detailer can import a model created in another 3D program. After you’ve detailed the surface of the model,
you can export it. If the correct format is used, all of the surface maps and settings are saved with the
exported model. When you add the model to your 3D scene, all of the work you did in Detailer will be intact.

Detailer includes a set of 3D primitive objects and has the ability to import models in several 3D formats. You
can assign texture, bump, reflection, highlight, and glow maps to any object in the model. These maps may
be at any resolution and come from a range of sources—imported paintings and photographs, Detailer’s own
Patterns and Textures, or images painted from scratch within Detailer.

Detailer can import and export 3D models in Detailer-native, QuickDraw 3D2 (3DMF), 3D Studio? (Windows
version only) and DXF formats. Included extensions for Ray Dream Designer2 and Ray Dream Studio? import
and export models in Detailer format, so you can use Detailer with models you create in these programs.



Developing Maps

When you’re developing your maps, you can paint directly on the object or work in the 2D view of the map
image. Paint where it’s convenient for you. Detailer automatically updates the brush stroke to the other
window. This means that if you paint on the model object, the stroke will also appear in the associated map
image window, and vice versa.

Detailer provides an arsenal of painting tools. Paint directly on the model using the wonderful Natural-Media
brushes Fractal Design Painter is famous for. And if that’s not enough, you can customize and create your
own specialty brushes.

Detailer supports multiple floating selections or “floaters,” so imported Painter or Photoshop? files maintain
independent floaters and layers. You can export your models with their maps and incorporate them in your
3D scenes and animations. You may also render your model right in Detailer, then use the mask to aid in
compositing with other images.

Detailer’s Multiple Undo feature allows you to step back through your actions up to 32 times!

Detailer can also open and save map image files in a variety of formats, including RIFF, PICT, TIFF, BMP,
JPEG, Photoshop 2.x, and Photoshop 3 (complete with layers).



Mapping on Models

A Detailer model may be comprised of a number of objects, and each object may have its own set of maps.
As many as five maps can be active and displayed on each object. Each map type controls one characteristic
of the object’s appearance:

* Texture Maps give the model its color.
* Bump Maps give relief to the surfaces.
* Highlight Mask control which areas are shiny or matte.

e Reflection Mask indicate which areas reflect their surroundings. Environment maps that you import define
the reflection image.

* Glow Maps add diffuse color after texture and lighting have been applied.

Detailer supports multiple mapping methods: cylindrical, spherical, cubical, pass-thru, and UV (implicit). Each
map can have its own mapping method, which you can change at any time.

Detailer provides flexible mapping controls, including the ability to resize and resample maps, adjust
mapping scale, and move the map seam and origin.



Detailer's Lighting Controls

Detailer provides control over the lighting environment. You can illuminate models with up to ten colored
lights and set their brightness and concentration. With the Light tool, you can click on the model to create a
light shining there.



High-resolution Rendering

Detailer can render 3D models at any resolution, complete with anti-aliasing and mask information.
Composite renderings directly in Detailer, or use a paint or image-editing program like Fractal Design Painter.



About this User Guide

This Detailer User Guide assumes you’re familiar with your computer’s operating system and basics like
clicking and dragging.

See also:
Organization
Section | Introduction
Section Il Models, Maps and Light
Section Il Imagery

Section IV Advanced Techniques
Reference

Conventions



Organization
This Help System is organized into five sections, comprised of several chapters each.

The sections divide 3D information from 2D information and separate primary features from those that are
more advanced.



Section | Introduction

This section describes the Detailer interface and gives the basics of working in Detailer. Full tutorials are
included in the Fractal Design Detailer User Guide.

See also:

Getting Acquainted with Detailer
Detailer Basics



Section Il Models, Maps and Light

This section covers Detailer’s 3D features. The first chapter of this section covers model features—acquiring,
manipulating, saving and exporting. The second chapter covers surface maps, including the methods and
features for applying and controlling them. The third chapter of this section covers the features for applying
light to the model.

See also:
Working with Models

Using Maps
Using Lights



Section Ill Imagery

This section covers the basics of developing images for use as maps. Starting with the features of image
windows, the chapters proceed through image materials, painting, and advanced painting.

See also:
Working with Images
Image Materials
Painting
Customizing Detailers Brushes




Section IV Advanced Techniques

This section covers some of the more powerful features and techniques for creating and manipulating
imagery:

® Selections and masks increase your control for developing imagery.
* Floating selections or “Floaters” let you move and manipulate imagery within a document.
* The Image Hose lets you paint with images.
® Special effects offer practical and creative ways to create and modify imagery.
* The Printing chapter describes how to set up and use Detailer’s print features.
See also:

Selections and Masks

Floaters

Using the Image Hose

Applying Effects

Printing



Reference

The Fractal Design Detailer User Guide includes a Reference section. This section includes the appendices,
glossary, index and software licensing agreement. Appendix A, “Designing Maps,” provides technical
information on designing surface maps. Appendix B, “Using Detailer with Other Programs,” provides
information about using Detailer with other programs, including features for exporting and importing Detailer

models in Ray Dream Designer or Studio. Appendix C, “Optimizing Memory Usage,” describes memory
considerations and offers tips on getting the most out of Detailer.



Conventions

Detailer is available for Macintosh and Windows. Program functionality is identical on the two platforms. Only
keyboard commands and the appearance of document windows, palettes and dialogs differ.

This user guide describes Detailer for both platforms. The keyboard commands for both platforms are given.
For example: “To save the file, press Command-S (Macintosh) or Ctrl+S (Windows).”

Screen captures of the palettes and dialogs are divided between the two platforms. Some sections use
Windows captures,
others use Macintosh.

Many Detailer features are available on menus. Some menu items offer sub-menus. This user guide
describes selecting these features as follows: In a distinctive font, the menu is identified, followed by an
arrow and the feature name. For example: File menu> Save.

If the feature is on a sub-menu (pull-right menu), an additional arrow and item appear. For example: Edit
menu> Paste> Into New Image.

Some palettes contain menus. In this case, the palette is identified, then the standard menu notation is used.
For example:

Materials palette: Object menu>

Set Object Color.

The Controls palette is a special palette whose content changes based on which tool is selected. This palette
is referred to as the Controls palette: Tool Name —for example, Controls palette: Floater Adjuster tool.



Getting Help

Detailer offers help information from within the application. This help is an abbreviated version of text from
this manual. Refer to your Quick Start guide for more information on getting help.

The Detailer Quick Start Guide contains information about how to install Detailer, set application memory,
access the Help system and use the Detailer CD.




Technical Support

You will find the answers to most of your questions within the pages of this User Guide. If you need further
assistance, you may contact Fractal Design’s Technical Support in any of the following ways:

www: http://www.fractal.com/
See the technical support
on-line guide for answers
to frequently asked
questions.

Phone: 408 430-4200 between
the hours of 8am and
5pm,

Pacific Standard Time.

FAX: 408 438-9672
Please fax a copy of the
Troubleshooting worksheet
found in the back of this
User Guide.

Internet: mac_support@fractal.com
win_support@fractal.com

Fill out and e-mail the form
at
http://www.fractal.com/sup
port/tech/contact.html

Mail: Technical Support
c/o Fractal Design
Corporation
P.O. Box 66959
Scotts Valley, CA 95067

For More Information

For more
information
about Fractal
Design
products, see
our World
Wide Web site
on the
Internet:

WWW: http://
www.fractal.com/

To exchange
tips and
techniques
with other
users, see the
following
online forums:



AOL: Keyword “Fractal”

CompuServe: “GO GUGPRA»

Getting Acquainted with Detailer
See also:
An Overview of Detailer
The Tools Palette
Palettes and Drawers
Libraries and Movers
About Plug-Ins
Setting up Ray Dream Designer to Export Detailer Models
Setting Detailer’s Preferences
Setting Pressure Sensitivity
Customizing the Interface
Setting Multiple Undo Levels

Preferences for Windows




An Overview of Detailer

In Detailer, you’ll create surfaces on
models by wrapping them with images.

The model you’re working on appears in the Model Window. Images appear in image windows. Detailer
supports these two document types.

Some of Detailer’s features are for working in 3D on the model. Some features are for creating and working
with images; and some features are for applying those images to the model, a process called mapping.

Detailer has a wealth of features. They’re organized (according to function) in pull-down menus and palettes.
Palettes are windows containing tools, options, and materials that float over your document windows.
Detailer has four main palettes—Tools, Controls, Brushes and Materials.

You can control the display of these
palettes using the Window menu.



The Tools Palette

In the Tools palette, you will find tools for viewing and navigation, adding light, painting, filling with color, and
creating selections. If the Tools palette is not displayed on your screen, you can display it by choosing
Window menu> Tools.

The Controls palette contains options for the current selected tool. The Controls palette updates as you
select different tools to reveal the selected tool’s options. If the Controls palette is not displayed on your
screen, you can display it by choosing Window menu> Controls.

See also:
The Object Selection Tool
The Virtual Trackball Tool

Magnifier Tool
Grabber Tool

The Dropper Tool
The Brush Tool

The Paint Bucket Tool
The Text Tool

The Light Tool
The Selection Tools

The Lasso Tool

The Floater Adjuster Tool



2D and 3D Tools
Some tools are exclusively for working in the Model Window. Some tools are only for working in 2D image
windows. Several tools may be used in both windows.

The Tools palette will change, depending on whether the Model Window or an image window is activated.
Detailer dims the icons of tools that are not available for the current window.



The Object Selection Tool

The Object Selection tool lets you identify which object (in a model comprised of several) you want to detail.
The Controls palette shows technical information on the selected object.

The Object Selection tool works only in the Model Window.



The Virtual Trackball Tool

The Virtual Trackball tool lets you rotate your view of the model in the Model
Window. The Controls palette offers sliders for controlled rotation on each of the three axes.

The Virtual Trackball tool rotates the view of the model in the Model Window; it does not rotate the model.
Lights remain fixed in relation to the surfaces of the model. When you use the Virtual Trackball tool to rotate,
you view the model from different angles. For more information about using the Virtual Trackball tool, see
“Working in the Model Window”

In an image window, the Virtual Trackball tool functions as the Rotate Page tool from Fractal Design Painter.
Rotate Page lets you rotate the image canvas to an angle that’s comfortable to your drawing style.

Using the Virtual Trackball tool, drag (in the image window) to rotate your page. When you want to set the
image back to its natural orientation, click in the window.

The keyboard shortcuts for this tool work regardless of the window type. Use Option-Spacebar for Macintosh
or Spacebar+Alt for Windows.



Magnifier Tool

The Magnifier tool allows you to magnify areas of an image when you are performing detailed work or zoom-
out to get an overall view of an image. Click once to zoom in. To zoom out, hold down the Option key for
Macintosh, Alt for Windows and click.

Click and drag to zoom in on a given rectangular area of an image. You can also use the Controls palette to
set the zoom level in image windows.

The Magnifier works in both the Model Window and image windows.

You can access the Magnifier tool while any other tool is selected. For Macintosh, hold down Command-
Spacebar and click to zoom in or Command-Option-Spacebar and click to zoom out. For Windows, use
Spacebar+Ctrl to zoom in and

Spacebar+Ctrl+Alt to zoom out.



Grabber Tool

The Grabber tool gives you a quick way to scroll the image or the model. You may also set the zoom level on
the Controls palette for an image window when the Grabber tool is selected.

The Grabber works in both the Model Window and image windows.

You can access the Grabber tool from any tool by holding down the Spacebar.



The Dropper Tool

The Dropper tool lets you pick up a color for use elsewhere. The Controls palette shows you values for the
color. When you select a color with the Dropper tool, that color becomes the current color on the Materials:
Color palette.

The Dropper works in both the Model Window and image windows.

You can access the Dropper tool from any color related tool by holding down Command for Macintosh, and
Ctrl for Windows. These tools include the Brush, Paint Bucket, Rectangular and Oval Selection tools and the
Floater Adjuster.

When used on a model, the Dropper picks up the color of an object without calculating the color of a light on
the surface.



The Brush Tool

The Brush tool lets you paint strokes directly on the model, on images or on a floater. You can set Opacity,
Grain, and Draw Style (Freehand or Straight Lines) in the Controls palette.

The Brush tool represents a category of marking tools. Within the Brush category are pencils, crayons, pens,
chalk, airbrushes, the remarkable Image Hose, and more. The Brushes palette lets you choose between
these tools and gives you access to controls that let you customize the brushes.

See also:
Painting
Advanced Painting

The Brush tool works in both the Model Window and image windows.

You can use the Brush tool to paint on a floater.
A floater is an image element or layer that hovers over the canvas or background.




The Paint Bucket Tool

The Paint Bucket tool lets you fill an area. The Controls palette shows choices for what area to fill and what to
fill it with.

The Paint Bucket works in both the Model Window and image windows.



The Text Tool

The Text tool lets you create text floaters. Use the Controls palette to choose a font, point size, and set
tracking.

The Text tool works in both the Model Window and image windows.



The Light Tool

The Light tool lets you click on the model to create a light that shines there. The Controls palette gives you
sliders to adjust the light you create.

The Light tool works only in the Model Window.



The Selection Tools

The Selection tools select an oval or rectangular area. When you create a selection, its coordinates are
displayed on the Controls palette.

These tools share a space on the Tools palette. Only one will appear at a time. To select the other tool, hold
down on the icon and when the icon for the other tool “pops-up” select it. You may also switch between the
tools on the Controls palette.

The Selection tools work only in image windows.
Rectangular Selection Tool
The Rectangular Selection tool allows you to create square or rectangular selections.
Oval Selection Tool

The Oval Selection tool allows you to create circular or oval selections.



The Lasso Tool

The Lasso tool lets you create a freehand selection area. The selection automatically snaps closed when you
let up on your mouse or stylus. On the Controls palette, you can choose to add or subtract from an existing
selection.

The Lasso tool works only in image windows.



The Floater Adjuster Tool

The Floater Adjuster tool allows you to select and adjust floaters. Click once to select one floater, or shift-
click to select additional floaters.

Floaters are image elements that float above the background image. The Controls palette lets you change
opacity, feathering, composite methods and floater layer order. It also allows you to group and drop
floaters.

The Floater Adjuster works in both the Model Window and image windows; however, not all functions are
available in the Model Window. The following functions of the Floater Adjuster are restricted to image
windows:

® Selecting floaters by dragging a marquee.

* Adjusting a reference floater by dragging its handles.



Palettes and Drawers

See also:
Using Palettes
Rearranging Palettes
Viewing and Hiding Palettes
Viewing Additional Palette Controls
Using ltems in Palettes
Using Palette Drawers
Locking Items on the Drawer Front
Tearing Off Palettes
Cleaning-up Palettes



Using Palettes

Detailer’s controls are organized into palettes. The Tools and Controls palettes are main palettes with every

function visible (no drawer mechanism). The Brushes palette is a main palette with pull down menu options

and a drawer containing brushes. The Materials palette is a main palette that holds several subpalettes. The
main palette pull down menus with additional options for each subpalette.

* The Tools palette determines your current activity. For example, you use this palette to tell Detailer
whether you want to draw, zoom in on a document, or select part of an image.

* The Controls palette changes to reflect options for the selected tool in the Tools palette, and to give you
instant access to the tool’s main functions. For example, when you have selected the Brush tool, the Controls
palette shows your Draw Style options.

® The Brushes palette is where you choose from Detailer’s wealth of drawing, painting and image editing
brushes. Brushes can be moved from inside the palette drawer to the drawer front.

The Materials palette is where you select your materials—from the basics, like a color for your pencil, to
unusual patterns, textures, lighting for the model, and the five map types you’ll apply to the model. The
subpalettes of the Materials palette are Color, Texture, Object, Pattern and Light.

See also:

Palette Tips



Palette Tips:
* Arrange your palettes so you can find and identify controls more effectively. Make sure that open palettes
don’t overlap each other. Palettes hidden in this way can be hard to find.

® Lock your favorite brushes to the Brushes Palette drawer front for quick access.

* If you have two monitors, use one to display the palettes, and use the other monitor to work in the
document window.




Rearranging Palettes
You can drag a palette to any location that’s convenient for your work. You can also stack palettes together
to save space. When palettes are moved in close proximity, they will snap together.

Detailer saves your palette arrangement, including locked items, so that it appears as you left it, the next
time you start the program.



Viewing and Hiding Palettes

You can hide a single palette by clicking its close box. You can display a palette by choosing its name from
the Window menu or using the key combination shown on the Window menu.

To hide all of the palettes, choose Window menu> Hide Palettes or press Command-H (Macintosh) or Ctrl+H
(Windows). Choose Window menu> Show Palettes again to display the palettes.



Viewing Additional Palette Controls

Many of Detailer’s palettes have additional controls that can be displayed or hidden, depending on the task
at hand. If you have opened a subpalette, you can expand it by clicking its grow box. For example, the

Materials: Color palette can be expanded to show the Color Variability sliders. Click the grow box again to
hide them.



Using Items in Palettes

To select an item from the front of a palette:
® Click the item’s icon.

A red outline appears around the icon you have selected. If you have clicked on an icon representing a
subpalette, the palette displays the options for that subpalette.

For example, when you click the Texture icon on the Materials palette, the palette appears along with a
drawer containing a collection of different textures. You can collapse this subpalette by clicking its icon again.

To select a menu item from the front of a palette:
® Choose it from a menu above an icon.

Some menu items open other palettes. For example, you can open the Floater List palette by choosing
Floater List from the Materials palette: Object menu.

When you’ve finished using the Floater List, you can close the palette by clicking its close box.



Using Palette Drawers

You can open the drawer of a main palette or subpalette to see the other items inside the drawer. The
pushbar indicates which palettes or subpalettes have drawers.

Storing items in closed drawers gives you more screen space. You will keep items on the drawer front that
you use most often and retrieve other items when you need them. For example, you would keep the most
often used textures on the front of the Texture subpalette. You would open the texture drawer to retrieve a
texture you use less often.

To retrieve items from inside a drawer, open the drawer by clicking the pushbar. A down arrow on the
pushbar means the drawer can be opened. You can click anywhere on the pushbar to open and close
a drawer. There are three methods for retrieving items from drawers:

* by clicking the icon
® dragging the icon
® by selecting the item’s name from the pop-up menu.
In some drawers, you’ll see a Library button. You can click it to reload the drawer with a new set of materials.
See also:
Libraries and Movers

You can access any palette drawer while in the effects dialogs. Your new selection updates in the preview
window. For more information about effects, see Applying Effects.

To take items out of a drawer by clicking:
Open the drawer and click the icon for the item you want.

The item will move to the front of the drawer, and it will be outlined in red to show that it is selected. Detailer
automatically replaces the least recently used item.

Iltems that are already on the front of the drawer are ghosted inside the drawer. When you put an item away,
it goes back to the same location so that you can always find it easily.

To take items out of a drawer by dragging:
Once the drawer is open, you can drag items out of the drawer to a specific position on the drawer front.

If you want to rearrange an icon’s position on the drawer front, first it will have to be replaced by an icon
from the drawer. Then you can drag the icon from inside the drawer onto the desired position on the drawer
front.

To use the pop-up menu to take items out of a drawer:
1 1o select an item by name, click the pop-up menu to display a list of all the items in the drawer.

2 Highlight the item you want and let up on your mouse or stylus to confirm your selection. The item’s name
appears on the pop-up and its icon appears on the drawer front outlined in red.

3 Click the pushbar to close the drawer.



Locking Items on the Drawer Front

You can arrange the items you use most frequently on the drawer front and lock them in place. When an item
is locked, Detailer will not put another item in its place. You will want to lock your favorite tools to the front of
the drawer so they are always there when you need them.

To lock items in place:
1 Drag each item out of the drawer to where you want it on the drawer front.

2 For each item you want to lock, click its icon and hold it down until a tiny green light goes on under the
icon. When you let go, the light stays on to show that the item is locked.

The item stays locked until you unlock it by pressing down on the icon again until the green light goes off.
Detailer lets you lock all but one item on any drawer front. One item must remain unlocked to allow a space
for any new item you might select.



Tearing Off Palettes

There are times when you’ll want to work with two palettes that usually aren’t available at the same time.
For example, you might want to work simultaneously with the Texture and Color subpalettes.

If you want to work with two subpalettes side-by-side, you can “tear off” one of them to display it separately.
Just drag its icon off the main palette. The torn off palette appears where you drop it.

When you no longer need the palette you’ve torn off, just click its close box.

Remember that one subpalette must remain displayed in the main palette. The selected palette will remain,
so you must drag one of the other palettes. If you want to tear off the current, selected palette, select a
different palette first.



Cleaning-up Palettes

You can choose Window menu]> [Clean Up palettes] to stack palettes in their collapsed state along the edge
of the screen.



Libraries and Movers
See also:
What are Libraries?

Adding tools or materials to the Current Library
Loading Alternate Libraries

Customizing Libraries

Creating a New Library

Accessing the Movers

Moving Items between Libraries
Modifying a Library

Default Libraries



What are Libraries?

A library is a saved collection of similar tools that can be loaded into a palette. For example, Detailer’s built-
in brushes (and their variants) are contained in the default brush library (Detailer Brushes), which is loaded
when you launch Detailer. As you customize brushes and other materials, you can save them into you own
libraries.

Libraries are available for textures, patterns, gradations, brushes, nozzles, floaters and lighting. You may
have any number of libraries, but only one (of each type) will be open at a time. When you want other tools,
you can load the alternate libraries.

Libraries allow you to extend Detailer’s tools and materials, without overloading the palette drawers.

The methods for working with all libraries are the same. You can create new libraries, add tools or materials,
and move items between libraries.

It’s a good idea to limit the number of tools or materials in a library. This makes it easier to find a particular
tool and helps Detailer manage memory.

Brushes are loaded into memory when you launch Detailer, so adding brushes to the default brush library
increases Detailer’s need for RAM. If you are working close to the memory threshold, you’ll want to organize
new brushes into secondary libraries. When you want a different brush set, switch libraries. This will help
Detailer be more efficient with memory.




Adding tools or materials to the Current Library

As you work with Detailer and create new tools or materials, you can save them to the current library. The
command for adding an item depends on its type. In some cases, you click a Save button. In others, you
choose a menu command. And in the case of floaters, you drag them from the image into the library palette.

The method of adding a particular resource to the library is described in the section on customizing that
resource.



Loading Alternate Libraries
When you want to use the items in a different library, you can load that library.

When you save tools or materials, Detailer puts them in the current library. If this is not where you want
them, you must switch libraries before saving.

To switch libraries:
1 Open the palette drawer for the tools or materials you want to work with, for example, Brushes.
2 Click Library. Detailer displays a directory window.

3 Select a library, then click Open or OK. Detailer loads the items from that library into the palette.



Customizing Libraries

The controls for creating libraries and managing their contents are contained in the Movers. A Mover is

provided for each category supported by libraries—textures, patterns, gradations, brushes, nozzles, floaters
and 2D lights.



Accessing the Movers

Each kind of mover is accessed from a
different location.

Texture

To open the Texture Mover, choose
Materials palette: Texture menu> Texture Mover.

Pattern

To open the Pattern Mover, choose
Materials palette: Pattern menu> Pattern Mover.

Lighting (applied lighting, 2D effect)

To open the Lighting Mover, choose
Command-Shift-L (Macintosh) or Ctrl+Shift+L (Windows).

Floater

To open the Floater Mover, choose
Materials palette: Object menu> Floater Mover.

Brush Mover

To open the Brush Mover, choose
Brushes palette: Brushes menu> Brush Mover.

Nozzle

To open the Nozzle Mover, choose Brushes palette: Nozzle menu>
Nozzle Mover.

Gradations

To open the Gradation Mover, choose Materials palette: Color menu>
Grad Mover.

The features of working with Movers are described below. When you have finished working in the mover,
click Quit.



Creating a New Library

Create a new library first, then copy or save items to the library.

To create a new library:
1 Open the Mover for the library you want.
2 Click New. Detailer prompts you to name the new Library.

3Enter a descriptive name and click Save or OK.

It’s a good idea to save libraries in the same directory. This makes them easy to locate and load when you
want them.

The new library’s name appears on the right-hand side of the Mover window. The area above the name is
blank because this new library is empty. To put things in it, you can move them from other libraries.



Moving Items between Libraries
Movers copy items from the library open on one side of the dialog to the library open on the other side.

When you open a Mover, the resources of the current library are listed on the left. Often, this is the library
you’ll want to move from. If not, you can open a different library as the source. Click Close to close this
library. Then click Open and select a different library file.

The destination library must be open on the other side. If you just created a new library, it will be open. If
not, you may open an existing library. Click Open and select a library file.

When the source library is open on one side and the destination library is open on the other, you are ready to
move resources.

To copy an item between libraries:
1 Make sure the source library is on the left of the mover and the destination library is on the right.

2 Select the item you want to move. The Preview shows an icon of that item. In the case of brushes, the
Preview shows the icon associated with each brush.

3 Click Copy. Detailer copies that item to the other library.



Modifying a Library

If you want to delete a resource from a library, you may—but be careful. If you remove one of Detailer’s
default brushes by mistake, the only way to retrieve it is to reinstall Detailer. When you reinstall Detailer,
you’ll lose any of the custom resources you’ve created, unless you save them into other libraries.

See also:
Deleting ltems
Renaming Iltems
Changing Brush Icons
Deleting a Library



Deleting Items

To delete an item from a library:
1 From within the mover, Select the item you want to delete.

2 Click Remove.



Renaming Iltems

To change the name of an item:

1 select an item.
2 Click Change Name. Detailer displays a dialog.

3 Enter the new name and click OK. When Detailer asks if you’re sure you want to change the name, click
Yes.



Changing Brush Icons
Working with brushes, you have the additional option of replacing the icon used on the Brushes palette.

Before you open the Brush Mover, use the Rectangular Selection tool to select part of a 2D image you want
as the brush icon.

10pen the Brush Mover by choosing Brushes palette: Brushes menu> Brush Mover.
2 Select the brush whose picture you want to change.
3 Click Change Picture. Detailer displays the change that you are proposing.

4\f you’re sure you want to change the picture, click OK.



Deleting a Library

To delete an entire library on a Macintosh, go to the finder and drag the library to the trash. On Windows, you
may delete the file from the Windows~ 95 Explorer. You may also drag the file to the Recycle Bin.

Be careful not to delete one of Detailer’s default libraries. If Detailer can’t find the libraries it needs, you will
have to reinstall Detailer.




Default Libraries

When you launch Detailer, the program loads the default libraries. If you would prefer to load other libraries
on launch, you can change the defaults.

Default libraries must be located in the directory with the Detailer application program.

To specify default libraries choose Edit menu> Preferences> General.

In the Libraries portion of the General Preferences dialog, enter the exact file names for the libraries you
want Detailer to load as default.



About Plug-Ins

Detailer supports third-party Photoshop-compatible plug-ins such as Kai’s Power Tools. There are three kinds
of plug-ins: Filter plug-ins, Import plug-ins and Export plug-ins. Plug-in modules are available from Detailer
menus. However, the actual operation of these plug-ins is determined by the plug-in developer. You should
refer to the documentation that came with your plug-in modules for instructions on how they work.

If you are interested in developing plug-in modules, please contact Adobe Systems for Developer kit
information.

See also:
Filter Plug-ins
Import Plug-ins
Export Plug-ins

Making Plug-Ins Available to Detailer




Filter Plug-ins

Filter plug-ins appear after Detailer’s built-in effects, in the Effects menu. These Filter plug-ins are usually
comprised of special image-editing effects. Plug-in filters operate the same way that Detailer’s Effects
operate. If you have an active selection, the filter is applied to the selection. If you have no selection, the
filter is applied to the entire image. Once the effect is applied to a map image, that has been associated with
a model, the view updates in the Model Window.

Since, Detailer and Photoshop were developed by different companies, there may be filters that will run in
one program, but not another. Fractal Design has made a conscientious effort to maintain compatibility with
as many third party filters as possible. Check with the filter developer to find out whether there are any
compatibility problems between their product and Detailer. Please note that since Detailer is an RGB-based
program, it cannot run filters that are specific to CMYK or Grayscale modes.



Import Plug-ins
Import plug-ins are accessed through the File> Import submenu. The Import interface is generally used to

support file
formats that are not built-into Detailer.



Export Plug-ins
Export modules are used to export models. Export modules are available through the File> Export submenu.

Check our web site at www.fractal.com for new information and availability of import and export
plug-ins for different 3D file formats.




Making Plug-Ins Available to Detailer

When Detailer launches, it searches for plug-ins in two locations. Detailer first looks in the Detailer
application folder and in directories below it. The second place that Detailer looks is the folder specified by
the “Other Raster Plug-Ins” preference.

Before Detailer can display your plug-ins in the Effects menu, you must indicate where your plug-ins are
located on your hard drive. Detailer will load plug-ins from the selected directory and its sub-directories.

To locate the plug-ins folder in
Windows95:

Choose Edit menu> Preferences> Other Raster Plug-ins. Browse to select the directory containing your plug-
ins. Click OK. Restart Detailer to have this change take effect.

To locate the plug-ins folder in Macintosh:

1 Choose Edit menu> Preferences> Other Raster Plug-Ins. You will see an Open File dialog box. Use the
dialog to specify the directory that contains your plug-ins.

2 Click the Select Plug-ins button.

3 You will have to quit Detailer and then restart the program to load these plug-ins.

When Detailer starts-up it quickly displays the names of all available plug-ins on the start-up screen.

To use third-party 2D plug-ins from within Detailer:

Choose the Effects menu. You see a list of available plug-ins at the bottom of the menu. You can use them to
edit your image.

Plug-ins that are designed for grayscale or CMYK images may not work properly in Detailer.




Setting up Ray Dream Designer to Export Detailer Models

Detailer lets you work with models you’ve created in Ray Dream Designer. To do this, you’ll export from Ray
Dream Designer 4.1.2 or later in the Detailer file format. You can then open the exported file in Detailer.

Ray Dream Designer may be used independently or as a component of Ray Dream Studio. The export setup
and method is the same in both products.

Exporting from Ray Dream Designer is handled as an extension.
1 You must have Ray Dream Designer 4.1.2, or later, installed.
2 Look in the Detailer folder on your hard disk. Locate the folder “For Ray Dream Designer.” Open this folder.

3 Copy the two files in this folder to the Ray Dream Extensions folder.

The next time you launch Ray Dream Designer, the File> Export dialog will offer Detailer as a file type option.
You have several options for the export. See Fractal Design Detailer User Guide: Appendix B, “Using Detailer
with Other Programs,” for more information.



Setting Detailer's Preferences

Detailer has several preference dialogs: General, Brush Tracking, Interface, Other Raster Plug-ins, Undo,
Model and Windows.

See also:
General Preferences

Model Preferences




General Preferences
To display the general Detailer preferences dialog box, choose Edit menu> Preferences> General.
See also:

Cursor Setup

Setting the Default Libraries

Choosing aDefault Scratch Disk

Floater Pre-Feather

Draw Zoomed-out Views Using Area-averaging

Display Warning When Drawing Outside Selection



Cursor Setup

Detailer gives you several choices for the appearance of your cursor. To choose whether the cursor will be a
triangle or a single pixel, check the radio button next to Cursor Type. To determine the direction the cursor will
point (depending on your design and whether you’re left- or right-handed), click the appropriate button in the
circle above Orientation. To select a cursor color that will contrast with your working area and will therefore be
clearly visible, click the appropriate rectangle above Color.



Setting the Default Libraries

Detailer provides several libraries that contain many different brushes, textures, floaters, lights and color
sets, and you can create your own. By typing a file name in the text box next to Brushes, Textures, Floaters, and
Color Set, you can designate which libraries will appear in drawers when you open Detailer.



Choosing aDefault Scratch Disk

To select the disk volume that Detailer will write its temporary file on, choose the volume name from the
Temp File Volume pop-up menu.



Floater Pre-Feather

The Floater pre-feather box determines how much you can feather a floater. The default setting is 16 pixels,
making this the maximum setting allowed for theFeather slider in the Controls palette: Floater Adjuster tool.
You can change this default to any number up to 50. The change takes effect immediately.



Draw Zoomed-out Views Using Area-averaging

When looking at an image at less than 100% view, screen re-draw is faster if you leave this option disabled.
Drawing is slower but more accurate if this option is enabled.



Display Warning When Drawing Outside Selection

Enabling this option activates the warning that appears when you draw outside a selection. The warning will
not appear if this option is disabled.



Model Preferences
Choose Edit menu> Preferences> Model. Detailer displays the Model Preferences dialog.

See also:

Model Display During Movement
Wire Frame

Wire Frame with Depth Cueing
Anti-aliased Wire Frame

Anti-aliased Wire Frame with Depth Cueing

Fully Textured Rendering

Shaded Non-Textured Rendering
New Model Rounding Factor
Background Color

Mesh Color

Ray Dream Compatible



Model Display During Movement

Detailer lets you set an option for the model display during tracking. The model display option is only visible
when changing the view of a model.

To change the model display during movement, choose the setting you want from the pop-up menu.



Wire Frame

The model appears as a framework of wires.



Wire Frame with Depth Cueing

The model appears as a framework of wires. Wires that are distant appear fainter than those that are close.



Anti-aliased Wire Frame

The model appears as a framework of anti-aliased wires.



Anti-aliased Wire Frame with Depth Cueing

The model appears as a framework of anti-aliased wires. Wires that are distant appear fainter than those that
are close.



Fully Textured Rendering

The model appears rendered with all surface maps. This is a computation-intensive display mode. Updating
and tracking will be slower. Some systems might not be fast enough to work comfortably in this mode.



Shaded Non-Textured Rendering

The model appears with solid surfaces, but no surface maps.



New Model Rounding Factor

The rounding factor lets you add a degree of convexity or concavity to flat faces of the Detailer primitives
you create.

The valid range for rounding is -1 to 1. When the rounding factor is zero, models have perfectly flat faces.
Negative values make the flat faces appear slightly concave.

Positive values make the faces appear convex.



Background Color

The color of the Model Window Background is displayed on screen and in the final rendering. Sometimes a
light-colored object is easier to view on a dark background and vice-versa.

To change the window background color:
1 click the Background Color swatch. Detailer opens the system color picker

2 Choose a color for the window background. Model renderings will use this background color.



Mesh Color

The mesh is an optional overlay of mapping vertices on image files. The mesh makes it easier to paint on
map image files. Its color should contrast the colors in the map image, so the mesh is easier to see.

To change the mesh color:
1 Click the Mesh Color swatch. Detailer opens the system color picker.

2 Choose a color for the mesh.



Ray Dream Compatible

Detailer allows you to use a different mapping mode for each map type; however, this is rarely practical.
Usually, you’ll want all maps applied to an object to use the same mapping mode. This is a requirement for
detailed models you intend to export to Ray Dream Designer.

If you want all maps to use the same mapping mode, enable the Ray Dream Designer Compatible option.

When Ray Dream Compatible is enabled, you’ll set mapping options for the first map you apply to a model.
Detailer will automatically assign this mapping mode to all subsequent maps.

If you then change the mapping mode for one map, Detailer will update all maps to the new mode.

If you intend to export your Detailer model to Ray Dream Designer or Studio, enable the Ray Dream
Compatible preference before applying the second and successive maps. When exporting a model avoid
saving your image map files in RIFF format. We recommend you save your files in TIFF format.




Setting Pressure Sensitivity

When you draw with Natural-Media, the amount of pressure you use with a tool determines how dense and
how wide your strokes are. Using a pressure-sensitive stylus with Detailer gives you this same kind of
flexibility. Each artist bears down on a drawing or painting tool differently. In Detailer, you can program the
computer to react to your individual touch just by dragging in the Brush Tracking dialog box.

To display the Brush Tracking dialog box, choose Edit menu> Preferences> Brush Tracking.

To set how sensitive the stylus will be to your hand pressure and speed, move the stylus across the scratch
pad area at a normal speed and with a normal amount of pressure.

Just as your signature varies, so will the way you work with the stylus at any given time, so you’ll set
upBrush Tracking each time you start Detailer. When you exit Detailer, the Brush Tracking sliders go back to
their default settings.



Customizing the Interface

Fractal Design has chosen colors and textures for Detailer’s interface that we think are aesthetically pleasing
and very legible. However, you may want to experiment with your own interface colors and textures.

To change Detailer’s interface, choose Edit menu> Preferences> Interface. The Interface Preferences dialog
box appears.

To change the icon selection color:
1 Using the Materials: Color palette or the Dropper tool, choose the color you wish to use.

2 Click the Use Current Color button under Icon Selection Color. The selection box changes to the currently
selected color. This color is used until you change it again.

To change the shadows under palette icons:

1 Enter new values in the boxes under Rectangular Shadows.

The X-Offset moves the shadow horizontally, and the Y-Offset moves the shadow vertically. Softness refers to
the amount of feathering the shadow has.

2 After entering the values, click Done. Watch an icon as its shadow changes. Repeat the procedure with
different values if you aren’t happy with the changes.

To change the rectangular pillowing:

1 Enter new values in the boxes under Rectangular Pillowing.

Rectangular pillowing refers to the shadows beneath sliders and rectangular items in palettes other than
icons. The X-Offset moves the shadow horizontally, and the Y-Offset moves the shadow vertically. Softness
refers to the amount offeathering the shadowing has.

2 After entering the values, click Done. Watch the palette shadows change. Repeat the procedure with
different values if you aren’t happy with the changes.

To change the palette background texture:

1 Choose the texture you wish to use in the Texture palette.

2 Choose Edit menu> Preferences> Interface. In the Interface Preferences dialog box, under Palette
Background Texture, click in grayscale if you wish the texture to be rendered in grayscale; click in current
colors if you wish the texture to be rendered in the current primary and secondary colors.

3 Click the Use Current Texture button.

4 Click Done. Your palette background texture changes.

To use the current pattern as the palette background texture:

1 Choose one of the default patterns or use the Rectangular Selection tool to select part of an image to
capture as a pattern. Choose Materials palette: Patterns menu> Capture Pattern.

2 Return to the preferences dialog and click the Use Current Pattern button. The palettes will update so you can
preview your choice.

3 Click Done. Your palette background texture changes to the current pattern.

To change the drawer bottom texture, follow the steps above, but use the buttons under Drawer Bottom
Texture.

To change the window background color:
1 set the current color using the Materials: Colors palette or Dropper tool.

2 Click the Use Current Color button under Window Background Color. The background is filled with the
current color.

When in current colors is selected in the Interface Preferences, Detailer uses the primary and secondary
colors from the Materials: Color palette to customize interface elements. Experiment with two colors for




interesting effects.

You may save your interface preferences by clicking the Save button in the bottom right of the Interface
Preferences dialog box. A standard save dialog appears asking you to name the interface setting. Give it a
descriptive name and click Save.

To load a saved interface set:
1 click the Load button.
2 Choose the interface set from the directory box that appears.

3 Click Open to load the interface set.

To return to Detailer’s default interface:
1 Click the Use Defaults button at the bottom of the palette.

2 Click Done. Detailer reverts to the default interface.



Setting Multiple Undo Levels

Multiple Undo allows you to undo and redo up to 32 levels of changes. The number of undo levels is set in
Undo Preferences, found under Edit menu> Preferences> Undo. Five levels are set as a default.

Undo levels apply across open documents. With five levels set, if you have two documents open and you
have “undone” three operations on the first document, you can only undo two operations on the second.

Multiple Undo can use a significant amount of disk space. If you perform multiple operations on the entire
image, the whole image must be saved for each undo step. So be careful with the number of Undo levels you
choose to save.



Preferences for Windows
Choose Edit menu> Preferences> Windows to display memory and printing options.
See also:

Physical Memory Usage

Printing Options

Display Option



Physical Memory Usage

For best performance, choose Maximum Memory for Detailer and run Detailer with no other programs
running in the background. Choosing Half Memory for Detailer will allow Detailer to run more efficiently with
other Windows applications running at the same time.



Printing Options

Free Memory for Printing will increase printing speed by writing the active image to disk, increasing the
amount of memory available for the print manager and the printer driver.

No Print Banding disables print banding for devices that support it. Disabling print banding may help some
PostScript printers, but will hurt the performance of some bitmap printers, such as the Hewlett-Packard
DeskJet printers. Most dot matrix printers will be faster with No Print Banding left unchecked in the dialog
box. If you experience problems printing in landscape orientation, you may have to turn off banding by
checking the radio button in the dialog box.



Display Option

If your video display driver is set to 32,000 colors, you may experience some color irregularities on your
screen when using Detailer. Checking No Device Dependent Bitmaps will correct this problem with most
32,000-color video displays. If you are not using 32,000 colors, this checkbox will have no effect on your
system.



Detailer Basics

See also:
How Detailer Works

Working in the Model Window
Objects and Maps

Rendering an Image
Saving and Quittin




How Detailer Works

Detailer takes two-dimensional images and wraps them onto the model in a process called mapping. The
images develop the surface of the model. Depending on the images and settings you use, the model can
become wood, metal, stone, plastic, even skin.

When you work in Detailer, you’ll open a model, select an object, and apply images as surface maps. You’ll
set lights, and ultimately create a rendering of the finished model. You may export your finished model for
use in another 3D program.

See also:
Models

Objects
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Map Image Files
Mapping Methods
Lighting
Rendering



Models

You have several options for generating and importing models, including creating primitives in Detailer and
opening 3D files created in Fractal Design Ray Dream Designer.

When you open a model, Detailer displays the 3D View of it in the Model Window. You can rotate your view of
the model, zoom in, and move the model in the window.



Objects

Models may be comprised of up to 240 separate objects. Each object may have completely different colors
and surface characteristics.

When your model has several objects in it, you’ll select the object you want to detail.

If you want to apply maps to more than one object simultaneously, you will have to combine the objects into
one with a modeling application like Fractal Design Ray Dream Designer.




Maps

When you’ve selected an object, you’ll apply one or more two-dimensional images to its surface. Detailer
maps these 2D images onto the 3D object to give it color, surface relief, and control the interaction with
light.

For each object in the model, you may load one image for each of five map types, or leave any channel
empty. The five map types are as follows:

Texture Map

The Texture Map adds color.

Bump Map

The Bump Map creates surface relief (physical texture).
Highlight Mask

The Highlight Mask controls the highlight in different areas. Dark areas of the mask reduce the highlight.
Using black and white, and shades of gray, you can specify which areas on a surface are shiny or matte.

Reflection Mask
The Reflection Mask controls the reflection in different areas. Dark areas of the mask reduce the reflection.
Glow Map

The Glow Map applies additional color after the other maps have been applied. The glow map is useful for
describing objects that emit light such as lamps or LEDs.



Map Image Files

When you apply a map, Detailer opens the map image in a window. You can see the 2D map image file and
work in this window. When you save the model, you’ll save all of these image files along with it.

The effect of the maps you apply appear immediately on the surface of the object in the Model Window. That
is, when you apply a texture map, the imagery in the map appears immediately on the 3D object. Any
changes you make in the map image file, like painting brush strokes, appear immediately on the object.

You may develop imagery working in the 2D image window, or you may paint directly on the object. In either
case, only one map image file is active for editing at a time. You must specify which map you want to “paint
into” to make changes. You do this on the Materials: Object palette or by activating the image’s window.



Mapping Methods

Detailer offers several methods for mapping the 2D image onto the 3D object. Each method is suited for
objects of different shape. The mapping mode you choose, and how you design the imagery, makes a huge
difference in how the map appears on the object.



Lighting

Several of the surface effects depend on light. Detailer’s Light tool and the Materials: Light palette makes it
easy to shine lights on your model. You can color or dim the lights to light the object just how you want it.



Rendering

When you’re satisfied with the maps you’ve applied, the light and other settings, you can render the image
at higher resolution. The rendering can be a larger, anti-aliased version of what you see in the Model Window.
The rendering includes a mask of the model, so compositing with other images is clean and easy. You can
composite images directly in Detailer or in a 2D application like Fractal Design Painter.



Working in the Model Window

The Model Window shows a 3D view of the model you are working on. When you’re adding detail to a model,
you’ll want to keep the area you’re painting centered in the window, at a reasonable scale, and square to
your view.

Detailer provides three navigation tools that make it easy to view and paint on any surface of the model—the
Virtual Trackball, the Magnifier and the Grabber.

Key shortcuts let you temporarily switch to the navigation tools.
To switch to Virtual Trackball, choose Option-Spacebar for Macintosh, Spacebar+Alt for Windows.

To zoom-in: Command-Spacebar for Macintosh, Spacebar+Ctrl for Windows.

To zoom-out: Command-Option-Spacebar for Macintosh, Spacebar+Ctrl+Alt for Windows.

To switch to the Grabber, hold down the Spacebar.

Note: The Macintosh System has a keyboard option for cycling through different keyboard layouts. You’ll want
to make sure this is disabled before zooming out—otherwise your keyboard might start acting funny. Choose
Apple menu> Control Panels> Keyboard. In the dialog, make sure the Command-Option-Spacebar feature is

disabled.

See also:

Using the  Virtual Trackball

Rotation on Axis

Controlled Rotation

Magnifying your Subject

Magnification Pop-up Menu

Using the Grabber tool to Pan the Model Window
Changing the Size of the Model Window

Setting the Model Window Background Color
Importing a  Background Image

Clearing and Showing the Background Image




Using the Virtual Trackball

You can view the model from any angle by rotating your view. Viewing from a particular angle helps when
you’re painting. It’s much easier to work when you’re facing the surface you’re painting. Trying to paint
oblique surfaces (on the side or edge of an object) can be difficult.

To change the 3D view:
1 choose the Virtual Trackball tool.

2 In the Model Window, drag to rotate your view of the model.

In the model space, the model doesn’t move. The model is fixed with respect to the lights. When you use the
Virtual Trackball, you’re changing your view of the model. That is, the model stays in one place and you
move around it. You may want to adjust lighting after rotating your view.

With the model starting in this position, the following diagrams show the path you would drag to rotate the
view as shown.



Rotation on Axis
Rotation on the X Axis
Drag down from the center of the window to view from above.
Rotation on the Y Axis
Drag left or right from the center of the window to view from the other side.
Rotation on the Z Axis
Drag in a circle from a corner of the window to change which side is up.
Rotation on Several Axes
Drag at an angle to compound rotation.

If you move around the model, you might find an area that is dark. This is because there is no light shining
from that side. You could add a light to shine there, you could increase ambient light, or enable the Flat
Lighting option in the Materials: Light palette.

See also:

Using Light



Controlled Rotation

When the Virtual Trackball is selected, the Controls palette provides sliders for rotating the view on the X, Y
and Z axes. The x axis runs horizontally. The y axis runs vertically. The z axis runs perpendicular to the plane
of your monitor screen.

Drag the slider for the direction you want to rotate the view.

The direct view of the north pole, in the model space, is 0j, 0j, 0j. A direct view of the front would be 90j, 0j,
0j.



Magnifying your Subject

The Magnifier works in image windows and in the Model Window.

To zoom in:
1 Choose the Magnifier tool.

2 Click on the area you want to view closer. You can also drag a marquee around the area you want to
magnify. Detailer zooms to the highest level that will display the full area of the marquee.

To move back and get a larger view:
1 Hold down the Option key for Macintosh or Alt for Windows.

2 Click in the window.



Magnification Pop-up Menu

When in an image window, the Controls palette: Magnifier tool provides a pop-up with a set of
magnification factors. Select the level you want and Detailer immediately sets the magnification to that
level.



Using the Grabber tool to Pan the Model Window

Use the Grabber tool to center the area you’re working on in the window. The Grabber works in the Model
Window and in image windows.

To pan the Model Window:
1 choose the Grabber tool.

2 Drag the model (or image) to view the area you want.



Changing the Size of the Model Window

You can change the size of the Model Window at any time.

To change the size of the Model Window:

1 Choose Window menu> Set 3D View Size. Detailer displays a dialog that allows you to set the size of the
Model Window.

2 Enter width and height values (in pixels) for the size Model Window you want.

The dialog shows how much RAM is required for the window specified. A larger window may be more
comfortable to work in, but requires more RAM. The bigger the window, the longer it takes to display. A large
window might not be possible on your system.

3 Click OK, Detailer sets the Model Window to the new size.

Don’t set a Model Window that requires more RAM than your system has available. Between 200 and 300
pixels square is a good size for most systems.




Setting the Model Window Background Color

You can choose a color for the background of the Model Window. You might want to use a dark background
with a light colored image and vice-versa.

If you are creating a 2D collage of several renderings, you will want to set the background color accordingly.

To change the background color:

1 Choose Edit menu> Preferences> Model. Detailer displays the Model Preferences dialog.

The other model preferences are described at the end of Getting Acquainted with Detailer.

2 Click the swatch for Background Color. Detailer opens the system color picker so you can choose a color for
the window background.



Importing a Background Image

Detailer lets you import an image as the background of the Model Window. You can use the image in the
rendering of the finished model. This enables you to adjust the surface maps, lighting, and view of your
model to match the imagery in the scene.

When you render the 3D view, the background is included in the image.

To import a background:

1 open the model you are working on.

2 Choose File menu> Import> Background. Detailer displays a dialog that allows you to locate and open the
file you want to use.

The file may be in certain image formats that Detailer supports: RIFF, TIFF, PICT, Photoshop 2.0 and 3.0, BMP,
PCX, TARGA, and JPEG.

The background will appear in the Model Window, aligned at the top, left corner.

If the background image is larger than the Model Window, only the upper left region will be visible. If this
does not work out for you, create a new image that is either scaled or cropped to the region you want.

If the background image is smaller than the Model Window, the image will be repeated (tiled) to cover the
area.

The background image file cannot be edited while it is associated with the model. If you need to edit the
background image, you’ll need to import it again.

If you need to edit the background image, it can be opened in Detailer as a 2D image. You can apply paint
and effects, save it and close it. Then it may be imported as a background again.




Clearing and Showing the Background Image

You might want to temporarily remove the background image. Perhaps you find the image a distraction to
your painting or you want to render without it.

To clear the background image:
1 Bring the Model Window to the front.

2 Choose Window menu> Clear Background. Detailer sets the window to display the background color.

To show the background image:
1 Bring the Model Window to the front.

2 Choose Window menu> Show Background. Detailer sets the window to display the background image.



Objects and Maps

A Detailer model may be constructed of up to 240 separate objects. Each object may have a unique set of
maps applied to it. When you work with a multi-object model, you need to select which object you want to
detail.

To select an object:

1 choose the Object Selection tool.

2 In the Model Window, click on the object you want. The selected object appears outlined in the 3D view.

In @ model comprised of a single object, like Detailer’s own primitives, that object is automatically selected.




The Object Palette

All of the features for applying and controlling maps are found on the Map menu and on the Materials: Object
palette. The features appear in both places to give you a choice of how to work.

Using Maps describes all of the features for applying maps to objects.

The Object palette lists the five map types that may be applied to the object: Texture, Bump, Highlight,
Reflection, and Glow.

When you select an object, the Object palette updates to show the settings and maps (if maps are loaded for
this object).

In each map type listing, you will see two icons to the left of the map type, and the name of the map file to
the right. The “X X” beside a map type listing indicates that this object does not have a map of this type
loaded.

The Eye and Pencil icons indicate that this object does have a map of this type. The map file name appears
on the right of the listing.

The Eye icon controls whether this map is displayed on the object. When the Eye is open, the map is
rendered to the object in the Model Window. When the Eye is shut, this map is not applied. You can click the
Eye to open and close it.

The Pencil icon controls which map is active for editing. Only one map can be edited at a time. The Pencil
icon for the active map is clear—the other Pencil icons have a red slash over them.

Clicking once on the Pencil icon (next to the map type in the Objects palette) brings the map to the front so
you can paint in it.

This has the same function as choosing Map menu> Paint Into> and selecting the map you want to work on.




Rendering an Image

You can render the 3D view of your model to a separate image at any time. The rendering you create will be
a high resolution version of what you see in the Model Window. The rendering includes a mask, which makes
it easy to composite it with other images.

Detailer’s rendering camera does not create perspective views of the model. If you want a true perspective
effect, you can export your Detailer model to Fractal Design Ray Dream Designer or another 3D program.

See also:

Render to Image
Using Renderings in Detailer



Render to Image

Rendering settings are found in the Render to Image dialog.

To render the 3D view:

1 Before rendering, use the Virtual Trackball, Magnifier, and Grabber to set the view of the model. Set the
lights how you want them.

2 Choose File menu> Render to Image. Detailer displays a dialog that lets you set rendering options.

3 Enter width and height values (in pixels) for the rendering resolution you want.

The values you enter should conform to the aspect ratio of the Model Window. Values that describe a
different aspect can lead to unexpected results in the rendering.

4 set your anti-aliasing options.

If you intend to composite the model with other images, you want to use the Anti-alias Mask option and not
the Anti-alias Image option.

Anti-alias Image: when this option is enabled, pixels at the edge of the model are faded to the background
color. Anti-aliasing the image creates a softer edge.

Use this option if you intend to use the rendering as a complete image.
Anti-aliased images take significantly longer to render.

Anti-alias Mask: when this option is enabled, mask pixels at the edge of the model’s shape are given
intermediate density values.

Use this option (and disable Anti-alias Image) if you intend to composite the model with other images.

In Fractal Design Detailer, when you convert the masked area to a selection and float it, the image pixels at
the edge of the object will be semi-transparent. Their level of opacity is directly proportional to the density of
the corresponding mask pixels.

When you move this floater over other imagery, some portion of the background colors will be visible
through the semi-transparent pixels at the edge of the floater. This gives the floating image a nice, soft edge
for compositing.

If you will be using your rendering as a finished image, choose to anti-alias the image but not the mask. If
you are going to turn your rendering into a floater or layer, choose the anti-alias the mask, but not the
image.

5when you click OK, Detailer renders the image. Rendering can take some time, depending on the
resolution you requested and the speed of your system. When the rendering is ready, Detailer opens it in a
new image window.

If you like the results, save the image file. If the rendering isn’t what you expected, close the window without
saving changes. Adjust your model, maps, or lights and render again.

Not all formats maintain the mask information. Save in RIFF, TIFF or Photoshop formats to maintain the mask
information.

Look in Appendix B, “Using Detailer with Other Programs,” for tips on compositing your rendering with other
images in Fractal Design Painter.




Using Renderings in Detailer

Often youw’ll want to composite the image of the rendered model with other imagery. The mask Detailer
creates in the rendering makes compositing easy.

To composite your renderings in Detailer:

1 Open the saved rendering in Detailer.

The rendering must be saved in a format that retains the mask (RIFF, TIFF, or
Photoshop formats).

2 Set the Visibility mode to Show Selection. The selection marquee appears around the model shape.
3 Choose Edit menu> Copy.

4 You can now move to another file and paste the selection. The selection is pasted as a floater.
See also:

Floaters



Saving and Quitting

A model that you have detailed may have up to five maps for each object. If the model is comprised of a
number of objects, there may be quite a few image files used for this one model. You’ll need to save all these
image files with the model.

When you select the Save command, Detailer applies it to the foremost window.
When an image window is active, Detailer saves that image.

When the Model Window is in front, Detailer saves the model. If any map images have not been saved,
Detailer requires you to save them before saving the model file. When you save the model, Detailer prompts
you to save any unsaved maps associated with the model.

Map image windows must remain open while you are working with the model. If you close a map image
window, that map becomes dissociated from the model.




Working with Models
See also:
Obtaining Models
The Model in Detailer




Obtaining Models

Detailer lets you paint and develop surfaces on three-dimensional models. To do this, you’ll need to create a
model in Detailer. You may also open or import a saved model file.

A Detailer model is a file comprised of one or more 3D objects. The model may have up to 240 objects, and
each object may have a different set of surface maps and properties. For example, a wooden handle,
corkscrew, and the cork it’s stuck in are three separate objects, but may be grouped as a single model.

Detailer has an engine for creating primitive objects. Detailer also comes with a catalog of interesting models
you can work with. Some artists will import models they’ve created in a 3D modeling program, like Fractal
Design Ray Dream Designer.

See also:

Creating a Detailer Primitive

Opening Saved Models

Importing Models




Creating a Detailer Primitive

Detailer primitive models are single objects.

To create a primitive:

1 choose File menu> New Model. Detailer displays a dialog that lets you choose the model type.

2 Use the pop-up to choose the model you want: Box, Cylinder, Cone, Sphere, or Cup.

3 After choosing a primitive, click OK. Detailer prompts you to select options for the selected primitive

model.

Dimensions. Enter dimensions that describe the size of the model you want. The dimensions required depend
on the model type.

Tolerance: Detailer models are constructed of triangular faces. The Tolerance setting allows you to control the
number of triangles used to approximate curved surfaces in the model.

e The Coarse setting creates the fewest triangles. You may see irregularities in renderings.
® The Medium setting creates more triangles than the Coarse setting, but not as many as Fine.
* The Fine setting creates the most triangles, which assures a clean image.

More triangles increase memory demands and may slow down some operations. See Appendix C,
“Qptimizing Memory Usage,” for information about dealing with memory limitations.

4 pfter exploring the options, click OK to confirm the model settings. Detailer prompts you to choose a size
for the 3D View or Model Window.

5 Enter width and height values for the size Model Window you want. You can get closer to the model by
zooming in with the Magnifier tool, so a large window may not be necessary.

The dialog shows how much RAM is required for the window specified. The 3D view or Model Window requires
52 bytes per pixel. A larger window may be more comfortable to work in, but requires more RAM. Larger
model windows update slower on screen. A large window might not be possible on your system.

Don’t set a Model Window that requires more RAM than your system has available. See Appendix C,
“Optimizing Memory Usage,” for information on optimizing Detailer for the level of RAM in your system. See
your Detailer Quickstart Guide for information about setting the application memory.

6 Click OK to set the Model Window size. Detailer opens the model in the 3D View or Model Window.



Opening Saved Models

Models you save in Detailer will be in Detailer format. The catalog of models on the Detailer CD are all in
Detailer format. You can also export models you create in Ray Dream Designer in Detailer format.

To open a Detailer model:

1 choose File menu> Open. Detailer displays a dialog asking you to choose between Model and Image
files.

2 Choose Model and click OK. Detailer displays a dialog that asks you to locate and select a saved Detailer
model.

3if you are opening an Detailer model exported from Ray Dream Designer, for the first time, Detailer
prompts you to choose a size for the 3D View or Model Window. Enter width and height values for the size
Model Window you want.

Detailer will open all maps and images associated with this model. However, if a file has been moved or
renamed, Detailer won’t be able to load it. In this case, Detailer displays a dialog giving you a chance to
locate the missing file. If you cancel the dialog without selecting an image, Detailer opens the model without
a map, background, or reflection environment.

See also:

Opening Models Created in Ray Dream Designer



Opening Models Created in Ray Dream Designer

You can create your own models in Ray Dream Designer or Ray Dream Studio and open them in Detailer.
Before you can open them, you must export them from Ray Dream Designer or Studio in Detailer format. The
export feature is a program extension for Ray Dream Designer 4.1.2, or later.

This extension is a pair of files (“Detailer” and “DETAILER.DTA”) that are part of the Detailer installation in a
folder called “For Ray Dream Designer.” You’ll need to copy these files to the Ray Dream Designer Extensions
folder.

To export a model from Ray Dream Designer in Detailer format:

1in Ray Dream Designer 4.1.2, select the object or object group you want.

You may select the Universe group to export the entire scene (lights and
cameras are not exported).

A group may have no more than approximately 80 objects in it.

Because end caps on extruded geometries are individually treated as separate objects, a group may have no
more than approximately 80 objects in it. With two end caps each, that would amount to approximately 240
objects in Detailer. Some objects may have no end caps and others may have multiple caps on each end
(depending on the geometry), that’s why these numbers are approximations.

2 Choose File menu> Export. The program displays a dialog that lets you select the export type, file name,
and save location.

3 Choose Detailer from the Format pop-up. Enter a file name and select a folder on your disk.
Note: If “Detailer” does not appear in the list, you haven’t copied the export extensions to the correct folder.
See also:
Setting up Ray Dream Designer to Export Detailer Models
4t you want to change your export options, click Options.

The options give you control over several model characteristics, including the number of objects created.
Your mapping capabilities (and your ability to import the work you do in Detailer back into Designer) may
depend on your export option choices. You’ll find complete descriptions of the Export Options in Appendix B,
“Using Detailer with Other Programs.”

5 After closing the Options dialog, click OK. The program creates the Detailer model file.

You can now open the model in Detailer.



Importing Models

Detailer lets you import models saved in 3DMF (Macintosh version only) and 3D Studio (Windows version
only).

To import a model:
1 choose File menu> Import and select the format of the file you want to import.

2 Use the import dialog to locate and select the file. Click OK.

Once imported, the model appears as any Detailer model. When you save the model in Detailer, you will be
saving it in the Detailer format. If you want to move the file back to your 3D modeling and rendering
program, you’ll need to export it from Detailer.



The Model in Detailer
See also:Selecting an Object within aMulti-object Model
Getting Technical Information
Setting Object Base Color
Setting Object Properties
Saving a Detailer Model

Closing a _Model
Exporting Models




Selecting an Object within aMulti-object Model

A Detailer model may be constructed of up to approximately 240 separate objects. Each object may have a
unique set of maps applied to it.

When you work with a multi-object model, you need to select which object you want to work on.

When a model is comprised of a single object, like Detailer’s own primitives, that object is automatically
selected.

If you try and paint on an object that isn’t selected, Detailer will ask you if you want to select it. If you click
Yes, and you have already applied maps to the object, Detailer will ask you if you want to paint in the first
map it finds. If you click Yes and you do not have any maps applied to the object, Detailer will ask you if you
would like to create a Blank map or one based on a pattern or texture.

To select an object:

1 Choose the Object Selection tool.

2 In the Model Window, click on the object you want. The selected object appears outlined in the Model
Window.

When you select an object, the Materials: Objects palette updates to show the settings and maps, if any are
loaded for this object.

The Controls palette: Object Selection tool displays technical information describing the selected object.

The minX, minY, and minZ and maxX, maxY, and maxZ describe the dimensions of the bounding box of this
object. The bounding box is the smallest box that will enclose the object completely.

The Controls palette also gives the number of triangles in the surface mesh.

See also:



Getting Technical Information

You can get technical information for points on the object.

To obtain 3D information:

1 Choose the Object Selection tool.

2 Hold down the Control key (Macintosh), Shift+Ctrl keys (Windows), and click on a point of interest on the
model.

Detailer displays an Object Report, describing that point on the model, its normal vector, and correlation to
the texture map. Some 3D artists might find this information useful.



Setting Object Base Color
You may color an object without applying a texture map.

Setting a base color doesn’t make sense if you intend to apply a texture map. The texture map hides the
base color completely. However, if you want the object to have a single, flat color, you can set its base color.
This is useful when you have a multi-object model and you only want to create texture maps for a few
objects.

To give the model a base color:

1 select the object you want to color.

2 Display the Materials palette.

3 Choose Materials palette: Object menu> Set Object Color.

Detailer displays the system color picker. Select a color for the object and click OK.

To set the base color of an object using the Dropper tool:
1 Use the Materials: Color palette to choose a color.
2 Select the Dropper tool.

3 Hold down the Option key (Macintosh), Alt key (Windows), and click the object you want to color.

To give all objects in a multi-object model the same color:
1 choose Materials palette: Object menu> Set All Objects Colors. Detailer displays the system color picker.

2 Select a color and click OK. Detailer will apply the color you select to all objects in the model.



Setting Object Properties

The Object palette provides controls for an object’s basic shading properties. These properties control how
the object appears under the lights. Particular settings help describe the object’s substance—whether it is
glass, metal, cork, skin, or whatever.

Select the object whose properties you want to adjust. Drag the Diffuse, Specular, and Reflection sliders to
set levels appropriate to your object’s surface.

See also:
Diffuse

Specular
Reflection



Diffuse

The Diffuse slider controls how much base color the object shows.



Specular

The Specular slider controls the object’s tendency to show highlights. Highlights are the bright spots and
streaks that appear on an object where light is reflected directly.

You can control specularity in regions of the object with the highlight mask.



Reflection

The Reflection slider controls the object’s tendency to reflect its environment. Moving the Reflection slider
to the right allows more of the environment image to appear reflected in the object.

You can control reflection in regions of the object with the reflection mask.

Reflection is useful when a good reflection map is loaded as the environment. If you do not have an image,
Detailer will use the current pattern.

See also:Using an Environment Map for Reflection

The settings below offer recipes for achieving different surfaces:
Material  Diffuse  Specular Reflection

Chalk 100% 0% 0%

Obsidian 0% 100% 0%

Mirror 100% 100% 100%

Plastic 60% 40% 0%




Saving a Detailer Model

After developing the surface of your model, save your work. You’ll be able to open the model later and
continue working. Saved models include settings for object properties, lights, and all references to applied
maps, the background, and environment.

A finished Detailer model consists of several files—the 3D model itself and each image file used as a map,
environment, or background. For the sake of organization, it’s a good idea to keep your model with its image
files in a new directory/folder.

To save a Detailer model:

1 Bring the Model Window to the front. You can click in the window or select its listing from the Window
menu. Model Windows appear at the bottom of the menu.

2 Choose File menu> Save.

If your model has maps associated with it that have not been saved, Detailer requires you to save them now.
Detailer will display a Save Image dialog for each image that has not already been saved.

Stay organized! Create a directory/folder named appropriately for this model and save all images associated
with the model to this folder.

3 save the map files to the same location. Name each file accordingly.

If you use floaters in your image and want to preserve them as independent floating objects, you must save
in either the RIFF or Photoshop 3 file formats. To keep file size to a minimum, use the RIFF file format. If you
intend to export your model, use the TIFF file format.

4 when all images have been saved, Detailer opens a Save dialog for the model. In the Save dialog, enter a
name for your model and click OK.



Closinga Model

The windows of the map images must remain open to stay connected with the model. This means you should
close the Model Window first. Then Detailer can close the image files.

To close a Detailer model:

1 Bring the Model Window to the front.

2 Click the window’s close box, or choose File menu> Close. If you haven’t saved the model, Detailer will

alert you and give you a chance to do so. Detailer will close each map file as well, alerting you to save if
necessary.



Exporting Models

Detailer is a powerful tool for developing surfaces on 3D models. Detailer lets you render a model, but many
artists will want to move their finished models to a full featured 3D program, like Fractal Design Ray Dream
Designer, for assembling in a 3D scene and rendering.

Ray Dream Designer/Studio offers features that Detailer doesn’t, including:
® You can create a scene with numerous models.

* You can develop sophisticated lighting and rendering effects, like shadows, luminous objects, and
translucence.

* You can achieve different perspective effects with an adjustable camera.
® You can create animations in Studio.

These are only a few of the benefits you get from moving your Detailer models to a scene-building and
rendering program like Ray Dream Designer or Studio.

Ray Dream Designer and Studio can import models saved in Detailer format. The model retains its surface
properties and all of the maps applied to it. When you import the model in Ray Dream Designer, all of your
details, including the alignment of the maps, will be intact.

For models created in Ray Dream Designer, you have the option of importing just the maps and shading from
Detailer. Designer automatically applies the maps to the existing model objects.

See Appendix B, “Using Detailer with Other Programs,” for more information on importing Detailer models in
Designer. Additional information may be in the ReadMe file in the Detailer folder and at our web site,
www.fractal.com.

Several aspects of the Detailer model might not apply when you move to a separate 3D program. The
background image, reflection environment, and the lights are discarded. You’ll want to develop these aspects
of the scene in your 3D scene-building program.

Detailer can export models in several formats.
® QuickDraw 3D, also known as 3DMF (Macintosh only)
* 3D Studio (Windows only)

To export a Detailer model:

1 Open the model you want to export.

2 Choose File menu> Export and select the format you want to use.

3The program displays a dialog that lets you name the file and choose a save location.

4 Click OK. The program creates the exported model file.
You can now import the model to your other 3D program.

Fractal Design Detailer has an extensible architecture for 3D file formats. Plug-ins for import/export in other
3D formats may become available. Visit www.fractal.com for updated information.

See also:

Using the Text File for __Exporting




Using the Text File for Exporting

The File menu> Export> Text feature creates a text file describing the properties, maps, and adjustments
you’ve made to the maps in Detailer.

In a program that doesn’t open the exported model file correctly, you might be able to enter the settings
from the text file to reconstruct your Detailer surfaces on the model.

Detailer can also import this text file. You might be able to edit properties numerically in a word processing
program, then import the edited text file. For example, you may want to edit the center of projection for an
object’s map.



Using Maps

See also:
Creating Surfaces on the Model
Applying Maps

Working in the Maps and Painting on the Model

Using an Environment Map for Reflection




Creating Surfaces on the Model

A model is a 3D file made up of one or more objects, and each object may have different shading. The
combination of applied maps give an object its overall shading. Shading is the set of characteristics that give
an object its appearance—color, surface texture (bump), shininess, and so on. Shading is apparent when the
object is rendered.

For example, a model of a cork screw and cork might be constructed of three objects—the cork, the screw,
and the cork screw handle. Each of these objects will have a different set of maps and surface properties that
describe its material—cork, chrome, and wood, respectively.

See also:

About the Five Maps

About Imagery in the Different Maps




About the Five Maps

In Detailer you’ll color and texture objects by wrapping them with two-dimensional images, called maps.
You’ll create up to five maps for each object to describe its surface attributes.

You’ll apply a single 2D image for each of the five map channels. Of course, you may leave one or more
channels empty.

The Materials: Object palette lists the maps for the selected object.
See also:

Texture Map

Bump Map

Highlight Mask

Reflection Mask

Glow Map



Texture Map

The texture map gives the object color. For example, a pattern of red bricks mapped onto a box-shaped
object turns the box into a chimney.

The texture map adds color, not physical texture. This might be confusing at first, but it’s the standard 3D
graphics term for this map type.




Bump Map

The bump map creates surface relief, like the rough terrain of tree bark. The bump map may be a grayscale
image. When the program renders the object, the bump map deflects the light (in the model space)
according to its imagery (light and dark features). Bright areas of the bump map appear recessed in the
rendering and dark areas appear raised.

You can invert the map with the Negative Polarity option on the Object palette.

It is important to note that the actual shape of the object doesn’t change—only the appearance of the
rendered surface. The silhouette edges of the object will not be affected by the bump map.

The bump effect is created by the interaction of light and the bump map. Different lighting conditions change
the appearance of the bump.

See also:

Light Reveals the Third Dimension

Continuing the chimney example: With the same brick image in the bump map, you can create the
appearance of recessed mortar lines between the bricks.

In the model of a face, you can use the bump map to add wrinkles, crinkles, moles, dimples and scars.
After loading a Bump Map, you can adjust the level of bump.

At the bottom of the Object palette, the Bump Map Adjustment: Amount slider lets you control the height and
depth of the bump features.

Dragging the slider to the right increases bump depth.
Enabling Negative Polarity inverts the bump map.

Detailer renders the new bump settings to the Model Window, so you’ll get immediate feedback on your
depth adjustment.



Highlight Mask

The highlight mask controls the amount of specularity (shininess) for different areas of the object. Highlights
are the bright spots on an object where the light is reflected directly.

The object has an overall highlight amount, set with the Specular slider on the Materials: Object palette.
The highlight mask lets you control the highlight amount (reduce the setting) for specific areas on the object.

For example, you’re developing a model of a wine bottle. The texture map places a rectangular label on the
bottle. The object will have strong highlight on the glass, but much less on the paper label. In the highlight

mask image, a dark rectangle that matches the size and position of the label in the texture map will reduce
the highlight on the paper label.



Reflection Mask

The reflection mask controls the amount of reflection for different areas of the object. Reflectivity is only
interesting when the environment (the object’s surroundings) appears in the reflection. In Detailer, you’ll
load a separate image to be reflected as the environment.

The object has an overall reflection amount, set with the Reflection slider on the Materials: Object palette.

The reflection mask lets you control the amount of reflection (reduce the setting) for specific areas on the
object.

Continuing the wine bottle example: The glass bottle should be reflective, but not the paper label. In the
reflection mask image, a black rectangle that matches the size and position of the color label will eliminate
reflection in the area covered by the paper label.



Glow Map

The glow map applies additional color on top of the other shader effects. Glow is a special effect you might
find useful, particularly for objects like light bulbs, LEDs and CRTs which actually produce light. For example,
a red LED on a control panel looks red, even when there are no other lights in the scene. A little airbrushing

of color in the right spot of the glow map would help you create this effect—without interfering with your
texture map.

Detailer applies the glow map after the other maps. This means that an area darkened by other shading
effects will receive uniform color from the glow map.

The glow map applies color to the object. It does not create a light source within the object. If you want an
object to actually cast light onto other objects, you’ll need to work with it in Fractal Design Ray Dream
Designer or another 3D rendering program.




About Imagery in the Different Maps

In Detailer, you’ll create images for the five map types using the brushes, effects and other image
development features.

Throughout this section, “painting on the model” refers to developing imagery in any of the five map
channels. Remember that the effect of an image on the model depends on which map it’s in. In the texture

map, a colored brush stroke puts color on the model. That same stroke in the bump map might cut a notch in
the model.

See also:

Grayscale Images



Grayscale Images

One thing to keep in mind as you develop imagery for a given map is what Detailer does with the image. For
the bump map, reflection mask and highlight mask, Detailer uses only the pixel luminance values to control
shading. Hue and saturation are ignored.

The bump map and mask images may be grayscale, which gives 256 value settings. Black is the lowest
value, white is the highest.

The bump map image may describe up to 256 levels of bump elevation.

The highlight or reflection mask images may describe up to 256 levels of mask density. The darker the pixels
in the image, the greater the masking effect on the object.



Applying Maps

After setting an object’s properties, youw’ll apply one or more images for the surface maps.

Display the Materials: Objects palette. This palette holds the central controls for working on maps.
You might want to tear off this palette and drag it to a convenient area of your screen.

Remember that you can’t tear off the current sub-palette. Select a different sub-palette before dragging the
Object icon away from the Materials palette.

You can apply any of the five map types.

To apply a map to an object:

1if necessary, select the object you want to work with.

2 Choose Map menu> Load> and select the map type you want (Texture, Bump, Highlight, Reflection or

Glow). Detailer displays the Apply Map dialog, which gives you options for choosing the source of the map
image.

The dimensions of the image you map onto the object can be critical in avoiding distortion. You’ll need to use
an image with an aspect ratio appropriate to the selected mapping mode and object scale. See Appendix A,
“Designing Maps,” for important information on designing surface maps.

You may also use the Object palette to open the Apply Map dialog for any map type:
See also:

Copy Image

Open Image

Make New Image Using...

Blank

Current Texture or Pattern

To use the Object palette to apply a map:
Click once to select the map type you want, then click the Load button.
You may also double-click the listing for the map type you want.

If you choose the Brush or Paint Bucket tool and start to paint on an object that doesn’t have a map, Detailer will
alert you that this is not possible and give you a chance to create a texture map.

See also:

Mapping Options

Replacing or Removing a Map

Changing Mapping on a Current Map
Adjusting a Map



Copy Image

The Copy image pop-up lets you create a new document for this map by copying any open image file. Use
the pop-up to select the name of the file you want to copy.

If the document you select contains floaters, they will be dropped (merged with the canvas) in the copy.

Copying an open image is often quite useful. For example, if you have a texture map applied, you’ll want to
create bumps that enhance the imagery in the texture map. By copying the texture map, you have the
perfect starting point for developing the bump map.

Likewise, copying the texture map will help in developing a highlight or reflection mask. You’ll be able to see
which areas need to be masked, and you can edit the image appropriately.



Open Image

The Open image option lets you open a saved image file. Select the Open Image option, then click OK.
Detailer displays an Open File dialog. Use it to locate and select the file you want.

Detailer opens a great number of popular image formats. When you open a RIFF file (Painter and Detailer’s
native format), the floaters remain floating. You’ll be able to move, scale, distort, and rotate these floating
images.

If you open a Photoshop 3 file, the layers are converted to floaters. Photoshop files have some technical
considerations. See Appendix B, “Using Detailer with Other Programs,” for more information.



Make New Image Using...

The Make new image using... options let you create a new, blank image or an image based on the current
Texture or Pattern.

Avoid creating excessively large maps. The map image files must remain open while you are detailing the
model. Larger images increase the demand for RAM.

Larger (higher resolution) images increase detail on the model; however, the rendering process limits the
detail that appears in the final image. This means that there’s a point beyond which increasing map
resolution does not lead to higher detail in the final rendering. However, if you are planning for high
resolution rendering, you should use a texture map of at least the planned rendering resolution.




Blank

If you want to start with a blank canvas, select Blank. Detailer displays text fields that let you set the
number of rows and columns (in pixels) for the new image. Enter the dimensions you want, then click OK.



Current Texture or Pattern

If you want to use a Texture or Pattern, you may use the Materials palette to choose a Texture or Pattern and
set options for it.

Detailer allows you to select your Texture or Pattern from the Materials palette while the Apply map dialog is
open.

Textures and Patterns “tile” over the image area. Tiling describes how a rectangular image repeats to cover a
larger area, like squares of linoleum covering a kitchen floor.

When you select one of these options, Detailer displays text fields that let you set the number of horizontal
and vertical repeats—how many tiles in each direction.

By default, Detailer suggests 1 x 1, which means that one tile image will be used in the map. The image size
will equal the Texture or Pattern dimensions. Enter values to describe how many tiles to use horizontally and
vertically.

To avoid distortion when Detailer maps the image onto the object, you’ll want to use a specific number of
repeats in each direction. See Appendix A, “Designing Maps,” for more information.

When you’ve specified your map source, Detailer displays the Set Mapping Options dialog.

If you are using the Ray Dream Compatible option as your model preference, the Set Mapping Options dialog
will appear only for the first map you apply to an object. All subsequent maps automatically inherit the mode
setting of the first map.

See also:

Ray Dream Compatible



Mapping Options

See also:
Mapping Modes
Orientation

Scale and Origin



Mapping Modes

The word “mapping” refers to the method Detailer uses to transfer the two-dimensional image to the surface
of the 3D model. Detailer offers five mapping modes. Each mode has benefits for certain types of models
and map images.

The mapping mode you use and the dimensions of the object will determine the optimum aspect ratio for the
map image. Using the correct aspect ratio minimizes distortion. See Appendix A, “Designing Maps,” for more
information.

See also:
Mapping Options: Cylindrical
Mapping Options: Spherical
Mapping Options: CubicalMapping Options: Pass-thru
Mapping Options: Implicit



Mapping Options: Cylindrical

Cylindrical mapping wraps the image around the object horizontally. This projective mapping is ideal for
lathe-type objects, like cans, cups, cones, and vases.

See Appendix A, “Designing Maps,” for information on determining the optimum aspect ratio for images used
in cylindrical mapping.




Mapping Options: Spherical

Spherical mapping wraps the image around the object horizontally and vertically. This projective mapping
is useful for spheres, ellipsoids, eggs, and other rounded objects.

Images used in spherical mapping should be twice as wide as they are tall. This will help minimize distortion.

See Appendix A, “Designing Maps,” for more information on spherical mapping.




Mapping Options: Cubical
Cubical mapping folds the image to cover each box face. This projective mapping is used for boxes.

To take full advantage of cubical mapping, you’ll need to create a map in the correct aspect ratio for the

dimensions of your box and know which regions of the image are folded (mapped) onto which faces of the
box.

See Appendix A, “Designing Maps,” for information on determining the optimum aspect ratio for images used
in cubical mapping. This appendix also explains which map regions correspond to which box faces.




Mapping Options: Pass-thru

Pass-thru mapping passes the map through the object, leaving imagery on the surfaces. Pass-thru is a
projective mapping, useful for flat objects, like walls, and for creating wood grain. This is similar to what
happens when you shine a slide projector on an object. Pass-thru mapping is directional. The angle the
projector shines is the angle of pass-thru.

In pass-thru mapping, the image appears on the distant side (from the angle of pass-thru) as well. On the
distant side, the image is the mirror of what appears in front—like looking at the window of a shop from the
inside.

If the object is closed, there will be someplace on the surface where the map stretches and doubles back.

See Appendix A, “Designing Maps,” for information on determining the optimum aspect ratio for images used
in pass-thru mapping.




Mapping Options: Implicit
Implicit mapping assigns points on the map to points on the object and tightly wraps the image onto the
model by lining up these points.

The object must have implicit UV coordinates defined in its geometry to use implicit mapping. Ray Dream
Designer models exported in Detailer format have implicit UV coordinates. Some Quickdraw 3D (3DMF)
models have implicit UV coordinates. All of Detailer’s own primitives have implicit UV coordinates.

In some cases, text used in an implicit map may appear in mirror image. This is a result of the object’s
construction and UV coordinate system. You can correct the text by flipping it horizontally.

Implicit is not a projective mapping. It usually provides the best results when it’s available (on objects with
UV coordinates). Implicit mapping is most useful for an object with a hole in it or one that bends

See Appendix A, “Designing Maps,” for information on determining the optimum aspect ratio for images used
in implicit mapping.

See Appendix B, “Using Detailer with Other Programs,” for information on using implicit mapping on Ray
Dream Designer models.




Orientation
The Orientation options let you choose where the map begins on the object. You can adjust the map later.
See also:

Align with Coordinate Axes

Align with Current View

Align in Register with



Align with Coordinate Axes

Detailer orients the map according to the object’s construction axes. You can get information on the object
by selecting it with the Object Selection tool and looking in the Controls palette.



Align with Current View

Detailer orients the map according to the view in the Model Window. For example, if you choose this option
with Pass-thru mapping, the image will be “projected” onto the object from your current vantage point.



Align in Register with

Detailer aligns this map with the one you select in the pop-up. Corresponding regions of the two images will
map to the same area on the model.

This setting is quite useful. For example, you use the texture map to put a label on a bottle. You want the
highlight mask to cover the paper label, reducing its specularity from the glass surface. With the color label
in the texture map and the dark area of the highlight mask occupying the same region of their respective
images, aligning the one with the other ensures that the two features will map to the same area on the
model.



Scale and Origin

Scale and Origin values provide further technical information on this mapping. These values change,
depending on the selected mapping mode.

When you click OK, Detailer closes the Set Mapping Options dialog, opens the map in an image window, and
applies it to the model.

Each map applied to a model appears in an image document window. Map image windows must remain open
while you are working with the model. Closing a map image window removes the map from its object. If you
try to close an image that is being used as a map, Detailer will warn you that it will be dissociated from the
model.

If you are on a Macintosh, you might want to use the WindowShade feature to minimize the space occupied
by the several image windows. Choose Apple menu> Control Panels> WindowShade to set options for this
Macintosh system 7.5+ feature. If you are using Windows, you can minimize image windows to get a similar
space savings.




Replacing or Removinga Map

At some point, you’ll want to replace a map image with a different one. You might even want to remove the
map completely.

To replace a map, simply apply a different one. Detailer will alert you that you are about to dissociate the
map from the model, then give you a chance to save the map.

To remove a map (and leave that map channel empty), open the Apply Map
dialog for the Map you want to remove. Select the Remove current map option and click OK.

You may also close the map’s image window.

You may only have one map of a type on an object. If you want to use two mapping modes for one map type,
you’ll need to use two objects. For example, cylindrical mapping does a great job on the circumference, but
distorts the image on the top and bottom. If you want to apply a map on the top of a cylinder as well, you
should place an appropriately sized disk (a separate object) on the end of the cylinder and map it with pass-
thru mapping.

You may also use Implicit mapping on an object that supports it.




Changing Mapping on a Current Map

After applying a map, you might realize that a different mapping mode or alignment might be better. You can
easily change the settings.

When you open the Set Mapping Options dialog, Detailer “auto-ranges” to determine the optimum values.
You can use the Adjust features to change scale, origin, and orientation (adjustments available depend on
mapping mode), but if you later decide to change mapping options, auto-ranging and the orientation setting
in the Set Mapping Options dialog will effectively wipe out your adjustments.

To change mapping:
1 with the Object Selection tool, select the object you want to work with.

2 Choose Map menu> Mapping Options> Map Type. Detailer opens the Set Mapping Options dialog for the
selected map.

Refer to_Mapping Options .

You may also use the Objects palette to open the Set Mapping Options dialog. Click the listing for the map
you want to change, then click Mapping.

If you’re using the Ray Dream Compatible preference, Detailer will update all maps on this object to the new
mapping.

See also:

Model Preferences




Adjusting a Map

After applying a map, you might want to adjust its position on the object. You can drag the map image across
the object surface, change its scale, and set its
orientation.

The adjustments available depend on the mapping mode of this map.

To adjust a map:

1 Choose Map menu> Adjust Mapping> and select the map you want to adjust.

You may also select the map you want to adjust by clicking it in the Materials: Object palette. The selected
map will be highlighted. Then click the Adjust button.

Detailer displays the Adjust Mapping tools. This dialog must remain open while you are adjusting the map.
The tools provided and their adjustment effect depend on the mapping mode.
See:

Cylindrical

Spherical
Pass-thru

Cubical
Implicit



Cylindrical

The Grabber lets you drag the map image on the surface of the object. This doesn’t move the position of the
map seam. It uses the Pattern feature “wrap-around seams” to move the entire map, including the seam, to
different locations in the image.

If you want to move only a portion of the map, work in the 2D image to select and float the region. Then you
can move it.

The Plus Magnifier reduces the number of repeats in the Y dimension by a factor of two and then magnifies
the single tile.

The Minus Magnifier doubles the number of repeats of the image in the Y dimension, making the map half of
its former size. Scale in the X dimension does not change.



Spherical

The Grabber lets you drag the map image on the surface of the object. This doesn’t move the position of the
map seam. It uses the Pattern feature “wrap-around seams” to move the entire map, including the seam, to
different locations in the image.



Pass-thru

The Grabber lets you drag the map image on the surface of the object. This doesn’t move the position of the
map seam. It uses the Pattern feature “wrap-around seams” to move the entire map, including the seam, to

different locations in the image.
The Plus Magnifier reduces the number of repeats by a factor of two, and then magnifies the single tile.
The Minus Magnifier doubles the number of repeats of the image, making the map half of its former size.

The Seam Adjuster lets you set the angle of pass-thru. Click on the object. Detailer projects the map onto the
object perpendicular to the surface at the click point.



Cubical

The Adjust Mapping tools are not valid in cubical mapping. If you design your map properly, adjustment is
not necessary. For more information, see Appendix A: “Designing Maps.”



Implicit

The Adjust Mapping tools are not valid in implicit mapping. Because of the variety in the topology of objects
there’s no way to know which areas of the map image correspond to which surfaces on the model. Showing

the mesh might help in some cases, but you’ll probably need to start painting on the model to make sense of
it.



Working in the Maps and Painting on the Model

Detailer allows you to work on the map images while they are applied to the object. You can paint new
imagery, apply image effects, create floaters and move them around in the image. Floaters are an excellent
way to place details on the model.

See:

Saving Map Images
See also:

Controlling Applied Maps
Working in either the Image Window or Model Window

The Mesh
Wrap-around Colors and Seamless Maps



Saving Map Images

As you develop imagery in a map, you’ll want to save your work. File menu> Save and Save As commands
are available to write your work to disk.

For better organization, save all map images in a directory/folder with the model.

Use the RIFF file format for best results. This is Detailer’s native format for images. This format retains the
mask and all floaters. Other formats might not retain this information, which can limit your options for editing
the image later. If you intend to export the model to another 3D program, use the TIFF file format.

See also:

Working with Images



Controlling Applied Maps
See also:
Making a Map Active

Hiding a Map



Making a Map Active

When you have several maps applied to an object, you’ll need to identify which one you want to work in.
Only the active map is available for painting, applying effects, and editing.

To make a map active:
Use any of these three methods:
®* Choose Map menu> Paint Into> Map.

® Choose the image window of the map you want. Click in the window or select its listing from the Window
menu.

In the Materials: Object palette, click the Pencil icon beside the map you want. The one Pencil icon that
appears clear (no slash through it) identifies the active map.

The foremost image window (displayed above all other image windows) is active for painting. Regardless of
which method you use to select the map, its window will come forward.



Hidinga Map

You might want to hide a map temporarily. This makes the effect of the map disappear from the Model
Window and can speed up the display. Perhaps you’re working in the bump map and the texture map makes
it difficult to see the result of your changes.

To hide any map:

1 Click the Eye icon beside its listing in the Object palette. The Eye winks shut and the map disappears from
the 3D view of the object.

2To bring back the map, click the Eye icon again to open it.

3The Map menu> Show submenu also lets you hide and show the maps. The submenu has a listing for each
applied map. Checked items are currently displayed on the model. Select an item to toggle its display state.



Working in either the Image Window or Model Window

After making a map active, you can paint into it, apply effects, or use any of the other tools to develop and
change the imagery. You may work in either the image window or directly on the model. In either case, your
brush strokes and effects appear almost immediately in the other window.

Some tools and features require you to work only in the 2D window.

In the Model Window, you can paint on the object with the Brush tool, fill with the Paint Bucket tool, sample
color with the Dropper tool, create Text with the Text tool, and drag floaters with the Floater Adjuster tool.

In the Model Window, you cannot create selections with the Lasso or Rectangular, Oval Selection tools. You
cannot drag handles of a reference floater for resizing, rotating, or skewing. You cannot use the Effects
menu> Orientation> features on the model. You can select a floater by clicking on it, but not by dragging a
marquee.

You can create a mask (or selection) in the 2D image and set the Drawing Mode to Masked Inside (or Masked
Outside). When you paint on the model, the brush will respect the Drawing Mode setting and the canvas
mask.

When a floater is selected, your brush strokes and effects apply only to the floater—the canvas will not be
touched. This is true whether you’re working in the image window or painting right on the model.



The Mesh

Detailer uses a mesh for the mapping correspondence between the 2D image and 3D surface. The mesh
type depends on the mapping mode selected for this map. Viewing the mesh might help you see
correspondence between the 2D image and 3D surface. In some cases, this information might be helpful in
developing images.

To show the mesh:
1 select the image window for the map whose mesh you want to view.

2 Choose Canvas menu> Display Mesh. You may also click the mesh icon in the top, right of the image
window.

To hide the mesh:

1 Choose Canvas menu> Display Mesh again. You may also click the mesh icon in the top, right of the image
window.



Wrap-around Colors and Seamless Maps
See:
Wrap-around Colors

Seamless Maps



Wrap-around Colors

Early sailors thought the world was flat. They feared that if they sailed too close to the edge, their ship would
fall into
nothingness.

Now, imagine your cursor as that ancient sailing ship on the sea of a 2D image.... Dragging a brush stroke
beyond the edge of the image would send it into nothingness.

Innovative thinkers and explorers proved the world was round. Magellan demonstrated that by sailing in one
direction, you’ll eventually return to your starting point.

This is how the Brush tool behaves in a Detailer Pattern image. Drag it off the right edge of the image and
the stroke continues on the left. This behavior is called “wrap-around colors.”

Detailer wraps the map image onto the model. But there must be an edge where the two sides of the map
meet (this is where you’d place a piece of tape on a gift wrapped package). The wrap-around colors feature
enables you to paint right across this seam. This is a huge advantage when painting directly on the model.

All surface maps applied to a model have the Pattern wrap-around seams attribute.

An image you create with the File menu> New Image command won’t have wrap-around colors. You can
enable this feature for an image if you like. Choose Materials palette: Pattern menu> Define Pattern. Once
the image is defined as a pattern, all features will wrap around.



Seamless Maps

Normally, the right edge of a Pattern tile meets the left edge of the next tile. With the map wrapped in 3D,
the right edge of the map meets its own left edge. In a sense, the map is a Pattern tile that “meets itself.”

The seam where the edges of the map meet should be invisible. The imagery should flow together as though
it was continuous. This will be the case for map images created from Detailer’s Patterns and Textures.

However, if the colors on the left edge of the map contrast the colors on the right edge, the seam will be
visible. You can use the Adjust feature to move the map and seam to the other side of the model, or you can
modify the imagery to make it seamless.

If you need more information on developing seamless maps, look at the section on developing seamless
Pattern tiles in Image Materials. Features and techniques described for creating seamless Patterns apply
equally to developing seamless maps.



Using an Environment Map for Reflection

If you’re in @ museum and you look closely at a 18th century porcelain vase, you might see your own face
reflected on the surface. It’s a subtle detail, but reflection adds visual interest and realism to your models.
Detailer lets you develop this kind of detail with reflection mapping.

Reflection mapping has four steps:
1 create an image for the environment.

2 Import the environment image for the model.

If you don’t import an environment, Detailer uses the current Pattern.
3 select each object in the model and use the Objects palette: Reflection slider to set its degree of reflection.

4ifa single object has areas with different reflectivity, you’ll want to apply a Reflection Mask to describe the
areas with limited reflectivity.

See also:
Creating an Environment Image
Importing the Environment

Setting Reflection for an Object
Using a Reflection Mask




Creating an Environment Image
The environment is the image that appears in the reflection.

Curved objects, like a porcelain vase, warp the image across the curve of their surface. In Detailer, you may
need to warp the image before loading it as the environment. This will depend on the topology of the object.
The rounder the object, the more likely you’ll need to warp the image before loading it as an environment.

To warp an image:

1 Before proceeding, make sure all floaters are dropped.

2 Choose Effects menu> Surface Control> Quick Warp.

3In the Quick Warp dialog, use the default settings (sphere) and click OK.

4 when you’ve finished developing the environment image, save it to disk and close the file.

For more information on Quick Warp options, see Applying Effects.




Importing the Environment

1 open a model.
2 Choose File menu> Import> Environment. Detailer displays an Open dialog so you can locate and select

the environment image you saved.
You can’t edit the environment image file while it is associated with the model. If you need to edit the image,

you’ll need to import it again.




Setting Reflection for an Object
The Object palette: Reflection slider controls the object’s overall reflection.

Select each object and drag the slider to describe its basic reflection amount.



Using a Reflection Mask
You can mask areas of the object to inhibit reflection by applying a reflection mask.
Refer to “Applying Maps,” earlier in this chapter, for more information.

White areas of the reflection mask allow the full Reflection slider setting. Black areas in the reflection mask
block reflection completely. A shade of gray in the mask inhibits reflection at a level that’s the inverse of its
luminance value. The darker the gray, the more it inhibits reflection, and vice versa.



Using Light
See also:
Lighting the Model

Colored Lights on the Model

Light Reveals the Third Dimension
Using Detailer’s Light Palette
Adding Lights with the Light Tool
Light Libraries



Lighting the Model

In Detailer, as in other 3D programs, light illuminates the model for the rendering camera. The rendering
camera’s view is displayed in the Model Window. Without light, all you would see in the Model Window is
black. If you’re going to render the model in Detailer, you’ll want to set the lighting with care. Lighting
directly determines the 3D appearance of the model.

If you’re going to export your model to a 3D scene-building program, like Fractal Design Ray Dream
Designer, you don’t need to pay much attention to Detailer’s lighting. You will set final lighting in your 3D
program. In Detailer you will use light to see how your surface maps will look; this helps you to create them.



Colored Lights on the Model

Detailer lets you use colored lights. The color of the lights you use influences the colors on the surface of
your model. For example, if your model has a cyan texture map and you shine yellow light on it, the model
surface will appear green.

Use white lights to illuminate your model without adding tints to its surfaces.

When you’ve finished adding surface detail to your models, you might want to export them to Ray Dream
Designer or another 3D program. Ray Dream Designer’s rendering engine uses ray tracing. Ray tracing offers
light effects that Detailer doesn’t. If you want objects that cast shadows and render with translucence and
refraction, you’ll need to export your models to a 3D program.




Light Reveals the Third Dimension

Lighting the model creates two effects that contribute to its three-dimensional appearance: highlights and
depth shading.

See also:
Highlights
Depth Shading
Lighting and the Bump map



Highlights
Specular highlights are the bright spots and streaks where light reflects directly.

You can control an object’s tendency to produce highlights with the Materials: Object palette: Specular
slider and with the Highlight Mask.



Depth Shading

Depth shading describes the dark areas that develop on surfaces away from the light source. Depth shading
is only apparent when ambient light is low.



Lighting and the Bump Map
Different lighting conditions change the appearance of the bump texture.
Lights that shine from a low angle create greater contrast in the bump texture.

* Ambient light shines from everywhere, so it minimizes the relief developed by the bump map. To see more
bump texture, reduce the Ambient light.

* Lighting a bump area from opposite directions creates a canceling effect on the bump features. To reveal
more texture, light the model primarily from one side.

The bump effect responds to lighting changes just as you’d expect in nature. Shine a flashlight straight into a
sidewalk crack, and you’ll see into it. The sidewalk surface and the crack will be much the same color. But if
you put the flashlight on the ground so that the light shines across the crack, the sidewalk will be lit, but the
crack will be dark and its detail will be hidden.




Using Detailer's Light Palette

Detailer opens new models with a single light shining on the front of the model. You can move this light and
create others. Each light may have different color, brightness, and concentration settings.

Detailer’s lights are distant lights. They shine on the model like the Sun shines on the Earth. You’ll set lights
for the model, not for individual objects within the model.

Most of the features for working with light appear in the Materials: Light palette.

If you want more sophisticated lighting, for example spot lighting, you will need to import your Detailer
model into a 3D rendering program like Fractal Design Ray Dream Designer.

See also:
Light Palette Preview
Light Icons
Display Slider
Show Icons
Controlling Individual Lights
Controlling Model Lighting




Light Palette: Preview

The lighting preview sphere represents the model space. Imagine your model just inside the sphere. The
lights shine on the preview sphere just as they shine on your model.



Light Icons

The small circles on the sphere are icons representing the individual lights. The light’s color appears inside
the circle.



Display Slider

The Display slider controls the brightness of the lighting on the preview sphere. The Display slider changes
the appearance of the preview. It has no effect on the lighting of your model.



Show Icons

When Show Icons is enabled, the light icons appear on the preview sphere. You might want to disable this
option to hide the icons and see the preview without their distraction.

You can hide the icons by disabling the Show Icons check box at the bottom of the palette.



Controlling Individual Lights

To add a new light:

® Click on the preview sphere where you want it. Detailer creates a new light using the settings of the
current, selected light.

To move a light:
* Drag the light’s circle icon. By moving the lights on the sphere, you move them around your model.

To select a light:
* Click inside the light’s icon. The icon for the selected light appears in “bold.”

When you’ve selected a light, you can change the settings for its color, brightness, and concentration.

To change the selected light’s color:

1 click the Color button. Detailer displays the system color picker so you can choose a color. You may also
choose Materials palette: Light menu> Set Color.

2 Choose a color from the color picker and click OK. You will see your color change take effect after you
dismiss the dialog.

To change the selected light’s brightness:

* Drag the Brightness slider to the right to increase the selected light’s intensity. Drag the Brightness
slider to the left to decrease the selected light’s intensity.

To change the selected light’s concentration:

* Drag the Concentration slider to control the spread of the selected light. Increasing concentration
(dragging the slider to the right) creates a smaller patch of light on the model. Decreasing concentration
(dragging the slider to the left) spreads light across the model.

To delete the selected light:
e Click the Delete button.

You may also choose Materials palette: Light menu> Delete.



Controlling Model Lighting

The following controls apply to the model in general.

Exposure Slider
Ambient Slider

Flat Lighting



Exposure Slider

The Exposure slider controls how much light enters the rendering camera. It works just like the exposure
setting on a regular camera. Increasing exposure (dragging the slider to the right) allows more light into the
camera, so everything gets brighter.



Ambient Slider

Ambient light is general—it illuminates the model from all directions. To get a stronger 3D effect from the
specific lights you set, keep ambient light low.



Flat Lighting

Flat Lighting puts a lot of light on all surfaces. Flat Lighting is equivalent to maximum ambient light. When
you’re painting in the texture map, you might want to use Flat Lighting to see all areas clearly. You’ll want to
disable this option to see depth shading, highlight, and bump effects.



Adding Lights with the Light Tool

Sometimes, you’ll want to add a light without going to the Materials: Light
palette.

The Light tool allows you to add a light by clicking directly on the model in the Model Window.

To add a light using the Light tool:
1 select the Light tool from the Tools palette.

2 Click on the model at the spot where you want the light to shine. Detailer adds the light. You will see the
effect on the model immediately.

3 Use the Controls palette: Light tool to adjust the light’s Brightness and Concentration. These are the same
sliders provided on the Materials: Light palette.



Light Libraries

When you’ve created a set of lights that you like, you can save them to a retrievable setting. You can load
the saved lights for any model you work with.

To save light settings:
1 set the lighting you want. The settings for position, color, and all of the sliders will be saved.

2 In the Materials: Light palette, click the Save button. Detailer prompts you to name the light set.

You may also choose Materials
palette: Light menu> Save.

3Enter a descriptive name and click OK.

Access saved light sets with the Load button on the Light palette. 3D light sets do not have libraries or
movers.

To load saved light settings:

1 in the Materials: Light palette, click the Load button. Detailer displays a dialog list of the saved light sets.

You may also choose Materials palette: Light menu> Load.
2 Click the listing you want. Detailer displays a preview of the light set.

3 Click OK. Detailer closes the dialog and loads the light setting for the model.

You can remove unwanted sets by selecting them, then clicking the Delete button.



Working with Images
See also:
Developing Images

Learning About Detailer Map Image Files
Creating a New Image File

Image Size Information

Navigating Your Document

Rulers

Guides

Using the Grid Overlay

Using the Mesh
Opening and Saving Images
Un-doing Operations



Developing Images

Applying maps to your models is just one aspect of Detailer. The major portion of your work will be creating
imagery in the map image files.

You may create images and, later, apply them as maps; or you may apply a map, then develop imagery in it.
Detailer lets you work either way.

One of the advantages to applying the map first is that you can then paint directly on the model. This is often
the best way to get the imagery you want, in just the location you want it.

In the sections that follow, the text refers to “working in the image.” It makes no difference whether an
image file is currently applied as a map or not—it’s still just an image. Detailer’s image development
features are as well suited for putting the finishing touches on a rendering as they are for developing map
imagery.



Learning About Detailer Map Image Files

Detailer has its own file format called RIFF. RIFF files have special properties. A RIFF will maintain floating
objects so you can return to the file to rearrange floaters. When you work in Detailer, you should always work
in RIFF format to preserve editability. For compatibility with other programs, you can save finished work in
other formats. If you intend to export your model to Ray Dream Designer or another 3D program, you should
save all of your maps as TIFF files.



Creating a New Image File
When you create a new image file, you set the image’s width and height, resolution and, paper color.
Create a new image by choosing File menu> New Image. The New Image dialog box appears.
See also:
Canvas Size

Width and Height
Paper Color




Canvas Size

The Canvas Size describes the file size. Next to the Canvas Size is how much memory (RAM) the document
requires. RIFF is a lossless compressed file format. When saved in RIFF, the saved size of the document is
roughly one-half to one-fourth of this number, depending on how many colors are present in the document. A
document with fewer colors or more white space can compress in RIFF format more than a document filled
with many different colors.



Width and Height

When you create a new image, the Width field is highlighted in the dialog box. You can use the Tab key to
move from field to field.

See also:
Choosing a Unit of Measurement

Setting Resolution



Choosing a Unit of Measurement

The default settings are in pixels. You can change the measuring units by using the pop-up menus. Choose
from pixels, inches, centimeters, points, picas and columns. Columns are two-inch columns, and you can
indicate how many columns wide and tall you’d like your image to be.

To set the width and height for a new document, enter a value for Width and a value for Height in the dialog
box.



Setting Resolution

In Detailer, resolution refers to the number of pixels per inch (ppi) that make up an image. When you enter a
value for Resolution, you will need to consider the intended output or use for your project:

¢ If you intend to display the final rendering on a monitor, for example on a World Wide Web site, set your
file to the monitor’s resolution, measured in pixels. Detailer is preset to 72 pixels per inch. The resolution of
your monitor may be different.

* |f you intend to make a large, high quality rendering, the resolution of the map should match the intended
render size and resolution. If you try to make a high resolution rendering with a low resolution map, the map
will appear softened on the model.

* |f you are creating a 2D collage or a rendering intended for print, you will need to consider the output
device’s resolution, measured in dpi, and, in the case of halftones, lines per inch (Ipi). Output-device
resolutions vary depending on the press and paper you’re printing on. Generally, a photograph to be printed
on glossy magazine stock will be output at a crisp 150 Ipi, and at 85 Ipi for more porous, and therefore more
forgiving, newspaper stock.

In the New Image dialog box, setting the document’s pixels per inch is the same as setting its dpi. Using the
default resolution setting of 72 pixels per inch means that your document’s dpi will also be 72. On most
printers, 72 dpi renders a coarse image, so you may want to choose a higher resolution value.

If you are printing a 2D collage or rendering, using a personal laser printer, set your size in inches,
centimeters, points or picas at the dpi specific to your printer.

If you are using a commercial printer or a more sophisticated output device, the dimensions should always
be set to the actual size it will appear in the printed piece. For the resolution, a good rule of thumb is to set
your document’s pixels per inch to twice the desired Ipi. So when Ipi is 150, the pixels per inch should be
twice that, or 300; if the Ipi is 85, the pixels per inch should be 170. It’s a good idea to check with your
service bureau if you have questions about output device resolution.



Paper Color

You can choose the background paper color. This color will fill the image as the background color when the
image opens. The Paper Color swatch shows the current paper color.

To set paper color, click the Paper Color swatch. Detailer displays the system color picker so you can choose
a color.

To change an existing paper color:
1 Use the Materials: Color palette to select the color you want.

2 Choose Canvas menu> Set Paper Color. The paper is set to the current primary color.

To see the change, you will need to delete areas of the image or use the eraser brush to erase areas (do not
use a bleach variant, bleach variants erase to white). To see the paper color change on an image, simply
choose Edit menu> Select All and press the Delete or Backspace key.



Image Size Information

You can use the i (the international symbol for information) near the bottom left-hand corner of the image
window to check image size.

To check image size and orientation:

1 Move the pointer to the i and hold down the mouse button.
You see the Width, Height, and Resolution.

When a printer is defined, the window also shows how your image fits on the page. Page size and orientation
(landscape or portrait) are based on those designated in the Page Setup dialog box. The non-printing area
around the edge of the page is grayed.

If you change your image’s resolution or dimensions by choosing Canvas menu> Resize, you can use the
window to see how the changes affect the way the image fits on the page. In Windows, this is not applicable
if Size to Fit Page is enabled in Postscript Setup.

2 Release the mouse button to close the image information window.



Navigating Your Document

You can navigate through an image by changing the level of magnification (zooming in or out), scrolling to a
different part of the image, or rotating the page. By navigation, we mean moving around a document,
changing views, or moving the page.

See also:
Zoom to Fit Screen
Zooming In and Out
Using the Grabber Tool
Rotating an Image Window



Zoom to Fit Screen

By default Detailer opens an image file at 100% view, but you can change the view to suit your needs.
Choose Window menu> Zoom to Fit Screen and Detailer will generate a view of the entire image to fit the
size of your monitor.



Zooming In and Out

Zoom in by clicking with the  Magnifier tool. Zoom in to a given rectangle of the image by dragging with the
Magnifier.
Zoom out by holding down the Option key (Macintosh) or Alt (Windows) and clicking.

In an image file, you may also choose a zoom level from the pop-up on the Controls palette: Magnifier tool.
The zoom factors range from 8.3% to 1200%.

You can access the Magnifier tool while almost any other tool is selected. For Macintosh, hold down
Command-Spacebar and click to zoom in and Command-Option-Spacebar to zoom out.
For Windows, use Spacebar+Ctrl to zoom in and Spacebar+Ctrl+Alt to zoom out.

To magnify a specific area:
* Use the Magnifier to drag a marquee around the area you want to magnify.
The area inside the rectangle is magnified to the closest magnification level that fills the screen.

The Magnifier tool works the same way in the Model Window and image windows with one exception. The
zoom level pop-up in the Controls palette applies only to image windows.

Double-click the Magnifier tool in the Tools palette to return the image to 100% magnification.




Using the Grabber Tool

The Grabber tool gives you a quick way to scroll an image.

Drag the Grabber inside the window to pan or move your image.
Shortcuts:

To center an image with the Grabber tool, click once in the image window.

If you double-click the Grabber tool in the Tools palette, Detailer fits the entire image to the largest size
window your monitor will permit. This feature is also available by choosing Window menu> Zoom to Fit
Screen.

To use the Grabber tool while almost any other tool is selected, hold down the Spacebar.

The Grabber tool works the same way in the Model Window and image windows.



Rotating an Image Window
You can rotate an image on the screen to accommodate the way your arm, wrist, and hand draw naturally.

This feature doesn’t rotate the image data—only your view of it.

To rotate an image window to suit your drawing style:

1 choose the Virtual Trackball tool or with almost any other tool selected, hold down Option-Spacebar
(Macintosh) or Spacebar+Alt (Windows).

2 Press down on your stylus or mouse and drag, and a rectangle with an arrow pointing at the top of the
screen appears.

3 Drag the rectangle or the arrow to the angle you want. To constrain page rotation to 90; angles, hold down
the Shift key while rotating the page.

To use the key combinations, press the Shift key first, before choosing Option-Spacebar (Macintosh) or
Spacebar+Alt (Windows).

To return the image window to its normal position:
1 Choose the Virtual Trackball tool or hold down Option-Spacebar (Macintosh) or Spacebar+Alt (Windows).

2 Click once in the image window.



Rulers
For assistance in laying out your images, Detailer provides rulers and guides.

To display the rulers: choose Canvas menu> Rulers> Show Rulers.
To hide the rulers: choose Canvas menu> Rulers> Hide Rulers.
See also:

Ruler Options

Snap to Ruler Ticks
Changing the Origin




Ruler Options

To set the ruler units: Choose Canvas menu> Rulers> Ruler Options. You may also hold down the Option key
(Macintosh) or Alt key (Windows) and click in the ruler to bring up the Ruler Options dialog.

Use the pop-up to choose the units you want: Pixels, Inches, Centimeters, Points, or Picas.



Snap to Ruler Ticks

Each mark in the ruler is called a tick. If you want the guides you create to land precisely on the tick marks,
choose Canvas menu> Rulers> Snap to Ruler Ticks.



Changing the Origin

Normally, the origin (0, 0) is in the top left corner. Sometimes you might want to choose a different origin to
assist in measuring between points.

To change the origin

1 Drag from the box where the horizontal and vertical rulers meet to the point in the document you want as
the origin.

2 When you release the mouse button, the ruler will update to describe this point as the zero.

This applies to the ruler only—not to floater placement or other location features.

To restore the top, left corner as the origin:
Double-click the box where the horizontal and vertical rulers meet.



Guides

Guides are non-printing lines that help you align objects, like floaters.

To create guides:
1 show the rulers. You must display the rulers to create guides.

2 Click once in either the horizontal or vertical ruler to create a guide at that point. If you drag, instead of
clicking, you can move the guide to any point on
the ruler.

If a guide doesn’t appear, Detailer may be set to Hide Guides. To show guides, choose Canvas menu >
Guides > Show Guides.

After creating a guide, you can drag it (by its triangular marker) to any point on the ruler.
To remove a guide, drag its marker off the edge of the document.
See also:

Guide Options

Hiding and Showing Guides

Snap to Guides



Guide Options
Each guide has an options dialog that lets you move it to a particular point and change its color.

Double-click a guide marker. If you haven’t created a guide, double-click anywhere in the ruler. Detailer
displays the Guide Options dialog.

The Guide Position value shows the current position of this guide. You can set the guide to a specific position
by entering a value in the Guide Position field. The units are specified in the Ruler Options dialog.

By default, guides are created in black. You can change the guide’s color by clicking the color chip and using
the system color picker to choose a color.

If you want all guides to be the same color, the Same Color For All Guides option should be enabled.
Choosing this option will make all existing guides the current color. If this option is off, you can create guides
of different colors. This might help if you have several guides near each other and want a reminder for which
is which.

If you want to lock this guide, enable the Locked Guide option. This makes the guide “un-draggable.” You’ll
need to open the guide’s options dialog again to unlock it.

You can clear all guides by clicking the Delete All Guides button.



Hiding and Showing Guides
To display the guides: choose Canvas menu> Guides> Show Guides.

To hide the guides: choose Canvas menu> Guides> Hide Guides.



Snap to Guides

If you want, drag and click operations to snap to the guides, choose Canvas menu> Guides> Snap to Guides.
This feature is enabled when the menu item has a check beside it. Choose it again to disable the feature.
The “snapping” occurs when the cursor (or edge) is within 6 pixels of the guide.

The following operations respect Snap to Guides:

* Dragging with the Rectangle and Oval Selection tools.

* Drawing straight lines with the Brush tool.

* Clicking and dragging with the Paint Bucket tool and Magnifier tool.

* Dragging floaters. The edges of the floater rectangle snap to the guides. The cursor—wherever it might be
in the floater—also snaps to the guide.

* Dragging the handles of reference floaters to scale or slant (skew) them.

* Dragging with the Floater Adjuster tool to create a selection marquee.



Using the Grid Overlay

Detailer has a grid layer to help guide you when laying down brush strokes or creating compositions. To
activate the grid, choose Canvas menu> Grid> Show Grid, or click the Show Grid button on the right side
of your image window.

The Grid Overlay is a special kind of guide. It’s not part of the imagery. If you want a grid in the image itself,
use the Effects menu> Esoterica> Grid Paper feature.

When you paint or draw with the grid turned on, you’ll see your brush strokes at 50% opacity. When you turn
off the grid, the strokes will be at 100% opacity. To have 100% opacity when the grid is turned on, enable the
Transparent Background option in the Grid options dialog.

See also:

Grid Options



Grid Options
You can set up the grid to suit your working style by choosing Canvas menu> Grid> Grid Options.
You can use the Tab key to move between the following fields:

Grid Type

Horizontal Spacing

Vertical Spacing

Line Thickness

Grid Color

Background

Transparent Background



Grid Type

Choose a command from the pop-up menu to determine whether your grid will be rectangular, have vertical
or horizontal lines, or consist of small dots.



Horizontal Spacing

Determines the spacing between vertical lines. The unit of measure can be in pixels, inches, centimeters,
points, picas, columns, or percent. Each column is equivalent to two-inches. Percent refers to the percentage
of the image’s width. For example, if the user chooses 10% for width and height in a 100 X 120 pixel image
then grid lines will appear every 10 pixels going across (vertical lines) and every 12 pixels going down
(horizontal).



Vertical Spacing

Determines the spacing between horizontal lines. Percent refers to the percentage of the image’s height.



Line Thickness

Sets the width of grid lines.



Grid Color

Click the Grid Color swatch to change the color of the grid lines. Choose a color in the system color picker,
then click OK or press Return or Enter. The default color is a light blue.



Background

Click the Background color square to change the grid’s background color. Choose a color in the system color
picker, then click OK or press Return or Enter. The default color is white.



Transparent Background

Click Transparent Background if you want the grid to be transparent so that your image will appear at 100%
opacity when the grid is turned on.



Using the Mesh

Detailer uses a mesh for the mapping correspondence between the 2D image and 3D surface. The mesh
type depends on the mapping mode selected for this map. Viewing the mesh will help you see
correspondence between the 2D image and 3D surface; this information might be helpful in developing
images.

Display the mesh by clicking the Mesh button in the upper-right corner of the window. You may also choose
Canvas menu> Display Mesh.



Opening and Saving Images
See also:
Opening Existing Images

Saving Images



Opening Existing Images

Detailer will open files saved in any one of its compatible formats (except EPS).You can open documents from
other graphics applications and use Detailer to add brush strokes, tints, or textures.

To open an existing image file:
1 Choose File menu> Open.
2 Detailer prompts you to choose between opening a model or an image. Choose Image and click OK.

3 Locate the file you wish to open. If it was saved in Detailer or Painter, the right-hand side of the dialog box
shows a thumbnail of the document.

For every document, regardless of the program in which it was created, Detailer lists the file’s dimensions,
how much space it takes up in memory, and its file format.

Clicking the Browse button displays a dialog box that shows thumbnails, dimensions, and file types for all the
supported documents in the folder.

4 From the Open dialog box or the Browse dialog box, open the document by double-clicking the file name,
or selecting the file name and clicking Open. You may also select the file name and press Return or Enter.

Detailer doesn’t open files saved in EPS format.

In Detailer you can have multiple images open at a time; however, each image has a requirement for RAM.
Depending on the size and resolution, keeping multiple images open at a time may make Detailer run
significantly slower.

Detailer can read files created with other programs only when they are saved in the RGB color or grayscale
formats. Grayscale files are automatically converted to RGB on import. If you try to open a file that was
saved in another format, for example CMYK, an alert dialog box tells you the file must be in RGB.




Saving Images
To name and save an image file, or rendering, choose File menu> Save As.

Use the file type pop-up menu to save your document in any of the formats Detailer supports: RIFF, TIFF,
PICT, Photoshop (2.0 and 3.0), BMP, PCX, Targa, EPS, JPEG. Name your file and click Save.

You can create a 2D collage in Detailer with renderings and image files. This file can be saved in any image
format Detailer supports.

See also:
RIFF Format
TIFF Format

PEG File Format
Adobe Photoshop 3.0 files




RIFF Format
We recommend that you save working files (files “in-process”) in RIFF format.

RIFF lets you compress files and save disk space with a “lossless” compression method. This option is
dimmed with other formats.

Select the RIFF format. The checkbox for Uncompressed should automatically be disabled.

RIFF also is the only format in which you can save the mask and keep floaters floating. Photoshop 3, TIFF and
PICT formats can retain only the mask information.

RIFF is the best format for working in Detailer; however, if you intend to export your finished models or

images, you will need to save your map images or renderings in a format supported by the other program.
TIFF is a good choice in most cases.




TIFF Format

For compatibility with other programs, in general, TIFF is the best file format to use. If you intend to export
your model or images to another program, save your map images or renderings in TIFF format.



JPEG File Format

Detailer supports the Joint-Photographic-Experts-Group (JPEG) file format. Because of its small file size and
high quality, JPEG is commonly used to transmit files via modem.

You can assign URLs to floaters and placed images and then save in JPEG format. For more information see
the last section in Chapter 11, “Floaters.”

JPEG allows you to compress your file on a scale of Fair to Excellent, where quality is directly proportional to
file size. These quality settings will let you achieve compression ratios of less than 10-to-1, to greater than
100-to-1.

JPEG is a “lossy” file format, meaning that a decompressed JPEG file will not be pixel-for-pixel identical to the
original. However, because the JPEG algorithm takes into account the sensitivity of the eye to different
colors, the higher quality settings should achieve visually satisfying results.

To save a file as a JPEG:
1 Choose File menu> Save As and select JPEG from the list of file types.
2 Click the Save button and the JPEG Encoding Quality dialog box appears.

3 Choose a quality option and click OK.

Excellent will compress the least but will retain the most data. Fair will compress the most but will lose the
most data.

It is best not to de-compress and re-compress a file multiple times. Although JPEG can compress and discard
data that is not visible or obvious, the degradation of the data can affect the condition of your file. When a
file has lost a significant amount of data, blocky patterns may appear in areas of the image. If you use a JPEG
as your bump map or if you try to use Detailer’s Apply Surface Texture effect on a JPEG image, you may find
it will accentuate the blocky patterns.




Adobe Photo shop 3.0 files

Detailer supports the reading and writing of images in the Photoshop 3 file format, including the conversion
of Photoshop layers into Detailer floaters, and vice-versa.

See also:
Layers
Masks & Channels




Layers

When reading in an image file from Photoshop 3.0 with layers, each Photoshop layer is automatically
trimmed and converted to a Detailer floater with the appropriate opacity. These layers become very efficient
floaters, which can be moved and manipulated with Detailer’s Floater Adjuster tool. All of Photoshop’s layer
blending modes are supported by Detailer. However, due to differences in the way Photoshop and Detailer
deal with color conversions, a few blending modes will look slightly different in Detailer than in Photoshop.

Detailer’s “Pseudocolor” compositing method is not supported in Photoshop. “Pseudocolor” is mapped to
Photoshop’s “Normal” compositing method. Note that in Detailer, “Normal” and “Default” methods are
identical. “Normal” is included for compatibility with Photoshop.

Photoshop’s user-defined layer masks are automatically consolidated in the mask layer for each floater
within Detailer. When you bring images with layer masks back to Photoshop from Detailer, the layer masks
will have been combined with the non-editable transparency mask for each layer. In addition, Photoshop’s
ability to clip layer data to the layer below is not supported by Detailer.

When saving Detailer images as Photoshop files, each Detailer floater is converted to a Photoshop layer.
Opacity and composite methods are maintained whenever possible. Grouped floaters become separate
Photoshop layers.



Masks & Channels

When reading a Photoshop 3.0 file with channels as an image for a map, Detailer will read in the fourth
channel as a Detailer canvas mask. When saving a Detailer rendering with a mask as a Photoshop 3.0 file,
the mask of the image will be saved as the fourth channel in the Photoshop file. Detailer does not support
transparent images. Therefore, when you import a transparent Photoshop 3 file, Detailer will automatically
create a blank background on which all of the layers will sit. For more information, see Appendix B, “Using
Detailer with Other Programs.”



Un-doing Operations
See also:
Multiple Undo
Fade



Multiple Undo

Multiple Undo allows you to undo and redo up to 32 levels of changes you make in an image. By using the
Multiple Undo feature, you can experiment freely with Detailer’s brushes and effects without “committing” to
every edit you make. The number of undos is set in the Undo Preferences dialog, found under Edit menu>
Preferences> Undo. Five levels are set as a default.

To Undo an action, choose Edit menu> Undo. To Redo an “undone” operation, choose Edit menu> Redo. Redo
is generally only available immediately after an Undo.

The Fade operation merges data from the image into the previous undo layer. An Undo of a faded operation
will effectively take you back two Undo levels.

Undo applies to changes you make in Map Images. Changes to the view in the Model Window, including
Lights, are not part of Undo.




Fade

Fade is used to partially undo effects and brush strokes. It is a form of undo, but only works on strokes and
effects. The Fade command measures an undo as a percentage of your last effect or stroke. This is a great
way to achieve just the right amount of an effect.

To see how fade works:

1 braw a dark brush stroke or apply an effect.

2 Choose Edit menu> Fade. The Fade dialog appears.

3 Drag the Undo Amount slider and watch the brush stroke or effect fade in and out.

4 When the preview shows the weight of stroke you want, or the right effect, click OK.



Image Materials
See also:
Introduction to Image Materials
Working with Color

Using Color Sets
Using Gradations
Using Textures

Working with Patterns

Creating Patterns
Applying Image Materials



Introduction to Image Materials

Detailer’s Materials palette holds the
features for choosing and controlling
colors, gradations, color sets, textures,
and patterns.

Detailer’s main materials are on sub-
palettes of the Materials palette: Color,
Texture, and Pattern palettes. The Grads palette is available from the Materials palette: Color menu.

The Object palette is used for applying and controlling maps; it’s discussed in, “Using Maps.”




Working with Color

In Detailer, you can add color to images by using brushes to make marks and you can fill an area by using
the Paint Bucket tool or the Effects menu> Fill command.

You can use the Dropper tool to sample or “pick up” a color for use elsewhere.

You can set color variability. The color palettes contain sliders to adjust variability. Variability allows you to
create brush strokes of several color levels. The best way to find out about color variability is to try it with
different settings.

See also:

Using the Color Palettes

Primary/Secondary Color Rectangles

Copying Colors
Setting Color Variability
Using Two Colors at Once



Using the Color Palettes

The Color palette is the main way to select colors. Click the Color icon on the Materials palette and the
Color palette appears.

Detailer provides three different types of Color palettes: Standard Colors, Compact Colors, and RGB Colors.
You can choose between palette displays on the Materials palette: Color menu.

The Standard Color palette is shown and described below.
The Compact Colors palette straightens the hue ring into a single bar.

The RGB Colors palette provides RGB
sliders for choosing color.

® Click the grow box in the upper right corner to expand the palette and display the variability sliders.

To select a hue and color from the Standard Color palette:

1 Drag the circle on the color ring to select the predominant hue. You can also select the hue by clicking
once anywhere on the ring.

The triangle displays all the available colors within a predominant hue.

2 Select a color on the triangle by dragging or clicking on the color you want.

Within the triangle, the colors are

organized by value and saturation.

Luminance values span the height of the triangle, with the highest value (white) at the top, and the lowest
value (black) at the bottom.

Saturation levels increase from left to right. Dragging to the right gives the purest color within the
predominant hue. Dragging to the left gives muddier or grayer colors.

To easily select black, click anywhere in the triangle, drag to the lowest point in the triangle, and let up on
the mouse or stylus. To easily select white, drag up instead of down.




Primary/Secondary Color Rectangles

The color you select appears on the front rectangle in the pair of overlapping rectangles. The front rectangle
shows the selected primary color. The back rectangle shows the selected secondary color. Whenever you
start Detailer, black is the selected primary color and white is the selected secondary color.

Don’t confuse the secondary color with what other graphics programs call “the background color.” In
Detailer, the background color is the paper color. When you remove areas of an image, you will reveal the

paper color underneath. For more information about setting the paper color, see Creating a New Image File.

Most of the time you’ll work with the primary color. The secondary color is for multicolor brush strokes, two-
point gradations, and Image Hose effects.

You can change the secondary color by clicking on the back rectangle, then picking a color.

After changing the secondary color, click the front rectangle again. This keeps the primary rectangle selected
for the next time you pick a color.



Copying Colors

In addition to choosing colors from the Materials: Color palette, you can use the Dropper tool to pick up a
color from an existing image and use the color elsewhere.

Using the Dropper Tool
The Dropper tool samples color from an image or from the active map right on the 3D object.
Shortcuts:

You can switch to the Dropper tool by pressing the “d” key. From most tools, you can temporarily switch to
the Dropper by pressing the Command key (Macintosh) or the Ctrl key (Windows).

To use the Dropper tool:
1 select the Dropper tool.

2 Click the front overlapping rectangle on the Materials: Color palette if you want to change the primary
color. Click the back rectangle if you want to change the secondary color.

3 Move the cursor to the color you want to pick up. You may pick a color from the image window or from the
object in the Model Window.

4 Click the color. The Color palette updates to display the chosen color.



Setting Color Variability
Use the Materials: Color palette to set up multiple colors for any of Detailer’s brushes.

To display the Materials: Color palette, click the Color icon on the Materials palette and expand the palette if
necessary.

The £ HSV sliders control ranges of hues, saturations, and values. Moving the £ Hue slider to the right
increases the number of hues in the brush stroke. These colors are the ones adjacent to the selected color on
the color ring.

Moving the = Saturation slider to the right increases the variability in the color intensity of the brush stroke.
Moving the = Value slider to the right increases the variability in the brightness of color in the brush stroke.

When you save a brush variant, the current color variability setting is saved with that variant.

You can try different =HSV slider settings with any of the brushes to get some interesting results. Moving
these sliders to the right is most useful when you’re working with the Van Gogh and Seurat variants of the
Artists brush and other variants set for variability.



Using Two Colors at Once

Usually you work with only the primary color, the front rectangle of the two overlapping rectangles in the
color palettes. Using one color produces a solid brush stroke.

By selecting a secondary color, you can determine the colors for multicolored brush strokes. Most brush
variants are able to paint with a variable range of colors.

The settings for the brush on the Brushes palette: Controls menu> Sliders palette determine how Detailer
decides when to use one color or the other. For information on this palette, see “Advanced Painting.”

To set up a two-color brush stroke:

1 select the Graduated Brush variant or another mark-making brush variant.

2 Click the front rectangle on the Color palette to select it.

3 Select a color on the Color palette or from a color set. The front rectangle displays the new color.
4 Click the back rectangle and select a secondary color.

5 Click the front rectangle again to make it active. This keeps the primary rectangle selected for the next
time you pick a color.

6 Make sure the Color Variability sliders are turned all the way down (to the left).

7 Before you make a stroke, choose Brushes palette: Controls menu> Sliders. Detailer displays the Sliders
palette.

8 set the Color slider to Direction.

9in your document, paint an “X.” Notice that the primary color is used in one mark and the secondary color
is used in the other. Draw some loops and circles to see the transitions.

You might want to try a different setting for the Color slider. If you have a stylus, try Pressure instead of
Direction.

For more information, see the Sliders palette discussion in Chapter 9, “Advanced Painting.”



Using Color Sets

Color sets are used to organize groups of colors. Some color sets are organized both by name and color
relationship.

You can customize your own color sets to control the colors in particular projects or create groups of your
favorite painting colors. You might call one color set “shades of purple.” You might call another color set
“crayon set” or “watercolor set.”

To display the current color set:

® Choose Materials palette: Color menu> Color Set. The Color Set appears on the screen.

To choose a color from a color set:

1 in the Color palette, click on the primary or secondary (front or back) rectangle to select the one you want
to change.

2 In the Color Set, click the color you want.

To load a different color set:
1 choose Materials palette: Color menu> Adjust Color Set.
2 Click Library. The standard open dialog box appears.

3 select a color set from the directory and click Open. The new color set is loaded.

You can set a default color set in the Preferences dialog box. For more information, see Setting Detailer’s
Preferences.

See also:
Finding Colors
Creating Color Sets
Customizing Color Sets



Finding Colors

There are two ways to find a color on a color set—by searching for the color name or by matching the current
color.

To find a color:

1 on the Materials palette: Color menu> Adjust Color Set palette, click Find Color. The Find Color dialog
appears.

2 Select a search method. You can find a color by name or find a color that’s closest to the current color.
3Click Search. If the name isn’t found, the OK button is grayed out.

4 Click OK. If the color set is visible, Detailer surrounds the found color with the selection frame.



Creating Color Sets

You can make your own color sets. The
colors can come from an existing color set, from the selected color on the Materials: Color palette, or from an
image.

To create a color set:
1 Choose Materials: Color menu> Adjust Color Set palette.

2Click New Set. A title bar appears with the name Color Set.

If you want to pick up colors from an image, open the image before you begin creating the color set. You can
customize the swatch size, grid lines, and names as described in the previous section.

Sometimes when you create a new set, the title bar is hard to find on your screen. Once you add a color, the
color set expands and the set will be easy to locate.

3 Choose a color you wish to add to the new color set. You can choose a color from the Materials: Color
palette or from an existing image.

4 1f the color set is locked, click the Padlock button on the Materials: Color Set palette to unlock it.

5 0n the Materials: Color Set palette, click Add Color. The color is added to the color set. To name the newly
added color, double-click the color swatch and enter a name in the dialog box that appears.

6 Repeat this procedure until you have chosen all of your color set colors.

You may change the name of any color in a color set by double-clicking the color. A dialog box appears
asking you to name the color. Type the new name and click OK.

7 Click the Library button. A dialog box appears asking if you want to save the changes you’ve made.
8 Click Save. Enter a name for the color set, choose a destination directory, and click Save or OK.

9The Open Color Set dialog will appear. You can cancel this dialog to keep your saved color set as the active
one.

See also:

Adding and Deleting Colors from a Set



Adding and Deleting Colors from a Set

Customize color sets further by changing, adding, or deleting colors.

To add a color to an existing color set:

1 choose the color you want to add to an existing color set. You can choose a color from the Materials: Color
palette or from an existing image.

If you want to add a color from an existing color set, select the color in the existing color set before you open
the destination set. When you open or create a new set, Detailer will first close the current set and then
display the new set.

2 If the color set is locked, click the Padlock button on the Materials: Color Set palette to unlock it.

3 0n the Materials: Color Set palette, click Add Color. The color is added to the color set. To name the newly
added color, double-click the color swatch and enter a name in the dialog box that appears.

To delete a color from an existing color set:

1 choose the color set that contains the colors you want to delete.

2 If the color set is locked, click the Padlock button on the Materials: Color Set palette to unlock it.
3 Click the color you want to delete to select it. The current selection frame surrounds it.

4 On the Materials: Color Set palette, click Delete Color. A dialog box appears asking you if you really want to
delete the color.

5 Click Yes. Detailer deletes the chosen color from the color set window.

To change a color in an existing color set:

1 choose the new color you want to place into the open color set. You can choose a color from the Materials:
Color palette or from an existing image.

2 If the color set is locked, click the Padlock button on the Materials: Color Set palette to unlock it.

3 Hold down the Option key (Macintosh) or the Alt key (Windows) and click the color in the color set that you
want to replace. The new color replaces the old one in the color set.



Customizing Color Sets

You can arrange a color set in a variety of ways. You can specify the number of rows and columns in the set,
the size of the color swatches, whether or not there are grid lines, and whether or not the colors are labeled.

You can make changes in any order until the color set is exactly the way you want it. The numbered steps in
the next set of instructions give you a place to start.

To customize a color set layout:
1 Choose Materials palette: Color menu> Adjust Color Set.

2 If the color set is locked (padlock closed), click the Padlock button on the Materials: Color Set palette to
unlock it.

3Clicka Sort Order radio button to order the colors in the set. Click Saved to sort colors in the order they
were originally entered. Click HLS to order colors by hue, luminance, and saturation; LHS for a luminance,
hue, saturation order; or SHL to order colors by saturation, hue, and luminance.

4 Use the Color Square Size box to adjust the size of the individual squares in the color set. Click the single
arrows to expand or contract each square by one pixel. Click the double arrows to double or halve the size of
each square.

5 Use the Color Set Size box to change the number of rows and columns in the color set. Click the single
arrows to add or delete rows or columns one at a time. Click the double arrows to double or halve the
number of rows or columns in the color set.

O Click the Display Text checkbox at the bottom of the ~Color Square Size box to turn the color names on and
off.

7 Click the Display Grid checkbox at the bottom of the Color Set Size box to turn the grid on and off. Turning
it off eliminates the lines between colors. You can see more colors, but the separations between colors are
not as distinct as when the grid is on.



Using Gradations

A gradation is a gradual transformation of one color into another. Sometimes they are called blends or
fountains. Detailer provides several different types of gradations: linear, radial, spiral and circular. You can fill
areas with these gradations or express them in an existing image.

Although Detailer comes with libraries full of gradations, you might want to create some of your own. You can
define two colors and create a gradation between them. You can also capture gradations from existing
images (even from imported art) and save them for use in other images. You can save your gradations in
your own libraries.

See also:

Working with Gradations
Filling with Gradations

Creating Gradations

Creating Gradations with the Gradation Editor
Capturing Existing Image Gradations
Expressing a Gradation in an Image



Working with Gradations
Use the Materials: Grad palette to select and adjust Detailer’s gradations.
To open the Grad palette, choose Materials palette: Color menu> Grads.

Across the drawer front are some gradations. Open the drawer to see more gradations. Click the gradation
you want to use and close the drawer.

In the center of the palette, the preview shows how the current settings affect the selected gradation.

The Gradation Angle Ring changes the angle of the gradation. Click anywhere in the ring to change the
angle. The red ball shows the selected angle. The numeric value appears below the preview.

You can click inside the gradation preview and Detailer will rotate the gradation for you. Click outside the
preview to stop it.

The gradation types on the right of the palette let you select from four types of gradations—linear, radial,
spiral or circular.

If you have a spiral gradation, you can drag the Gradation Angle Ring with the Command key (Macintosh) or
Ctrl key (Windows) held down to tighten the spiral.

The gradation orders at the bottom of the palette determine how a gradation behaves. The preview strip
(above the gradation orders) shows the selected gradation order.

The top row (from left to right) orders the current gradation from left to right, left to right and mirrored, and
right to left. The bottom row orders the current gradation from left to right and doubled, right to left and
mirrored, and right to left and doubled.



Filling with Gradations

After selecting a gradation, you can use it to fill all or part of an image. See “Filling an Area,” in this chapter,
for information about selecting what you want to fill and what you want to fill it with.

If you would like to practice using gradations, you can use the Rectangular Selection tool to define an area to
fill. You can also fill the entire image area if you want.

To fill an image with a gradation:

1if you want to fill a selected area of an image, first make a selection.
2 Choose Effects menu> Fill.

3inthe Fill dialog box, click the Gradation button.

4 Click OK. Detailer fills the image with the selected gradation.

You may also use the Paint Bucket tool in conjunction with the Controls palette to fill an area. You set what
you want to fill, and what to fill it with, on the Controls palette, then click in the area of the image with the
Paint bucket tool.




Creating Gradations

You can create your own gradations from simple to complex. For a simple gradation, choose primary and
secondary colors to define a two-point gradation. For more complex gradations, use the Gradation
Editor or capture gradations from existing artwork.

Creating a two-point gradation

You can define a two-point gradation by defining two colors in the Color palette and then having Detailer
create the gradation between them.

To create a two-point gradation:
1 Display the Color palette.
2 Choose a primary color.

3 Choose a secondary color.
Now that you have defined the two colors, you can make the gradation in the Grad palette.

40pen the Materials palette: Color menu> Grads palette.

5 Select the Two-Point gradation:

® Click the Two-Point icon (the one that looks like overlapping rectangles). If necessary, open the drawer to
find the icon. If it’s in the drawer, drag it to the drawer front.

* Alternatively, you can open the drawer and choose Two-Point from the pop-up menu.
6 Make sure the drawer is closed, so you can see the preview of your gradation.

7Try changing the color order by clicking the different icons at the bottom of the window. You can also try
out different gradation types.

8 If you want to save this gradation, click the Save button, give it a name and click OK.



Creating Gradations with the Gradation Editor

Use the Gradation Editor to create new gradations or edit simple, two-point gradations into a more complex
blend.

To edit a gradation:
Choose Effects menu> Gradation> Edit Gradation.
The colored ramp across the top of the dialog displays the current gradation bar.

Along the bottom of the bar, the color control points are indicated by the pointed gray markers. You can
change the colors for these points.

See also:

Changing color control points
Adding and deleting color control points

Using the Linear check box
Changing the color space



Changing color control points

To change a control point’s color, click a color control point to select it. You can then change the color for this
control point by selecting a new color from the Color palette. To start with a two-point gradation, click on the
far right control point and then choose a color. Click on the far left control point and choose a different color.
Now you could generate additional colors in between by adding new control points.



Adding and deleting color control points

You can easily add new color control points by clicking in the gradation bar. Click anywhere in the bar and a
new control point is added without changing the color at this location in the bar. If you Option-click
(Macintosh) or Alt+click (Windows) in the bar, a new control point is added and set to the current color. You
can also press the Delete or Backspace key to remove the selected color control point.



Using the Linear check box

Leave the Linear check box enabled to create ramps that blend linearly between colors. When editing non-
linear gradations (Linear is disabled), all ramps within the gradation are non-linearly blended using smooth
curves. When using non-linear ramps, you should use the Color Spread slider to control the color smoothness
at each color control point.



Changing the color space

The square boxes above the ramp are located at the midpoints between the adjacent color control points.
Click on a square box to select it. When one of these boxes is selected, you can change the color space for
the corresponding color ramp segment. The RGB option will blend directly between the red, green, and blue
components of the two colors. The Hue Clockwise and Hue Counterclockwise options will blend between the
endpoint colors by rotating around the color wheel. For a better understanding of this concept, see the
standard system color picker and note the order of the colors on the wheel.

Notice that as you change the parameters within the Edit Gradation dialog, the gradation previews are
updated within the Grad palette. Click OK when you’re finished. If you want to save your new gradation, click
the Save button in the Grad palette, name it and click OK.



Capturing Existing Image Gradations

You can use any existing imagery as a source for creating new gradations.You could capture the colors in a
photo of a sunset or paint your own range of colors as the content of a gradation.

To capture a gradation:
1 uUse any tool to draw a color blend or open an existing image.

2 Use the Rectangular Selection tool to select a horizontal or vertical area. Make the selection as narrow as
possible. If the selection is horizontal, Detailer uses the first row of pixels starting at the upper left for the
gradation. If the selection is vertical, Detailer uses the first column of pixels starting at the upper left for the
gradation.

3 Choose Effects menu> Gradation> Capture Gradation. The Save Color Ramp dialog appears.

4Type a name for the gradation and click OK or press Return or Enter. The new gradation is saved in the
current library. In the future you can choose it by name from the pop-up menu inside the Grads drawer.

Refer to the Chapter 1, “Getting Acquainted with Detailer,” for information on working with libraries.



Expressing a Gradation in an Image

You can apply a gradation to an existing image, replacing the colors of the image with the colors from the
gradation. The pixel luminance values are used as the mapping guide. For example, expressing a colorful
gradation in a grayscale image produces a colorful rendition of the image.

To express a gradation in the image:

1 Open the image you want to change. You can select part of the image or use the entire image. Images
created with Make Fractal Pattern provide excellent source images.

2 On the Materials: Grads palette, select the gradation you want to use.
3 Choose Effects menu: Gradations> Express in Image. Use the Bias slider to adjust how the gradation is

mapped and click OK. Detailer replaces the colors in the image with the colors in the gradation, based on
matching luminance.



Using Textures

Detailer’s brushes interact with the selected Texture material just as natural tools react with the texture of
the surfaces you mark on. Textures are used as the bump map and in applying surface texture and other
effects, like Glass Distortion.

Texture materials are not the same as the texture map or the surface texture revealed by the bump map.
The Texture material is a special feature that help in developing imagery.

Detailer’s Textures are equivalent to Painter’s Paper Textures. On some palettes, the word “Grain” refers to
the Texture.

The texture is a grayscale image. When the texture image is smaller than the area you’re working in, the
texture tiles.

Most of Detailer’s textures tile seamlessly—you won’t see where one tile ends and the next begins. This
might not be the case for textures you create.

You can select different textures, modify them, organize them in libraries, and even create your own custom
textures.

Click the Texture icon on the Materials palette to display the Materials: Texture palette. Additional materials
are stored inside the drawer. Click the grow box to expand the palette.

The Texture palette is where all your textures are stored. In addition to selecting textures, you can use this
palette to invert or resize the grain and to open other texture libraries.

See also:

Selecting a Texture

Changing Texture Libraries

Inverting Grain
Scaling Texture
Capturing Textures

Making Textures
Setting a Random Grain




Selecting a Texture

To select a texture:
1 click the Texture icon on the drawer front of the Materials palette.
2 Open the drawer to see more selections.

3 Click a texture’s icon to select it. You may also select a texture by name from the pop-up menu inside the
Texture drawer.



Changing Texture Libraries

Detailer’s textures are stored in libraries. Open a new library to get more texture choices.

To open a Texture library:

1 Open the drawer of the Materials: Texture palette by clicking the pushbar.

2 Click the Library button. An Open File dialog appears with a list of texture libraries.

3 Locate other texture libraries. There are a number of libraries installed into the Detailer directory/folder by

default, and additional libraries on the Detailer CD-ROM. Double-click the library you want to open, or select
it and click Open. A new set of textures is loaded into the drawer.



Inverting Grain

You can think of the texture grain as a three-dimensional landscape. Usually brushes react to the texture by
coloring the peaks and ignoring the valleys. Enabling the Invert Grain checkbox makes color fill the valleys
and ignore the peaks.



Scaling Texture

Use the Scale slider at the bottom of the Texture palette to resize the texture. You can scale the texture down
to 25% and up to 400%.



Capturing Textures

The Capture Texture command lets you turn a section of an image into a texture, which will be available on
the Texture palette.

To capture a texture:

1 Open or create an image. The Make Fractal Pattern feature creates excellent textures.

2 Selectall ora piece of the image with the Rectangular Selection tool.

3 Select Materials palette: Texture menu> Capture Texture. The Save Texture dialog box appears.
4\f necessary, move the Crossfade slider to the right to blend the distinction between tile borders.

5Type the name of your new texture and click OK or press Return or Enter.

Your texture now appears in the Texture palette drawer and is added to the current library.



Making Textures

The Materials palette: Texture menu> Make Texture command lets you create regular textures.

To create textures:

1 Choose Materials palette: Texture menu> Make Texture. The Repeating Texture dialog box appears.
The Preview Window reflects your changes.

2 Choose a pattern (not related to Pattern materials) from the Pattern pop-up menu to use as the basis of
your texture.

3Adjust the Spacing and Angle sliders. Moving the Spacing slider to the right opens up space between rows
and columns in the selected pattern. Moving the Angle slider changes the direction in which the pattern
rows are lined up.

4 when you like the look of the texture, type a name for it and click OK. Your new texture appears as the last
item in the Texture palette.



Setting a Random Grain

Normally, texture grain is fixed—the grain is in the same position each time you apply a brush stroke. You
may change this if you want the grain to move randomly.

To randomize the paper grain:
1 Choose Brushes palette: Controls Menu> Random.

2 Enable the Random Brush Stroke Grain option.



Working with Patterns

A pattern is a repeating design. The smallest unit of a pattern is known as a tile. When you fill with a pattern,
the tile is repeated across the area. Detailer saves tiles in separate files and in libraries. Detailer provides
you with over 120 photorealistic patterns. You can also create your own pattern tiles.

Patterns are created by repeating a rectangular image tile across an area. ldeally, the images are created so
that they tile seamlessly.

When you paint using the Cloner brush, Detailer uses the current pattern image by default. This means you
can “paint with patterns.”

See also:

Seamless and Wrap-Around
Check Qut Pattern




Seamless and Wrap-Around

To help in making seamless pattern tiles and surface maps, Detailer gives images defined as a pattern or
applied as map two special characteristics: wrap-around colors and wrap-around seams.

* A brush stroke dragged off the edge reappears on the opposite side of the image. This is called “wrap-
around colors.”

* With the Grabber tool selected, you can hold down the Shift key and drag the seams to the center of the
image. For best results, do this at 100% scale, not when you’re zoomed in. This is called “wrap-around
seams.”

To choose a Pattern:
1 click the Pattern icon on the Materials palette.

2 Click the icon for the pattern you want. You can open the drawer to see more choices. If you want to see
other patterns, click the Library button and load a different pattern library.

3 When you’ve selected a pattern, close the drawer.

The palette shows a preview of the pattern, gives the dimensions of the tile image (Rows and Columns
describe the number of pixels horizontally and vertically), and gives you options for scaling and arranging the
tile in fills.

e Rectangular places the tile in a regular grid for fills. The Offset slider does not apply.

* Horizontal allows you to offset the tiles in subsequent rows. The Offset slider controls the amount of
offset.

e \Vertical allows you to offset the tiles in subsequent columns. The Offset slider controls the amount of
offset.

When you’ve set these options, you can use the pattern. To test it, open a new image. To see the tiling, the
image must be larger than the tile. Choose Effects menu> Fill. In the Fill dialog, choose Pattern as the
material source and click OK. The pattern tile will fill and repeat as specified on the Materials: Pattern
palette.



Check Out Pattern

If the preview isn’t enough, you can open the pattern tile in its own window.

To check out a pattern for editing:
1 in the Materials: Pattern palette, select the pattern you want to review.

2 Choose Materials palette: Pattern menu> Check Out Pattern.

Detailer opens the selected pattern tile in its own document window.

3You can edit the pattern tile as you would any image. To put the modified pattern back in the palette use
the Add Image to Library or Capture pattern features discussed in the following section.



Creating Patterns

Detailer offers three ways to create patterns:

* By defining the current image as a pattern and adding it to the pattern library.
® By creating a rectangular selection and capturing it as a pattern.

* By making a fractal pattern and adding it to the library.

After creating a pattern tile, you’ll probably want to work with it to improve the way it tiles. See “Tips for
Creating Seamless Tiles,” in this chapter, for more information.

Caution: Creating patterns can become addictive. It’s a good idea to keep libraries small. Use the Patterns
Mover to create new libraries and delete unwanted patterns. You can switch libraries whenever you want to
use a different set of patterns.

See also:
Define Pattern
Add Image to Library
Capture Pattern

Tips for Creating Seamless Tiles
Make Fractal Pattern



Define Pattern
You can give any image the pattern wrap-around characteristics by defining it as a pattern.

Images applied as maps are automatically defined as patterns. This gives them the important wrap-around
characteristics.

To define an image as a pattern:

1 Open the image file you want to work with.

2 Choose Materials palette: Pattern menu> Define Pattern.

If you save in RIFF format, images defined as patterns maintain these characteristics even after they have

been saved and reopened. If you want the defined pattern in your Pattern palette drawer, you’ll need to add
it to the library.



Add Image to Library

After you create a pattern, you can add it to the current library.

To add the image to the current library:

1 Open the image you want to add to the pattern library.

2 Choose Materials palette: Pattern menu> Define Pattern.

3 Choose Materials palette: Pattern menu> Add Image to Library. Detailer prompts you to name the pattern.

4Giveita descriptive name and click OK. If a pattern of that name already exists in this library, Detailer will
ask if it’s okay to replace it. If not, click No and try again with a different name.



Capture Pattern

You can capture a pattern from an existing image and set the horizontal and vertical shift for the pattern tile.

To capture a pattern:
1 Open the image that contains the area you want to use.
2 Choose the Rectangular Selection tool.

3 select the area you want. Remember, the edges of the selection will meet when the image is tiled, so
select carefully.

4 Choose Materials palette: Pattern menu> Capture Pattern. Detailer displays the Capture Pattern dialog,
which lets you name the pattern and define how it should be arranged in a fill.

Rectangular Tile places the tile in a regular grid for fills. The Bias slider does not apply.

Horizontal Shift allows you to offset the tiles in subsequent rows. The Bias slider controls the amount of
offset.

Vertical Shift allows you to offset the tiles in subsequent columns. The Bias slider controls the amount of
offset.

As you try different tile arrangements and Bias settings, the preview shows their result. Don’t worry about
making it perfect, you can change the direction and Bias setting in the Patterns palette.

If you intend to use a pattern to create your texture or bump maps, you will want to make sure that the
offset and bias is set to zero. This will ensure the edges of the pattern match up seamlessly when they meet
on the model.

S5Enter a descriptive name for the pattern and click OK.

Detailer captures the pattern and saves it to the current library. You can find your captured pattern in the
Pattern palette. If you want to edit it, you can check it out of the library.



Tips for Creating Seamless Tiles
Patterns are created by repeating a rectangular image tile across an area.

Detailer wraps surface maps onto objects. There is a seam on the object where the edges of the map meet.
Ideally, the imagery on either side of the seam matches closely and the transition is not apparent. The
techniques for creating seamless pattern tiles apply also to developing maps that appear seamless on the
model.

When you develop patterns, you’re creating images for tiling. Ideally, the images will tile seamlessly. That is,
the eye will not be able to distinguish between the boundaries of the tiles. Detailer provides several features
to help you generate such pattern tiles.

U Wrap-around colors means that a brush stroke dragged off one edge of an image appears on the other
side. This makes it easy to paint seamless, self-tiling patterns.

* The wrap-around seams feature lets you move the edges of the pattern tile to the center of the image,
where their tonal differences are more apparent and easier to correct.

To wrap around the seams:

1 open the image.

2 Choose Materials palette: Pattern menu> Define Pattern.

3 Click the Grabber tool on the Tools palette.

4 Hold down the Shift key and drag in the image. You’ll see a horizontal and vertical line where the image

edges meet. When the crossing lines are centered, release the mouse button.

To create a seamless tile, you’ll need to edit the image to get rid of the image edge lines. Several techniques
are possible, depending on the type of image.

* The Soft Cloner brush set to clone from somewhere in this image is best for preserving detailed imagery as
it appears, while providing soft edges for smoother transitions. To set the cloning source in this image, hold
down the Control key (Macintosh) or the Shift key (Windows) and click on the point you want to clone from.
Release the key. Now click on the point you want to clone to. Your strokes maintain this clone source-
destination relationship.

* You might paint out the lines using any cover brush or smear across them with a Water or Drip brush.

* Floating a copy of a selection and moving it over the line is another good choice. Sometimes feathering the
floater and reducing its opacity can help produce a clean transition. You’ll probably want to hide the selection
marquee while you work. Drop the floater when you’re satisfied.



Make Fractal Pattern

Make Fractal Pattern is a pattern generator that creates interesting landscapes. Make Fractal Pattern can be
used to generate bump maps. These topographic patterns can also be filled with color to create
interesting texture maps.

To make a fractal pattern:
1 Choose Materials palette: Pattern menu> Make Fractal Pattern.

2 Use the preview, with the options available in the dialog, to design your pattern. These options are
described in the following paragraphs.

3 When you are satisfied with the adjustments you have made to the pattern, as displayed in the preview,
click OK.

Detailer creates your new pattern file. When Detailer is finished, your pattern file will be displayed in its own
image window.

See also:
Power Slider
Feature Size Slider
Softness Slider
Pattern Size
Channel Options
Height as Luminance
Gradient Bearing
Surface Normal

Converting a Pattern to a Texture



Power Slider

The Power slider controls the level of intricacy of the pattern’s definition, as if you were “zooming” in and
out on a textured surface with a microscope. Move the Power slider to the right to zoom out and you will see
many, smaller patterns. Move the Power slider to the left to zoom in and you will see few, larger patterns.



Feature Size Slider

The Feature Size slider defines the number of prominent features within the tile. Move the slider to the left
to increase the number of features per tile.



Softness Slider

The Softness slider adjusts the softness of the pattern.



Pattern: Size

Size describes the exact size of the tile you are creating. If you have a lot of memory, you can make a larger
file with a higher resolution.

Depending on the amount of memory you have allocated to Detailer, some of the size options may be
unavailable.




Channel Options

Detailer uses four channels to store graphic information: Red, Green, Blue, and Alpha (or Mask). Information
other than color values can be placed in these channels as well. The channel options allow you to visualize
this information in new and different ways.



Height as Luminance
Height as Luminance displays pseudo-height information as luminance.

Images generated with this option are excellent bump maps. Dark areas are peaks, while white areas are
valleys.

Images generated with this option are also useful in conjunction with the Apply Surface Texture feature.
However, with this feature, white areas are represented as peaks, and dark areas become depressions.

The Height as Luminance fractal pattern is grayscale. To colorize it, choose a colorful gradation and use the
Effects menu> Gradation> Express in Image command.



Gradient Bearing

Gradient Bearing uses the Red channel to display the bearing of the down angle of a height field.



Surface Normal

Surface Normal uses the Green and Blue channels to represent the X and Y components of the surface
normal (angle perpendicular to the surface at a given point) of the height field. (Green=X, Blue=Y)

These two latter options for viewing a fractal texture are offered for purely aesthetic reasons. One way to
take advantage of them is to create color variations of the texture with the Adjust Colors effect. Other effects
can deviate quite a ways from the original image.

Fractal patterns can be saved in the current pattern library using the Add Image to Library feature discussed
earlier in this chapter.




Converting a Pattern to a Texture

Some patterns make excellent textures. If you wanted to use a pattern as a texture map, you would probably
fill the texture map with a pattern and apply it to a model. However, you may want to keep a pattern
modified to be a texture in your texture library for future use.

To convert a pattern to a texture:
1 Generate a fractal pattern or check out a pattern to display it in an image window.

2 The luminance and contrast are all that matters in a texture. You may want to adjust the contrast and
brightness of the pattern first, before converting it.

3 When you’re satisfied with the tonal balance, choose Edit menu> Select All.
4 Choose Materials palette: Texture menu> Capture Texture.

5 Name the texture and click OK.

The texture appears in the current library.



Applying Image Materials

Image materials, including color, gradations, weaves, and patterns can be applied to your images in a variety
of ways. Most commonly, you can fill selected areas with the Paint Bucket tool or the Fill command.

Detailer also provides a number of special effects methods for using image materials.
See also:

Filling an Area

Applying Texture



Filling an Area

To fill an area with a color, gradation, or pattern, use the Paint Bucket tool on the Tools palette or the Fill
command on the Effects menu.

When you want to use the Paint Bucket tool, click its icon on the Tools palette. Selecting the Paint Bucket tool
displays the Controls palette: Paint Bucket tool. This palette shows choices for what to fill and what to fill
with. The current fill is shown on the left of the palette.

To fill with the Paint Bucket:

1 click the Paint Bucket tool on the Tools palette to select it.

2 Display the Controls palette: Paint Bucket tool.

3 Click the radio button for what you want to fill with when you click in the image window with the Paint

Bucket tool.

Image fills an image area differently depending on whether or not an area of the screen is currently selected.
If no area is currently selected, the Paint Bucket will fill all contiguous pixels based on the color of the pixel
clicked with the Paint Bucket. If an area of the screen is currently selected, the Paint Bucket will fill either the
inside or outside of the selection, depending on where you click.

Mask fills contiguous areas of the Mask layer based on the luminance values of the selected Fill With
source.

4 Click the radio button for what you want to fill the area with.
Current Color uses the selected color. When you select it, the Current Fill preview shows the selected color.

Gradation uses the selected gradation. When you select it, the Current Fill preview shows the selected
gradation.

Pattern uses the current pattern. The source image appears in the Current Fill preview.

5When you’re finished setting the Controls palette, click with the Paint Bucket in the desired area to fill it
with the new material.

To use the Fill command:

1 select part of your image.

2 Choose Effects menu> Fill. The Fill dialog appears.

3 Select what you want to fill with—the Current Color, Pattern, or Gradation.
4Adjust opacity if you like.

5 Click oK or press Return or Enter. The selected area fills with your choice.



Applying Texture
You may be wondering why you can’t fill with a texture. Remember that Texture is a surface control material.

To apply texture, choose Effects menu> Surface Control> Express Texture. You may also use Effects menu>
Surface Control> Apply Surface

Texture. In some cases, you might want to try Effects menu> Surface Control> Dye Concentration or Color
Overlay and set the Using pop-up to Texture. See Chapter 13, “Applying Effects,” for more information about
image effects using

texture.



Painting
See also:
Introduction to Painting

Mark Making

Starting to Paint

Selecting Brushes and Variants
Using Texture with a Brush
Basic Brush Controls

Built-in Brush Variants

Cloners Brushes



Introduction to Painting

In Detailer, you can paint with traditional tools like pencils, crayons or charcoal in maps or directly on a 3D
model. Detailer’s brushes overflow with features from Natural-Media to fantastic effects.

This chapter covers Detailer’s brushes and the basics of painting. You’ll learn how to make marks, choose a
brush and variant, resize a brush and create and save new variants. The built-in brush variants will be
described in detail. Look in the next chapter for more information on customizing the brushes.

To paint in Detailer, use the Brush tool. Choose a brush in the Brushes palette, and make marks by dragging
with your mouse or stylus. You may mark in an image window, which may or may not be currently applied as
a map. If it is a map, the effect of your marks will appear in the Model Window.

Conversely, you may mark on the model in the Model Window, and your strokes will simultaneously appear
in the map image window.

The actual result of your strokes will depend on the type of map you’re working in—whether it’s the texture
or bump map, for example. Remember to select the map you want to paint into before you start marking.

If you paint with the Brush tool in the 2D image, the brush dab will have the same size anywhere in the

image. However, if you use that same brush in the Model Window, the dab size may change on different
regions of the model. This is because scale will vary across the object in some mapping modes. Refer to
Appendix A, “Designing Maps,” for more information.

The Brush tool represents a category of marking tools. Within the Brush category are pencils, crayons, pens,
chalk, airbrushes, the remarkable Image Hose, and more. The Brushes palette lets you choose between
these tools and gives you access to controls that let you customize the brushes.

Many of Detailer’s brushes, such as chalk and charcoal, interact with the current texture. By combining
different brushes and textures, you can create an amazing variety of stroke effects.

In terms of brush strokes, the current texture is called grain. References to “Grain” in sliders, palettes, and
dialogs refer to the current texture.

See also:

Stylus versus Mouse

Freehand and Straight Lines Drawing
Selecting Brushes



Stylus versus Mouse

Most stylus and graphics drawing tablets provide 256 levels of pressure information. The mouse has no
pressure information. The mouse is either “on”—button down, or “off>—button up.

Many of Detailer’s brushes respond to the pressure information provided by a drawing stylus. Greater
pressure can increase the width of a brush stroke, the penetration of color, the amount of the secondary
color, or the degree of some other effect, depending on the variant.

When you draw or paint, some qualities of your marks will vary depending on whether you’re using a
pressure-sensitive stylus or a mouse. With a stylus, you can use pressure to get the most out of Detailer’s
brushes.

If you are using a mouse with Detailer, you can compensate for the lack of pressure information by adjusting
the Opacity and Grain sliders on the Controls palette: Brush tool. For example, moving the Opacity or
Grain slider to the left can give the same results as pressing lightly on a stylus. Moving the Opacity or Grain
slider to the right can produce the same effect as pressing heavily.

Another way to modify a brush is with the Brushes palette: Controls menu> Sliders palette. Here you can
modify the brush to respond to factors like velocity and direction instead of pressure. See “Sliders Palette” for
more information.



Freehand and Straight Lines Drawing
With Detailer, you can draw freehand, or you draw with straight lines.
Freehand allows you to click and drag in any motion or direction you like.

Straight Lines will connect each point click with a line and can be closed (return to origin) by pressing the
Return or Enter key.

To make a freehand stroke:
1 select the Brush tool in the Tools palette. Brush controls appear in the Controls palette: Brush tool.

2 Select a brush from the Brushes palette. You may double-click the Brush tool to display the Brushes
palette.

3Click the Freehand radio button on the Controls palette under Draw Style.
4 position the pointer where you want to start painting.
5 Push down on the stylus or hold down the mouse button and drag to make a mark.

6 When you have finished, let up on the stylus or release the mouse button.

With some brushes, you see a dotted line before the mark appears. This dotted line appears when you use
complex brushes. For example, the Van Gogh brush and the Hairy Brush. These brushes have to be
precomputed, which causes a delay in the stroke’s appearance on the screen. These brushes work best when
you apply them in short strokes. Wait until the stroke appears before you start another one.

Straight line mode is not available when marking in the Model Window. The following description applies only
to marking in an image window.

To draw a straight line:
1 select the Brush tool and choose a brush from the Brushes palette.
2 Click the Straight Lines radio button on the Controls palette: Brush tool under Draw Style.

3 Click the stylus or mouse where you’d like your stroke to start in the image window. You’ll see an origin
point marker.

4 Drag to where you want your stroke to finish. A thin line connects the two points. Before you release the
mouse or stylus, you can move the stylus or mouse around and place the finishing point exactly where you
want it. Release the mouse or stylus. Detailer fills in a straight line between the two points.

5 Continue to draw more lines in the same fashion, or you may simply click to create points that are
automatically connected by a line. When you are done, press the Return or Enter key if you want Detailer to
draw a line from where you left off to the origin point. If you don’t want to connect the points, click the
Freehand button to return to freehand drawing. Toggle between the Draw Styles as you paint.

In Straight Line mode, to constrain your line to a 45 or 90; angle, hold down the Shift key as you click your
second point. Lines automatically are constrained to a grid if the snap to grid is turned on. Snap to grid is
found under the Canvas menu> Grid.

Keyboard Shortcuts

Key Description

b Choose Freehand mode.

\Y Choose Straight Lines mode.

The “v” will also end the current polygon so you can begin a new one.



Selecting Brushes

Detailer’s painting, drawing, image-editing, and cloning brushes are located on the Brushes palette.

To select a brush:
1 click a brush on the drawer front of the Brushes palette. Click the pushbar to open the drawer and see
more brushes.

A red highlight appears around the brush you selected. The name of the brush variant appears on a pop-up
menu under the drawer pushbar .

2 Make changes on the Controls palette: Brush tool if you need to.

The Opacity and Grain sliders change the appearance of brush strokes; they are described later in this
chapter. The Draw Style radio buttons determine whether you draw freehand or straight lines. The
Overlapping Rectangles show the selected primary and secondary colors.

3 Choose a variant from the Variants pop-up menu.

For each brush, you have a choice of variants. For example, if you select Pencils, you can choose from
Colored Pencils, Thick & Thin Pencils, a 2B Pencil, a Sharp Pencil, a 500 Ib. Pencil, and a Single Pixel Scribbler.
All variants are described later in this chapter.



Mark Making

In Detailer, you can paint by simply selecting the Brush tool, choosing a brush from the Brushes palette and
making marks on the canvas. The particular variant of that brush you choose determines the appearance of
the marks you make.

Detailer provides a drawer full of different brushes, each with its own characteristics. Many of the brushes
are digital equivalents to the traditional media you’re familiar with. Using these brushes, you can create 3D
models that look like they were hand painted or wrapped with real canvas or textured paper.

Some brushes contain special image-editing capabilities. These brushes—including the Retouching brush,
Image Hose, Cloners, and Water—take advantage of the computer’s power to produce effects that wouldn’t
be possible with traditional media alone.

Many of Detailer’s brushes respond to the additional control provided by a stylus and graphics tablet. Brush
strokes fade in and out, change width, or penetrate based on the pressure of the stylus.

Because you use a stylus the same way you draw and paint with pencils, pens, and brushes, the stylus has a
familiar feel. You can apply your experience with the traditional tools directly to the Detailer canvas and
youw’ll get natural-looking strokes.

If you are using a mouse, you can use the Sliders palette accessed from the Brushes palette: Controls menu
to get the same effects produced by a stylus. Instead of using pressure to determine size or color, you could
choose to use direction. See, “Advanced Painting,” for more information.




Starting to Paint

To paint, you’ll need to choose a brush, choose a variant, choose a texture, select a color, and mark in either
the Model Window or image window.

Refer to the “Image Materials,” for information on choosing textures and colors.

See also:

Choosing a Brush



Choosing a Brush

One thing to consider when applying paint is whether the brush you have chosen applies color that “builds
up” or “covers.”

A real-world example of build-up is the crayon: Scribble on the page with blue, then scribble on top of that
with green, then red... The scribbled area keeps

getting darker—approaching black. Even if you were to apply a bright color like yellow, you couldn’t lighten
the scribble, it would stay dark; this is build-up.

An example of “cover” is oil paint. No matter what colors you paint, you can always apply a layer of paint
that completely hides what’s underneath. Even with a black background, a thick layer of yellow will be pure
yellow.

Build-up and Cover are called “methods.” Methods are categories that describe brush behavior. The brush
methods are build-up, cover, eraser, drip, mask, cloning, wet. Brush methods are described in, “Advanced

Painting.”
Another important quality of a brush is the degree of anti-aliasing. Anti-aliased brush strokes have soft

edges. The color dissipates over a few pixels to the background. See each brush description in this chapter to
determine if the variant is aliased or anti-aliased.



Selecting Brushes and Variants

Detailer’s brushes are stored in the Brushes palette. You can show the Brushes palette in any one of three
ways: select Window menu> Brushes, press Command-2 (Macintosh) or Ctrl+2 (Windows), or double-click
the Brush tool in the Tools palette.

Detailer provides a number of different brushes: pencil, eraser, pen, etc. Each of these brushes is further
divided into variants. A variant is a specific version of that brush. For example, the Pencils brush offers the
following variants: Colored Pencils, Thick & Thin Pencils, a 2B Pencil, a Sharp Pencil, a 500 Ib. Pencil, and a
Single Pixel Scribbler.

Complete descriptions of each brush and variant are in the following section, “Built-in Brush Variants.”

To select a brush from the Brushes palette, click the icon for the brush you want. You may have to open the
palette drawer to find a particular brush. When the drawer is open, you may also select a brush from the
Brushes pop-up menu.

Detailer’s built-in brush variants are so cool that many artists will use them with only the basic adjustments
—size, opacity, and the amount of grain revealed by the stroke.

If you want to create your own, custom variants, Detailer offers a number of controls that let you modify the
brush effect. To retain these specific adjustments for future use, you’ll need to save the variant., “Advanced
Painting,” provides detailed information about customizing brushes and saving variants.



Using Texture with a Brush

In the natural world, a marking tool has different effects on surfaces of different texture. Detailer allows you
to control the texture of the canvas to achieve the results you’d expect from natural media on a given
surface—pencil on watercolor paper, markers on cotton paper, paint on canvas, chalk on the sidewalk, etc.

Brushes with a “grainy” method respond to texture. For more information about Brush Methods, see
“Advanced Painting.”

The different brush variants interact with the canvas texture at different levels. You can control the texture of
brush strokes in three ways:

* By changing the texture. For more information, see, “Image Materials”)
® By changing the Grain slider on the Controls palette: Brush tool.

* By changing the stroke of the stylus on the pressure tablet. In most cases, a light stroke colors only the
peaks and ridges of the grain. A heavy stroke fills color deep into the pockets and valleys.



Basic Brush Controls

The basic brush controls for Opacity and Grain are found on the Controls palette when the Brush tool is
selected.

See also:
Brush Controls: Opacity
Brush Controls: Grain

Brush Controls: Brush Size



Brush Controls: Opacity
The Opacity slider controls the degree the stroke “covers” or “builds up” on the underlying colors.

When Opacity is at maximum, the color is solid, completely covering, or building up, on the underlying
colors.

With Opacity low, the color is thin. You’ll be able to see through to the underlying colors.

One brush method, Grainy Edge Flat Cover, does not respond to opacity. It is the nature of any brush with
this method not to respond to adjustments you make in the Opacity slider.




Brush Controls: Grain

The Grain slider controls how much color penetrates into the canvas texture.

Moving the Grain slider to the right intensifies penetration of the color. This allows less texture to show
through.

Moving the slider to the left reduces the stroke’s penetration, which reveals more texture.



Brush Controls: Size

Detailer offers a number of features for resizing and shaping brushes. Resizing brushes becomes technical
quickly. This information is covered in detail in, “Advanced Painting.” For now, the quickest way to change the
size of a brush is with the keyboard shortcut:

1 Hold down the Command--Option (Macintosh) keys or Ctrl+Alt (Windows).
21In the image window, press the mouse button and drag. A circle that represents the brush diameter
appears beneath the cursor. When you’ve dragged the circle to the size you want, release the button.

In some cases, the brush must be “built.” Press Command--B (Macintosh) or Ctrl+B (Windows), click the Build
button, or choose Brushes palette: Brushes menu> Build Brush. If you try to paint with an “un-built” brush,
Detailer will alert you.

If resizing the brush has made its stroke appear strange to you, you probably need to adjust Spacing.



Built-in Brush Variants
The following section is a catalog of Detailer’s built-in brush variants.

These descriptions of the variants outline the behavior of a brush when pressure information is available. If
you are using a mouse to paint, you’ll want to modify a brush to achieve those pressure-sensitive effects.
Modifying brushes will help you get the most out of the mouse as an input device.

See also:

o

rush

Artists

iquid

2

Water Color
The Water Color Brush Variants
Airbrush

Felt Pens
Crayons
Retouchers
Masking Brushes
Image Hose
Dodge



Brush

The Brush provides effects you’d expect from oil paints and acrylics. All of the Brush variants cover
underlying brush strokes, and many are capable of multi-colored strokes.

See “Image Materials,” for information on defining the colors for multi-color brushes.

Some of the Brush variants, like Loaded Oils, give the striated effect of real bristles. Using these variants with
Apply Surface Texture in the Effects menu produces some great oil or acrylic-like brush strokes.

See also:
Hairy Brush
Graduated Brush
Cover Brush
Penetration Brush
Qil Paint
Camel Hair Brush
Rough Out
Big Rough Out
Huge Rough Out

Digital Sumi
Loaded Oils

Small Loaded Oils

Big Loaded OQils

Big Wet Qils

Brushy

Fine Brush

Sable Chisel Tip Water
Coarse Hairs

Smaller Wash Brush

Ultrafine Wash Brush

Big Wet Ink
Big Dry Ink



Hairy Brush

The Hairy Brush simulates strokes made by a bristle brush, showing semi-anti-aliased “brush hair” lines. The
Hairy Brush interacts with grain and is pressure sensitive in terms of opacity and stroke width. The Hairy
Brush can paint multi-color strokes.

You can customize the Hairy Brush dramatically by adding bristles and opening up space between them. For
instructions, see “Advanced Painting.”




Graduated Brush

The Graduated Brush is ideal for shading. It paints semi-anti-aliased brush strokes of just the primary color or
the primary and secondary color, depending on pressure. It interacts with grain, and its stroke width is also
determined by pressure.

See “Image Materials,” for instructions on selecting primary and secondary colors.



Cover Brush

The Cover Brush produces brush strokes that have soft, anti-aliased edges. It does not interact with grain.
Stroke width and opacity are determined by pressure.



Penetration Brush

This brush has hard, aliased edges. Its strokes look like acrylics when you apply surface texture to them
using the Effects menu (described in “Applying Effects”). The Penetration Brush reacts to grain. Pressing
lightly with a stylus allows more texture to show through; pressing heavily reveals less texture.



Oil Paint

The Oil Paint brush gives you strokes that have hard, aliased edges. Its strokes interact with grain. Stroke
width and opacity are determined by pressure.



Camel Hair Brush

The Camel Hair Brush gives soft, anti-aliased strokes. Bristle size is dependent on drawing speed. Dragging
quickly narrows each bristle; dragging slowly widens each bristle. Opacity depends on pressure.



Rough Out

Rough Out acts like a fast, dry brush and is ideal for roughing out ideas. The dab size of the brush is
dependent on drawing speed. The faster you drag your stylus, the thinner the lines. Dragging slower
produces thicker lines. The amount of grain revealed by this brush depends on pressure. Pressing lightly
reveals more grain; pressing harder reveals less grain.



Big Rough Out

This variant is a wider version of Rough Out.



Huge Rough Out

This variant is an even wider version of Rough Out.



Digital Sumi

The Digital Sumi brush variant is a multiple-bristle brush made up of single-pixel bristles. Pressure affects
width.



Loaded Oils

The Loaded Oils brush simulates the look of a traditional loaded brush—a brush dipped in more than one
color. Use the Color Variability sliders to adjust how loaded oils appear. For more information about Color

Variability see “Image Materials.”



Small Loaded Oils

This variant is a narrower version of Loaded Oils.



Big Loaded Oils

This variant is a wider version of Loaded Oils.



Big Wet Oils

Big Wet Oils is a wide loaded brush that mixes with the colors in the image.



Brushy

Brushy is a multi-bristle brush that runs out of paint toward the end of a stroke and picks up colors it’s
dragged through.



Fine Brush

The Fine Brush is a very fine-hair brush that changes scale quickly based on pressure.



Sable Chisel Tip Water

This variant is a fine-hair brush that uses water to smear the colors in an image.



Coarse Hairs

The Coarse Hairs brush produces a stroke with a small number of coarse hairs that change scale quickly
based on pressure.



Smaller Wash Brush

The Smaller Wash Brush has a multitude of fine, closely spaced bristles that mix and smear the current color
with colors in an image.



Ultrafine Wash Brush

This variant is similar to the Smaller Wash Brush but with a larger bundle of finer bristles.



Big Wet Ink

Big Wet Ink is a thick striated brush, loaded with ink. It has a soft appearance and looks like the bristles are
spread apart.



Big Dry Ink
Big Dry Ink is like Big Wet Ink, but with a bit harder edge.



Artists

The Artists brush helps you paint in the styles of the master artists. Paint in the style of Vincent Van Gogh,
where your brush strokes are multishaded, or in the style of Georges Seurat, where multiple dots combine to
form an image.

With all of the Artists brush variants, dragging quickly produces narrower strokes, dragging slowly produces
wider strokes. Use the Color Variability sliders to adjust how the Artists brush strokes are colored. For more
information about Color Variability see “Image Materials.”

See also:
Van Gogh
Van Gogh 2
Seurat
Impressionist
Flemish Rub

Piano Keys



Van Gogh

One of the things that made Vincent Van Gogh’s style special was his use of multicolored brush strokes. The

Van Gogh brush recreates this style with a multicolored, anti-aliased brush stroke that covers underlying
colors.

This is a complex brush and the strokes must be pre-computed; hence the dotted line that follows the cursor

during the stroke. For best results, use shorter strokes with this brush, and wait for them to render before
making new strokes.



Van Gogh 2

Van Gogh 2 has about the same look as Van Gogh but it paints interactively—the strokes do not have to be
pre-computed.



Seurat

Georges Seurat painted in the pointillist style, a neo-Impressionist technique of using clusters of dots to
represent the subject. The Seurat brush automatically creates multicolored, anti-aliased dot clusters. To add
more dots, drag over the area again.

You can regulate dot size on the Size palette accessed from the Brushes palette:
Controls menu> Size. Move the Size slider to the right to make the dots bigger.



Impressionist
This brush re-creates the style of the Impressionists who painted with flattened dabs of color. The direction
you drag determines the angle of the dab.

You can use the Impressionist variant to push around existing paint in an image by moving the Opacity slider
to the left.



Flemish Rub

This variant creates an effect similar to the Impressionist variants. The difference is that Flemish Rub smears

existing color instead of applying new color. Use this variant to apply an impressionistic effect to an existing
image.



Piano Keys

This variant creates a colorful ribbon-like stroke with color bands perpendicular to the direction of your
stroke. Piano Keys uses a closely spaced, thin captured rectangular tip to produce the effect.



Liquid
The Liquid variants treat the underlying image as though it was floating on a thick liquid. The brush stroke
drags image colors behind it.

This can be particularly useful when working with scanned photographs. These brushes can create a palette
knife painting effect.

To smear existing paint with a Liquid brush variant—without adding color—move the Opacity slider all the
way to the left.

To smear while adding some color, move the Opacity slider to the right.

Stylus pressure affects texture differently for the Liquid variants (drip method). More texture is visible when
you press heavily, and less texture is apparent when you press lightly. This follows the natural behavior of
smearing—the harder you smear the paint, the more you will reveal the surface it is painted on.

Drag these brushes slowly. The amount of pressure determines how much of the image you smear.
The Grain slider controls the strength of distortion a Liquid brush exerts on an image.
See also:

Distorto

Smeary Bristles
Total Oil Brush

Smeary Mover
Coarse Smeary Mover

Coarse Smeary Bristles
Coarse Distorto

Thick Qil

Tiny Smudge




Distorto

This variant moves paint around without adding color. Dragging quickly produces a thinner stroke; dragging
slowly creates a wider one.



Smeary Bristles

This variant smears the primary color into the image. This variant is grain-sensitive. Dragging quickly
produces a thinner stroke; dragging slowly creates a wider one.



Total Oil Brush

This variant is similar to Smeary Bristles, but produces a tighter stroke.



Smeary Mover

This variant is similar to Smeary Bristles, but it smears existing paint without adding color.



Coarse Smeary Mover

This variant is a semi-anti-aliased version of Smeary Mover.



Coarse Smeary Bristles

This variant is a semi-anti-aliased version of Smeary Bristles.



Coarse Distorto

This variant is a semi-anti-aliased version of Distorto.



Thick Oil

Thick Oil smears with a stroke loaded with the primary color.



Tiny Smudge

Tiny Smudge is a single-pixel, multi-bristled smudging tool.



Water Color
The Water Color brush variants produce natural looking watercolor effects.
See also:

The Wet Layer

Diffusion

The Water Color Brush Variants



The Wet Layer

Water Color brushes are different from the other brushes. Water Color brushes paint into the “wet layer,”
which has special properties that enable the colors brushed into it to flow and mix.

The wet layer floats over the image. This separation of layers enables effects and techniques that wouldn’t
otherwise be possible. You can edit the watercolors, including erasing and blurring, without changing
anything in the image layer. For example, you can draw pencil outlines in the image layer, then overlay
watercolor shading without smudging the pencil lines.

You can’t edit the wet layer with image-layer tools. If you’re using the Eraser brush and it has no effect on a
brush stroke, that stroke may be in the wet layer. Use the Wet Eraser instead.

You can’t use the Selection tools to select and delete an area in the wet layer.
You can’t use the Dropper tool to sample colors from the wet layer.
Once you save, the wet layer dries.

The wet layer automatically dries when you save the image. Once the watercolor image is dried, you can’t
do any more “wet” modifications to it.




Diffusion

Diffusion creates wonderful, soft, feathery edges on the strokes of some water color variants. In terms of
natural water colors: wet paper produces more diffuse strokes.

After applying water color strokes—but before saving the image—you can increase the diffusion of your
strokes.

Diffusion spreads color into the grain. Make sure the current texture is appropriate for the diffusion effect you
want.

To increase diffusion on water color strokes:
1App|y one or more strokes with a water color brush variant.

21f you would like to restrict the diffusion to a region, make a selection with the Rectangular Selection tool.
The diffusion effect will apply only within the selection.

3 Press Shift-D.

4 Repeat the command until the strokes show the level of diffusion you want.



The Water Color Brush Variants

All of the Water Color variants, except Wet Eraser, interact with the canvas texture. The Grain slider works
differently with the Water Color brushes than with the other brushes. With Water Color variants, moving the
slider to the right makes the texture more pronounced. Moving the slider to the left reduces the grain
interaction.

Stylus pressure affects the width of the brush stroke for all of the Water Color brush variants except Wet
Eraser. Increased pressure widens the brush stroke; less pressure narrows the stroke.

See also:

Simple Water
Water Brush Stroke

Wet Eraser

Pure Water Brush

Spatter Water
Broad Water Brush
Large Water

Large Simple Water
Diffuse Water



Simple Water

The Simple Water variant leaves a stroke of the primary color without bristles.



Water Brush Stroke

This variant is a watercolor bristle brush. When you first make a stroke, a dotted line appears while Detailer
computes the stroke.



Wet Eraser

The Wet Eraser removes watercolor strokes from the wet layer. The Wet Eraser is pressure sensitive. Pressing
heavily erases more quickly.

If you’ve “dried” the wet layer (by saving the image), use the regular eraser to remove the stroke from the
image.



Pure Water Brush

This variant behaves like the Water Brush Stroke variant except without adding color. Use this variant to
spread and blend the colors of existing watercolor strokes.



Spatter Water

This variant spatters water randomly with each stroke.



Broad Water Brush
This variant paints a wide brush stroke that shows its bristles.

See “Advanced Painting,” for ways to customize bristle brushes.




Large Water

This variant paints a broad wash of color.



Large Simple Water

This is a larger version of the Simple Water variant.



Diffuse Water

This variant produces a stroke with diffuse edges (refer to the description of Diffusion at the beginning of the
Water Color section).



Airbrush

The Airbrush applies a fine spray of color. The Airbrush covers underlying colors. Stylus pressure determines
the concentration of color.

See also:
Fat Stroke
Thin Stroke
Feather Tip
Spatter Airbrush
Single Pixel Air



Fat Stroke

The Fat Stroke variant covers a large area with a soft, anti-aliased paint stream.



Thin Stroke

This variant covers a smaller area than Fat Stroke.



Feather Tip

Feather Tip is a small sized variant that paints soft, anti-aliased lines of varied widths. The width variation is
more apparent when you widen the brush size.



Spatter Airbrush
The Spatter Airbrush introducing a random texture into the airbrush spray. This variant produces a semi-anti-
aliased stroke. Stylus pressure determines how much grain is revealed.

The results vary with different textures. Experiment with different textures and see how the brush stroke is
affected.



Single Pixel Air

This variant is a single-pixel brush. Color builds up based on pressure.



Pencils

Pencils are great for anything you’d use real pencils for—from rough sketches to fine-line drawings. Like their
natural counterparts, Pencils interact with canvas texture.

All the Pencils variants build to black. Pencils are pressure sensitive in terms of opacity. The Colored Pencils
variant is an exception. Colored Pencils have uniform opacity regardless of pressure.

With the Colored Pencils, 2B Pencil, Sharp Pencil, and 500 Ib. Pencil variants, dragging quickly produces a
thinner line; dragging slowly leaves a thicker line.

The thick-to-thin variation becomes more apparent as you increase the +Size setting on the Brushes palette:
Controls menu> Size palette.

See also:
Colored Pencils

Thick & Thin Pencils

2B Pencil

Sharp Pencil
500 Ib. Pencil

Single Pixel Scribbler



Colored Pencils

The Colored Pencils variant produces lines with semi-anti-aliased edges.



Thick & Thin Pencils

With this semi-anti-aliased variant, line width depends on the direction of your stroke.



2B Pencil

This variant is a soft lead pencil that produces thin, anti-aliased lines.



Sharp Pencil

This variant is a hard lead pencil with semi-anti-aliased strokes.



500 Ib. Pencil

The 500 Ib. Pencil creates fat, semi-anti-aliased lines.



Single Pixel Scribbler

The Single Pixel Scribbler has a one-pixel pencil point. Pressure affects opacity.



Built-in Brush Variants: Eraser

Detailer has two ways to remove color: the Eraser variants, which erase down to the paper color, and the
Bleach variants, which erase to white. Darkeners are Eraser variants that increase color density, building
colors toward black. Darkeners are the inverse of Bleach.

With all of the Eraser variants, pressure determines how much you erase. To erase lightly, press gently.

If you’re using a mouse, the Opacity slider controls how much you erase. With an eraser variant’s opacity at
100%, it will completely remove color in one stroke. With opacity low, the eraser removes color gradually.



Water

Water smudges and dilutes existing colors in the image. It doesn’t add any color. All of the Water variants are
pressure sensitive—the harder you press, the more you’ll smear the image.

The Water variants work in the image layer. They are not associated with the wet layer or the Water Color
variants.

See also:
ust Add Water
Grainy Water

Frosty Water
Tiny Frosty Water

Big Frosty Water
Single Pixel Water

Water Spray
Water Rake



Just Add Water

This variant smudges with smooth, anti-aliased strokes. It removes grain and responds to the velocity of your
stroke, smearing more when you drag slowly.



Grainy Water

This variant reacts to grain. It is ideal for smearing existing textured strokes because it helps them maintain
their graininess. You can also use it to add texture to smooth strokes.



Frosty Water

This variant smears with a hard-edged, brittle stroke. It interacts with the texture grain. Try choosing other
textures for some different results.



Tiny Frosty Water

This variant is a sharpened version of Frosty Water.



Big Frosty Water

This variant is a large version of Frosty Water.



Single Pixel Water

This is the smallest Water brush available, similar to wetting a single hair and using it to smear an image.



Water Spray

This variant sprays pixels of water onto the image.



Water Rake

This variant is a multi-bristle water applicator.



Chalk

Chalk produces the thick, rich texture of the natural pastel sticks. Chalk covers with strokes that interact with
grain.

The Chalk variants are pressure sensitive in terms of opacity. Adjust the Opacity slider to get the same effect
with a mouse.

See also:
Artist Pastel Chalk
Sharp Chalk
Large Chalk

Square Chalk
Qil Pastel



Artist Pastel Chalk

This variant produces a medium width, semi-anti-aliased stroke.



Sharp Chalk

This variant is a sharper version of Artist Pastel Chalk.



Large Chalk

This variant is a wider version of Artist Pastel Chalk.



Square Chalk

This variant uses a captured rectangular tip to produce a chiseled edge.



Oil Pastel

This variant slightly smears the underlying color. It uses a captured triangular tip to produce a chiseled edge.



Charcoal
Charcoal leaves covering strokes that interact with grain. Both Grain and Opacity are pressure sensitive.
See also:

Gritty Charcoal

Default Charcoal

Soft Charcoal



Gritty Charcoal

Gritty Charcoal gives deep-toned, semi-anti-aliased strokes. The width of the stroke depends on the direction
you drag.



Default Charcoal

This variant produces heavily textured, semi-anti-aliased strokes.



Soft Charcoal

Soft Charcoal produces a soft, anti-aliased stroke.



Pens
The Pens variants give you ink pens that never clog, spatter or run dry.
See also:

Fine Point

Smooth Ink Pen

Calligraphy

Pen and Ink

Flat Color

Scratchboard Tool

Scratchboard Rake

Pixel Dust

Single Pixel
Leaky Pen



Fine Point

The Fine Point variant produces a ballpoint pen stroke that reveals texture.



Smooth Ink Pen

This variant behaves like the traditional fountain pen. Strokes get darker as you layer them. Stroke width and
grain depend on pressure. Heavy pressure produces a wide stroke that penetrates the grain. Light pressure
produces a narrow stroke that reveals grain.



Calligraphy

The Calligraphy pen is great for stylized lettering. The line width varies with the direction of the stroke.
Heavy pressure produces a wide stroke; light pressure produces a narrow stroke.

Keep the Opacity slider in its default position for the most ink-like lines.

With variants where direction determines stroke width, you can set the angle where the width changes. See,
“Advanced Painting,” for information.




Pen and Ink

With the Pen and Ink variant, the width of the stroke is determined by how fast you drag. The faster you
drag, the thinner the lines become.



Flat Color

This variant lets you cover large areas with even color.



Scratchboard Tool

The Scratchboard Tool is smooth, anti-aliased and pressure sensitive.

To create a scratchboard drawing:
1 Open a new image and choose black as the paper color.
2 In the Materials: Color palette, select white, or any other color, as the primary color.

3 Now you can scratch out your design with this variant. Line width depends on pressure.

The Scratchboard variants work just as well with dark colors on a light background.



Scratchboard Rake

This variant is a multi-toothed version of the Scratchboard Tool. This brush is ideal for crosshatch shading.
Line width depends on pressure.



Pixel Dust

Pixel Dust sprays a random distribution of pixels.



Single Pixel

The Single Pixel variant draws with a single pixel brush.

This variant is not pressure sensitive.

Use this variant with the Straight Lines drawing style to draw single-pixel lines.



Leaky Pen

This variant leaves a scattering of drops, like you’d expect from a leaky pen. The slower you drag, the bigger
the drops.



Felt Pens

The Felt Pens variants draw smooth, anti-aliased lines that build toward black as you layer strokes. Pressure
determines opacity for all of the Felt Pens.

See also:

Fine Tip Felt Pens

Medium Tip Felt Pens

Felt Markers

Dirty Marker
Single Pixel Marker




Fine Tip Felt Pens

This variant draws narrow strokes.



Medium Tip Felt Pens
This variant draws medium-width lines. Drag quickly for a narrow stroke. Drag slowly for a wider one.

With variants where drag speed determines stroke width, you can adjust the width range and the
smoothness of transitions between wide and skinny in the Brushes menu> Controls menu> Size palette. See

“Advanced Painting,” for information.



Felt Marker
The Felt Marker produces a softer shade than the Felt Pens. The direction of the stroke determines its width.

With variants where direction determines stroke width, you can set the angle where the width changes. See,
“Advanced Painting,” for information.



Dirty Marker

The Dirty Marker produces shades that build toward black more quickly than those made with the Felt
Marker. The direction of the stroke determines its width.



Single Pixel Marker

This variant is a one-pixel Felt Pen. Pressure affects opacity.



Crayons

The Crayons produce semi-anti-aliased strokes that interact with texture and build up as you layer them.
Pressure determines opacity and grain.

See also:

DefaultDefault>(w95sec)

Waxy CrayonsWaxy_Crayons>(w95sec)



Default

This is a basic crayon.



Waxy Crayons

This variant smears the primary color with the underlying colors.



Retouchers

The Retouchers cover underlying colors. Typically you’ll use the dropper to sample a color from the image,
then use a Retoucher brush to cover aberrations in that area of the image. Stylus pressure determines the
concentration of color.

The Retoucher brushes are distinguished by two characteristics: size and softness. The sizes are small,
medium, and large. The dab edge softness levels are soft, medium, and hard.



Masking Brushes
M asking Brushes paint in the mask layer. They are described in Chapter 10, “Selections and Masks.”
Following are examples of how the masking brush strokes appear.
See also:
Masking Pen
Masking Airbrush
Masking Chalk
Grainizer

Single Pixel Masking Pen

Big Masking Pen



Masking Pen

The Masking Pen draws smooth, anti-aliased lines.The Masking Pen is pressure-sensitive in terms of stroke
width.



Masking Airbrush

The Masking Airbrush paints misty, anti-aliased strokes.



Masking Chalk

The Masking Chalk variant draws semi-anti-aliased lines that interact with the texture.



Grainizer

The Grainizer produces broad, grainy, anti-aliased strokes. The grain is based on the texture.



Single Pixel Masking Pen

The Single Pixel Masking Pen draws with a single pixel. This brush is useful when zoomed in.



Big Masking Pen

The Big Masking Pen produces broad, solid, anti-aliased lines. This brush is good for filling in large areas.



Image Hose

The Image Hose is a special brush that applies images instead of color. The images it paints come from
Nozzle files.

The following examples are previews of the default nozzles. For complete information on Image Hose
variants, creating Nozzle files, loading them, and controlling the Image Hose, see, “Using the Image Hose.”



Dodge
Dodge lightens the colors of the image.

Dodge is a photographer’s technique. A photographic print is made in the darkroom by projecting the
negative’s image onto light-sensitive paper. While making a print, a photographer might mask a small
portion of the image for a few seconds. The photographer keeps the mask moving, “dodging” it over the
paper, so that it won’t leave an outline. When the exposure is finished, the area that was dodged received
less light. When the paper is developed, the dodged area is lighter.



Burn
Burn darkens the colors of the image.

Burn uses the same technique as dodge, but with the opposite mask—one that covers most of the image.
The un-masked portion receives more light during the exposure, so it develops darker.



Cloners Brushes

The Cloners are a special set of brush variants. Cloners sample imagery from one area and reproduce it in
another.

Detailer offers a number of Cloners variants. Some reproduce imagery perfectly. Others introduce artistic
effects. Each variant is described later in this section.

Cloners work in the Canvas. You cannot use a Cloners variant to paint in a floater.

You can use Cloners variants in one of two ways:
* To paint with the current pattern.

* To replicate imagery within an image—from an area in the upper left to the center, for example. This is
called “point-to-point” cloning.

When you choose a Cloners variant and start painting, you’ll be painting with the current pattern. If you want
to do point-to-point cloning, you’ll need to set the origin.

See also:

Point to Point Cloning

Cloners Variants



Point-to-Point Cloning

To set the clone source location:
1 choose a Cloners variant.

2 With the Control key (Macintosh) or Shift key (Windows) held down, click in the source area in your image.
This is the origin for the clone sampling.

3 Move the cursor to the destination area and click. This establishes the source-destination relationship
between your two click points.

Now, painting in the destination region delivers imagery from the source region.



Cloners Variants

The variants of the Cloners brush behave like their “plain” brush counterparts—for example, the Chalk Cloner
produces the same effect as the Artist Pastel Chalk variant of the Chalk brush.

You can customize the Cloners variants with Detailer’s other customizing functions that are described in
“Advanced Painting,”

See also:
Felt Pen Cloner
Pencil Sketch Cloner
Hairy Cloner
Oil Brush Cloner
Chalk Cloner
Hard Oil Cloner

Van Gogh Cloner
Melt Cloner

Driving Rain Cloner

Straight Cloner
Soft Cloner

Impressionist Cloner



Felt Pen Cloner

This variant re-creates felt pen strokes that get darker as you paint over other strokes. To keep the colors
from darkening too quickly, move the Opacity slider in the Controls palette: Brush tool to the left.



Pencil Sketch Cloner

This variant imitates pencil lines. To get a quick-sketch effect with uneven lines, open the Brushes palette:
Controls menu> Random palette and move the Clone Location How Often slider all the way to the left.



Hairy Cloner

The Hairy Cloner paints like the Hairy Brush variant of the Brush, producing somewhat anti-aliased strokes
that show the brush’s “hair lines” and react to the grain. This brush is useful with oil painting.



Oil Brush Cloner

The Oil Brush Cloner gives you anti-aliased brush strokes that hide underlying ones. This is another good
brush to use with oil painting. Short strokes work best with the Oil Brush Cloner. How quickly you drag the
mouse or stylus determines the width of the stroke. Drag slowly for thick strokes, quickly for thin ones.



Chalk Cloner
This variant draws like the Artist Pastel Chalk variant of the Chalk brush.



Hard Oil Cloner

The Hard Oil Cloner gives you a harsh stroke with a hard edge that interacts with the grain and covers
underlying strokes. It’s good for oil painting and works best with short strokes. How quickly you drag the
mouse or stylus determines the width of the stroke. Drag slowly for thick strokes, quickly for thin ones. This
brush interacts with the current texture. Choose different ones in the Materials: Texture palette for unusual
results.



Van Gogh Cloner

This variant paints multicolored brush strokes in the style of Vincent Van Gogh.



Melt Cloner

The Melt Cloner melts an image so that it looks like it’s dripping, and works the way the Distorto variantin
the Liquid brush works. When you use this brush with oil painting, it looks like you applied paint with a

palette knife.



Driving Rain Cloner
This variant clones your image as it would look through a window during a rainstorm.

Here’s how it works:

After you choose the Driving Rain Cloner, click and drag the stylus or the mouse and you’ll see slanted brush
strokes that look like rain drops appear perpendicular to your stroke’s direction.



Straight Cloner

This variant duplicates the image without changing it. Simply click and drag and you’ll see the area around
the source point come through.



Soft Cloner

The Soft Cloner gives you airbrush-style strokes that softly recreate the source area. The edges of the Soft
Cloner brush are soft, allowing it to blend realistically with an existing background.



Impressionist Cloner

The Impressionist Cloner uses the directions of your brush strokes to place many short dabs in varied colors
based on the source point.

Detailer has all of these great brushes to create surface maps, but you can also customize your own brushes.
The next chapter describes all of the brush controls and how you can customize Detailer’s brushes for your
own specific needs.



Advanced Painting
See also:
Customizing Detailer’s Brushes
Brush Controls

Spacing Palette
Random Palette
Well Palette
Sliders Palette
Brush Methods

Fine-Tuning the Cloning Methods

Saving, Restoring and Deleting Brush Variants
Capturing Brushes

Creating a New Brush
Brush Libraries



Customizing Detailer's Brushes

All of Detailer’s brushes are adjustable in a myriad of ways. In fact, the default variants in the Brushes
palette are just saved settings from Detailer’s vast collection of brush controls.

While these default brushes do excellent work, you’ll probably want to adapt them to a particular need or
refine them to your own style. You can change brush size, shape, angle, how color flows from the tip, and
much, much more. This chapter describes the many features for customizing Detailer’s brushes.

Changes you make to brush variants, including the basic controls like size and opacity, apply only as long as
that variant is selected—they disappear as soon as you switch to another variant or select a different tool
(this ensures that the brushes are “clean” every time you reach for them). If you want to keep the changes, you
must save them. Detailer allows you to save customized brushes as the default variants, or as new brush
variants.

In this chapter you’ll learn...

* About dabs and strokes—Size, Spacing, Random and Well

* Making brushes sensitive to input using the Sliders palette

* About brush methods

* How to save custom brush variants and how to modify the default variants
e Captured brushes

* Creating new brushes and managing brush libraries.



Brush Controls

Although brush strokes appear as having continuous color, they are actually created by laying down a series
of closely spaced individual dabs. Detailer lets you control both the dab shape and the way it’s repeated to
create the stroke.

Controls of the dab are located primarily on the Size palette.

Controls for the stroke are located primarily on the Spacing palette.

The Random palette has one control for the stroke and several for the medium.

The Well palette controls the medium (usually color) that flows from the brush.

The Sliders palette can be used in many ways to change the behavior of the dab, stroke, and medium.
See also:

Size Palette



Size Palette

The Brush Controls: Size palette accessed from the Brushes palette: Controls menu> Size palette lets you
control the brush dab width and tip, for example, use the Size palette to sharpen your pencils.

See also:
Preview
Brush Tip
Build
Brush Control Size
£Size
Size Step
Adjusting the Angle

Dab Types




Preview

The Preview in the center of the palette shows how your changes affect the brush dab. Clicking in the
Preview lets you toggle between “hard” and “soft” views of the dab.

In the hard view, concentric circles show the minimum and maximum size of a brush. The inner (black) circle
shows the minimum dab width. The outer (gray) circle shows the maximum dab width. Remember that some
brushes vary the line width based on pressure or stroke speed. The difference between the diameter of the
two circles shows the range in which the stroke width will vary.

In the soft view, shading shows the density distribution of the brush tip. The density distribution describes
how much of the medium is conveyed by a given point on the brush dab. For example, an individual dab
made by an airbrush produces a soft-edged circular mark with minimum density at the outer edge of the
dab. Density increases inward to a maximum value at the exact center of the dab.



Brush Tips

The brush tip profile shows a cross section of density distribution across the diameter of the dab. You can
think of a brush tip profile as a bell curve graph representing the density spread across the brush dab.

Different mediums have different density distributions. Changes in the density distribution produce different
marking qualities in a brush stroke.

To change the density distribution, click the icon for the brush tip profile you want.
See also:

Pointed profile

Medium profile

Linear profile

Dull profile

Watercolor profile

1-Pixel Edge




Pointed profile

Pointed profile provides maximum density at the center with rapid fall-off to the edge.



Medium profile

Medium profile has a wide area of greater density at the center with rapid fall-off to the edge.



Linear profile

Linear profile provides maximum density at the center with an even fall-off to the edge.



Dull profile

Dull profile provides maximum density at the center with a high density weighting to the edge.



Watercolor profile

Watercolor profile provides maximum density at the outer edge in a ringlike fashion with medium internal
density.



1-Pixel Edge

1-Pixel Edge provides maximum density throughout with a rapid fall-off at the edge, producing a one-pixel,
anti-aliased edge.



Build

When you finish making changes on the Brush Controls: Size palette, you may need to click Build (if the
button is raised and highlighted) to create the brush shape. Pressing Command--B (Macintosh), or Ctrl+B
(Windows), or by choosing Brushes palette: Brushes menu> Build Brush also builds the brush.

Relax, some brushes may take a little while to build—especially if you’re working on a slower machine.
Larger dab and +Size values increase build time.



Brush Control: Size

The Size slider controls the width of the brush dab and, therefore, the brush stroke. Moving the slider to the
right makes a brush wider. Moving it to the left makes it narrower.

You don’t need to open the Brush Controls: Size palette to adjust the size of a brush. Use the brush sizing
shortcut: Hold down the Command--Option keys (Macintosh), or the Ctrl+Alt keys (Windows), and drag in the
document window. A circle that represents the brush diameter appears beneath the cursor. When you’ve
dragged the circle to the size you want, release the button. In some cases, the brush must be “built.” Press
Command--B (Macintosh), or Ctrl+B (Windows), to build the brush. If you try to paint with an “un-built” brush,
Detailer will alert you.

As size changes, you may need to adjust Spacing—especially if gaps appear in the stroke.




+Size
The =Size slider controls the difference between the minimum and maximum width of a stroke. Remember

that some brushes vary the line width based on pressure or stroke speed. The difference between the
diameter of the two circles shows the range the stroke width will vary. Moving the slider to the right increases

the difference between the narrowest and widest portions of a stroke.



Size Step

The Size Step slider controls the transition between the narrow and wide sections of a stroke. Moving the
slider to the right makes the transition appear more abrupt. Moving it to the left makes the transition
smoother.



Adjusting the Angle

Expand the Brushes palette: Controls menu> Size palette by clicking the grow box. The Angle Control
sliders appear.

See also:
Squeeze
Brush Control: Angle
Ang Rng
Ang Step




Squeeze

The Squeeze slider controls the shape of the brush dab. Squeezing a brush changes it from round to
elliptical. Moving the slider to the left makes a dab more elliptical and moving it to the right makes a dab
more round.

Squeeze and angle controls are not valid for Bristle and 1-Pixel dab types.



Brush Control: Angle
The Angle slider controls the angle of an elliptical brush dab. Moving the slider to the right rotates the dab
clockwise. Moving the slider to the left rotates the brush counterclockwise.

The angle describes the angle of the ellipse.



Ang Rng

The Angle Range slider lets you specify a range of dab angles that may appear in a brush stroke. Setting
this slider to 1800 means you can get every angle between 00 and 1800 in your stroke.

To take advantage of this feature, you’ll need to set up the brush to base the angle on some factor, like
stroke direction or randomness. You’ll do this in the Sliders palette.



Ang Step

The Angle Step slider controls the increment of change for brushes with an Angle Range greater than 0.
For example, setting the Angle Step to 50 means that you get a brush dab every 50 within the current angle
range setting. Moving the slider to the right results in fewer brush dab angles. Moving the slider to the left
creates more brush dab angles.



Dab Types

Brushes can have one of the following dab types: Circular, 1-Pixel, Bristle, or Captured. You can choose the
dab type for a variant you’re creating at the bottom of the expanded Size palette.

Circular
Circular dabs are controlled by the Size palette.
1-Pixel

A 1-Pixel dab consists of one pixel. You can’t change its size. You’ll use 1-pixel brushes mostly when you
zoom in to edit at the pixel level.

Bristle
When you select the Bristle dab, the soft view of the Preview on the Size palette displays a bristly dab.
Captured

Captured dabs are dab shapes that you create and capture with Brushes palette: Brushes menu> Capture
Brush, described later in this chapter.



Spacing Palette

A brush stroke is created with a series of dabs. By adjusting the spacing between dabs, you can control the
continuity of the brush stroke. To access the Brush Controls: Spacing palette, choose Brushes palette:
Controls menu> Spacing.

See also:
Spacing Size
Min Spacing
Stroke Types



Spacing/Size

The Spacing/Size slider controls the distance between the brush dabs in a stroke. When the Spacing/Size
slider is at 100%, the spacing equals the radius of the dab. For example, a dab that’s 10 pixels across is
repeated every 5 pixels. As the Spacing/Size slider is moved to the left, the distance between dabs is less
and they begin to overlap. Overlapping increases the density of the stroke and makes it look more
continuous.



Min Spacing

The Minimum Spacing slider specifies the minimum number of pixels between dabs. If you don’t want a
continuous stroke, move the Minimum Spacing slider to the right. In this way, you can create a dotted or
dashed line. Each dot or dash is made by one brush dab.



Stroke Types

Expanding the Brush Controls: Spacing palette reveals the Stroke Types buttons. The Bristles slider, at the
bottom of the palette, controls the number of dabs used for Multi-stroke and Rake brushes.

See also:

Single




Single
A Single stroke brush has one dab path.

You can use Bristle and Captured dabs with the Single stroke option to create the effect of multiple bristles.



Multi

A Multi-stroke is made by dragging a set of randomly distributed dabs. The several dabs leave strokes that
are not parallel, and they may overlap. Each time you apply a multi-stroke brush, the result may differ.

Each stroke in a Rake or Multi-stroke brush can have a different color. Increase Color Variability on the
expanded Materials: Color palette to color the strokes differently.

Multi-stroke brushes must be precomputed, which generates a delay in their appearance on the screen.
Because of this delay, Multi-stroke brushes, such as the Van Gogh brush, work best when you apply them in
short strokes.



Rake

A Rake stroke is made by dragging a set of evenly distributed dabs. The several bristles in a rake brush are
parallel to each other.



Hose

The Hose is a single stroke composed of the current Image Nozzle file. See Chapter 12, “Using the Image
Hose,” to learn more about the Image Hose and
Nozzle files.



Bristles

The Bristles slider controls the number of bristles or dabs used for Multi-stroke and Rake brushes.



Random Palette

Detailer uses randomness to introduce an “accidental” quality in color and stroke. Randomness contributes
to the appealing, unique look of artwork done in Detailer. You can control brush randomness with the
Advanced Controls: Random palette, accessed from the Brushes palette: Controls menu> Random.

Randomness of the primary color is controlled from the Materials: Color palette.
See also:

Dab Location Placement

Clone Location

Random Brush Stroke Grain

Random Clone Source



Dab Location Placement

The Dab Location Placement slider introduces a randomized jitter to the brush stroke. Instead of appearing
directly along the stroke, dabs appear randomly outside the brush stroke path. Move the slider to the right to
increase deviation from the stroke path.



Clone Location
The two Clone Location sliders work with brushes of the Cloning method.

A cloning brush takes color information from a specified source point, or the current pattern (by default), and
applies it to a destination area in an image.

Detailer’s cloning brushes move information from the current Pattern to the image or from one area of the
image to another.

See also:
Variability
How Often



Variability

When Variability is zero, the pixels of the source and destination images correspond precisely—using a
cloning brush at full opacity (and no grain) will simply recreate the source image.

Introducing a degree of randomness disturbs the pixel-to-pixel correspondence. The resultant variations in
the image distance the clone from its source point, which can contribute to the Natural-Media appearance.

The Variability slider lets you randomly offset the location where the clone brush samples the source. Moving
the slider to the right increases the range (distance) the sample may be offset.



How Often

The How Often slider controls the period between random offsets. Moving the slider all the way to the left
sets the period to zero—every sample is offset. This gives the clone image a rough, distorted look.

Moving the How Often slider to the right increases the period—samples are offset less frequently. This keeps
the clone’s appearance more like the source.



Random Brush Stroke Grain

Normally, when you make a brush stroke, the grain is fixed—the “bump” areas will always be bumps. Strokes
repeated over an area will bring out the same grain.

The Random Brush Stroke Grain option randomizes the grain beneath the brush. The Spatter Airbrush is an
example of Random Brush Stroke Grain brush.



Random Clone Source

Random Clone Source randomly samples from the specified source point, or the current pattern (by default).
There’s no correspondence between the samples taken from the source or pattern and where they are
placed on the destination. The result is a random effect of the predominant colors in the source or pattern.

The brush and stroke determine the nature of the source or pattern.



Well Palette

The Well palette controls how a brush conveys its medium (color) to the paper. The Resaturation, Bleed, and
Dryout controls work together to determine how much color a brush has at the start and finish of a stroke.

The Well palette has no effect on brushes that smear existing color, like the Eraser and Liquid brushes.
See also:

Resaturation
Bleed

Dryout



Resaturation

Resaturation controls the amount that color is replenished in a stroke. If Resaturation is zero, the brush will
never get any color. When Resaturation is below 10% (and Bleed is less), the brush stroke fades in gently.



Well Palette: Bleed

The Bleed slider controls how much the brush colors mix with the underlying colors—including the paper
color. Moving the slider to the right increases the extent of bleed.

When Bleed is higher than resaturation, more color bleeds than covers, so the stroke will never reach full
opacity.



Dryout

The Dryout slider determines how quickly a brush runs out of its medium. Dryout is measured in pixels.
Moving the slider to the left makes a brush’s reservoir empty more quickly. This can lead to brush strokes
that fade out gently.

When the slider is set to the far right, the brush never runs out of color.

Dryout works in conjunction with Bleed, so Bleed must be above zero to take advantage of Dryout. You can
modulate the Dryout effect by changing the Bleed setting.



Sliders Palette

The Advanced Controls: Sliders palette lets you control brush effects based on a number of input factors.
For example, many brushes vary their opacity or width in response to changes in stylus pressure. This is
merely their default setting. You can use the sliders to vary these effects in response to other factors, like
stroke direction or velocity. This is the kind of modification you’ll want to make if you’re using a mouse to
draw with and don’t have access to pressure information.

The Sliders palette is set up as a matrix. Drag the slider for one of the eight main brush components to link it
to one of the eight control factors.

See also:

Control Factors

Brush Components



Control Factors

Control factors determine how the brush component is adjusted.
Random

Random adjusts the component at random.

Source

Source adjusts the component based on the luminance of the current Pattern. Higher luminance (closer to
white) increases the setting for that component—for example, a wider stroke.

Bearing

Bearing adjusts the component based on the direction in which the stylus points. Not all stylus models
convey this information.

Tilt

Tilt adjusts the component based on the angle of the stylus from the tablet. Not all stylus models convey this
information.

Pressure

For pressure sensitive tablets, Pressure adjusts the component based on stylus pressure. Greater pressure
increases the setting for that component.

Direction
Direction adjusts the selected brush component based on the direction of the stroke.
Velocity

Velocity adjusts the component based on the dragging speed. Dragging quickly minimizes the setting.
Dragging slower increases it.

None

None applies no adjustment to the component.



Brush Components
Size

The Size slider determines how Detailer should vary the width of the brush stroke. The range from minimum
to maximum is determined by the xSize slider in the Brushes palette: Controls menu> Size palette. The
most common source for size variance is Pressure. The Scratchboard Tool is a good example of a brush with
Size based on Pressure.

Jitter

The Jitter slider determines when (how often) Detailer should jitter the brush stroke. The amount of jitter is
controlled by the Dab Location Placement slider on the Brushes palette: Controls menu> Random palette. A
typical source for controlling jitter is Velocity. Jitter will reduce as the brush speeds up.

Opacity

The Opacity slider determines how Detailer should vary the density of the medium. The Opacity slider in the
Controls palette: Brush tool will establish the maximum opacity of the brush. The opacity of the Airbrush is
determined by pressure. More pressure yields more opaque strokes.

Grain

The Grain slider determines where Detailer should reveal texture in a brush stroke. The Grain slider in the
Controls palette: Brush tool sets the maximum amount of grain in the brush. The Colored Pencil variant has
its Grain component determined by pressure. Increasing pressure causes the pencil to “dig into” the paper.

Color

The Color slider determines where Detailer should use the primary or secondary color. Set Color to direction
and Detailer will paint with two colors, depending on the direction of your brush strokes.

Angle

The Angle slider determines how Detailer orients the brush dabs. The Ang Rng setting in the Brushes
palette: Controls menu> Size palette must be greater than 0.0 and Squeeze must be less than 100% in order
for brush angles to vary. The Impressionist and Qil Pastel variants will change dab angles based on the
direction of the stroke.

Resat

The Resaturation slider determines how Detailer controls resaturation—how much color is replenished in a
stroke. When used in conjunction with Bleed, setting the Resat component to Pressure can create a brush
that behaves like a drying marker.

Bleed

The Bleed slider determines how Detailer controls bleed—how much colors mix. When used in conjunction
with Resat, setting the Bleed component to Pressure can create a brush that behaves like a drying marker.



Brush Methods

The brush method describes the basic nature of a brush. All of the many brush control settings flow through
the method to determine the brush effect.

Understanding the methods and being able to vary them gives you more options for creating new brushes or
editing existing ones. For example, some brush controls and effects are invalid under certain methods, so by
changing the method, you can radically alter a brush.

To display the methods, click the grow box on the Brushes palette. You can change the method category and
subcategory from the menus.

There are seven method categories: BuildupBuildup>(w95sec), CoverCover>(w95sec),
EraserEraser>(w95sec), DripDrip>(w95sec), MaskMask>(w95sec), CloningCloning>(w95sec)
WetWet>(w95sec).

See also:

Method Sub-Categories
Cloning Methods



Buildup

The Buildup methods produce brush strokes that build toward black as you overlay them. Felt Pens are an
example of buildup brushes.



Cover

The Cover methods produce brush strokes that cover underlying strokes. Chalk is an example of a cover
brush.



Eraser

The Eraser methods either erase, lighten, darken, or smear the underlying colors.



Drip

The Drip methods interact with the underlying colors to distort the image.



Mask

The Mask methods paint directly into Detailer’s masking layer. You can also use any of Detailer’s brushes

in View Mask Mode to paint into the mask. Masking is covered in detail in Chapter 10, “Selections and
Masks.”



Cloning

The Cloning methods take a source imagery (from the current Pattern or somewhere else in the image)
and re-create it in another medium.



Wet

The Wet methods produce watercolor effects.



Method Sub-Categories

Each method category is further divided by its subcategories. The following terms are used in describing the
subcategories:

* Soft methods produce smooth, anti-aliased strokes.
* Flat methods produce strokes with hard, “pixellated” edges.
* Hard methods provide brush strokes with semi-anti-aliased edges

In a few instances, you’ll see the words Edge and Variable in a method. Edge means strokes are thick and
sticky looking. Variable means a brush stroke starts off a bit more transparent.

Last, there’s Grainy. It means the brush reacts to the grain.

So putting together the method categories and their subcategories results in the specific brush methods. For
instance, Grainy Hard Cover means that brush strokes interacts with the current texture and have semi-anti-
aliased strokes that hide underlying ones. Grainy Hard Cover is the default method for Chalk and Charcoal
brushes.



Cloning Methods
Hard Cover Cloning
Gives you semi-anti-aliased brush strokes that hide underlying strokes.
Soft Cover Cloning
Produces anti-aliased brush strokes that cover layered ones.
Grainy Hard Cover Cloning
Works like Hard Cover Cloning but brush strokes also interact with paper grain.
Grainy Soft Cover Cloning
Works like Soft Cover Cloning but brush strokes also interact with paper grain.
Drip Cloning
Pushes color around as if it were wet, cloning the original with distortion based on your stroke.



Fine-Tuning the Cloning Methods

Four settings on the Random palette, found under the Brushes palette: Controls menu> Random, can affect
the results of the cloning methods.

* Moving the Clone Location: Variability slider to the right softens brush strokes and works best with the
bristle brushes for creating an impressionistic effect.

* Moving the Clone Location: Variability slider a bit to the right and the Clone Location: How Often slider to
the left gives drawing tools a sketchy feel.

e Clicking Random Clone Source makes the cloning methods randomly pick up pieces from the specified
source point or the current pattern (by default). What you get with your brush is random snippets of the
image.

e Clicking Random Brush Stroke Grain makes the cloning methods pick up paper grain at random from the
current paper grain.

See “Random Palette,” for more information about these settings.

See also:

Changing Methods



Changing Methods

It’s good to know how to juggle methods. Lets say you want a Charcoal-looking stroke, but instead of hiding
underlying strokes, you want brush strokes to muddy to black. you can get this effect by changing the
method to Grainy Hard Buildup.

Now let’s say you want a smoother, anti-aliased stroke. Change the method to Grainy Soft Buildup. The
stroke still isn’t quite right—you don’t want to see the texture. So you choose the Soft Buildup subcategory.
Your stroke has smooth, anti-aliased edges and turns builds to black. Soft Buildup is the default setting for
Medium Felt Tip Pens. You can change the method category and subcategory by using the pop-up menus.



Saving, Restoring and Deleting Brush Variants

When you’ve customized a brush the way you like it, you can use it immediately. Unless you save them,
changes you make to brushes disappear as soon as you switch to another variant or brush. If you want to
keep a brush, save it—either as a variant to an existing brush or a variant to a new brush. These options are
called: Save Variant and Save Built Variant.

See also:
Save Variant
Save Built Variant
Restore Default Variant

Delete Variant



Save Variant

This command creates a new variant under the current brush category. For example: You started with the
Pencil brush and modified it to resemble a grease pencil. Choose Brushes palette: Brushes menu> Variants>
Save Variant and Detailer opens a dialog where you can name the variant “Grease.” From now on, you’ll find
your Grease Pencil alongside Detailer’s default Pencil variants.

To save the current brush settings as a variant of the selected brush in the current library:
1 choose Brushes palette: Brushes menu> Variants> Save Variant.

2 Detailer will prompt you to name the variant. Type a name, then click OK.
Your new variant will now appear on the variant pop-up for the current brush category.

Each brush may hold up to 32 variants. It’s easier to find the variant you’re looking for when the list is
shorter. You can manage the number of variants under a brush by creating new brushes and adding variants
to them. Saving new variants to new brushes in new libraries will also help Detailer manage memory.




Save Built Variant

This command saves your changes to the current variant. This is the command you’ll use to modify
Detailer’s default variants. For example, you might decide that the Qil Paint brush variant is too big. Select it

and modify the brush size. Choose Save Built Variant. From now on, you’ll find the Oil Paint variant as you
defined it.

To save changes to an existing variant:

Choose Brushes palette: Brushes menu> Variants> Save Built Variant. Your changes are incorporated in the
variant.

If you change one of Detailer’s built-in variants, then decide that you want the original back; choose the
Restore Default Variant feature described below.



Restore Default Variant

Restore Default Variant allows you to return the current variant to the factory settings.

To restore the default variant:
Choose Brushes palette: Brushes menu> Variants> Restore Default Variant.



Delete Variant

Delete variant lets you remove an unwanted variant from the current brush. Remember, if you delete one of
Detailer’s default variants from the default Brushes library, you will have to reinstall Detailer to get it back.

To delete a variant:
1 Choose the variant from the Variant pop-up menu.

2 Choose Brushes palette: Brushes menu> Variants> Delete Variant. Detailer asks you to confirm that you
want to delete the variant. Click Yes to delete the variant.



Capturing Brushes

You can create your own brush shapes. Any brush shape is possible.

To create a brush shape:

1 0n a white background, draw the brush shape in black. If you like, use shades of gray to define partially
transparent areas of the brush.

2 Choose the Rectangular Selection tool.

3 Hold down the Shift key and drag across your brush shape to create a square selection.

Detailer uses the selected area to map the brush size. When the brush is built, this area is sampled to
compute each brush dab.

4 Choose Brushes palette: Brushes menu> Capture Brush.

5 Take a look at the brush dab in the Brushes palette: Controls menu> Size palette. Change its size, squeeze,
and angle, if necessary. Click Build if Detailer doesn’t automatically build your brush.

6 Draw with the brush. If you like the results, save it as a new variant.

When the original area must be scaled to the size of the brush dab, sampling can appear aliased. The greater
the scaling, the more aliasing will be apparent. To prevent this, create a shape with soft (grayscale) edges
and draw it close to the size you’ll use it.

Important Tip: When creating a brush that responds to direction and pressure, orient the brush shape toward
three o’clock.




Creating a New Brush

You can add your own brush categories to Detailer’s Brushes palette. You might want to create a brush if
you’ve customized a medium and you wanted to keep its tools organized. Your new brush will appear at the
same level as Pencil, Chalk, Crayons, etc.

1 Draw a small image to use as the palette icon for the new brush.

2 Choose the Rectangular Selection tool.

3 Hold down the Shift key and drag across the image to create a square selection.
4 Choose Brushes palette: Brushes menu> Variants> Save Brush.

5 Detailer will prompt you to name the brush. Type a name, then click OK.
Your new brush and its icon now appear on the Brushes palette.

When you create a new brush, it starts with zero variants. The first thing you’ll want to do for your new brush
is to create and save some variants to it.

For efficiency on systems with limited RAM, keep brush libraries small. Detailer will be more efficient if you
store the brush variants you create into several libraries. When you want to use these special brushes, load
the alternate libraries.



Brush Libraries

A library is a saved collection of similar tools. For example, Detailer’s built-in brushes (and their variants) are
contained in the default brushes library.

You can create new libraries for brushes and add your custom brushes to them. You can create as many
brush libraries as you want, but only one will be open at a time.

For information on loading alternate libraries and managing the contents of your libraries, see “Libraries and
Movers” in Chapter 1, “Getting Acquainted with Detailer.”.

It’s a good idea to limit the number of brushes in a library. This makes it easier to find a particular brush and
helps Detailer manage memory.

Brushes are loaded into memory when you launch Detailer, so adding brushes to the default brush library
increases Detailer’s need for RAM. If you are working close to the memory threshold, you’ll want to organize
new brushes into secondary libraries. When you want a different brush set, switch libraries. This will help
Detailer be efficient with memory.




Selections and Masks

Selections and masks are features to help you develop imagery. They increase your control over where you
paint and apply effects.

Selections and masks have a close relationship. Both features work by isolating areas; however, they differ in
the way they’re created and what you do with them. Some operations in Detailer require a mask, others work
only with a selection. Depending on the artwork, sometimes you will choose to work with the mask and
sometimes the selection is a better choice. You can easily convert between a mask and selection, so no
matter which way you start working, you can achieve the same result.

See also:
Selections
Mask

Working with Selections

Masking




Selections
Selections are areas of an image that you isolate—either to copy, float, or apply effects.

You may create selections in image windows, but not in the Model Window. If you create a selection in an
image window, you can switch to the Model Window and your selection will remain active.

Selections are enclosed by a moving line of black and white dashes, called the selection marquee, or «
marching ants.” You can exclude a region within the enclosure by creating a negative selection. Negative
selections “cut holes” in the regular, positive selection. On screen, negative selections appear in the image
window as red marching ants. Selection paths are not displayed in the Model Window.

Negative selections are generated by the Lasso tool, set to Subtract From Selection in the Controls palette.




Mask

The mask is an 8-bit overlay that protects image areas from changes or encloses areas to be changed. When
a selection is created, the mask responds to the selection according to how the Drawing buttons are set,
masking inside or outside of the selection.

The background (canvas) mask can also be used to control the appearance of floaters. By setting options for
a floater, you can use the canvas mask to conceal or reveal part of the floater.

See, “Floaters,” for more information on floaters and floater/canvas mask interaction.

Each floater has its own mask. In a floater, the mask determines the visible region of the floater. By
modifying the floater’s mask you can change the shape of a floater.

See also:

Drawing and Visibility Modes

Drawing Modes
Visibility Modes



Drawing and Visibility Modes

For working with the canvas mask and selections, Detailer has three drawing and three visibility modes. The
controls for these modes appear in pop-ups in the bottom left of the image window.



Drawing Modes

The Drawing buttons determine whether the inside or outside of a selection is protected when you paint.
Mask Disabled

The mask is turned off. Brush strokes are allowed anywhere in the image.

When you paint in the Model Window, your brush strokes obey the drawing mode.

Masked Inside

The mask protects the areas it covers. Opaque areas of the mask prevent brush strokes from reaching the
canvas. Clear areas of the mask allow brush strokes to go directly to the canvas. Where the mask is shaded,
a portion of the brush stroke is applied semi-transparent.

Masked Outside

Masked Outside inverts the mask. Only the masked regions accept brush strokes.



Visibility Modes

The Visibility buttons control how the mask appears in your image. The modes allow you to convert between
mask and selection.

Clear View
In this mode, you won’t see the mask; however, it will still function according to the drawing mode setting.
View Red Mask

The mask is displayed as a red overlay in the image window. Brush strokes will reach the canvas only where
you can see through the mask.

This mode has two main uses: to allow you to see where the mask protects the image and to allow you to
paint in the mask.

In this mode, you can see the mask invert when you switch between Masked Inside and Masked Outside
drawing modes.

Detailer offers one other way to view the mask—Edit Mask mode. This feature and methods of working with
Edit Mask mode appear later in this chapter.

View Selection
The mask is displayed as a selection. By choosing this visibility mode, you can convert a mask to a selection.

A selection is active only when the ants are marching. Detailer must be in this mode to create, cut, float, or
apply an effect to a selection.

In most cases, Detailer sets the visibility mode automatically, according to the tool or command you use.
A shortcut between modes

When working with a selection in View Selection mode, you can immediately set Detailer to Mask
Disabled/Clear View by choosing Edit menu> Deselect. You can then proceed without interference from the
selection or mask.

When you want the selection back, choose Edit menu> Reselect. Detailer switches to Masked Outside/View
Selection.



Working with Selections
In this section, you’ll learn how to create selections. Selections work only in image windows.
See also:

Creating Selections

The Selection Tools

Converting a Mask to a Selection
Creating a Selection Using the Magic Wand



Creating Selections
To select the entire image, choose Edit menu> Select All.
If you want to select a portion of the image, you can specify the selection path in any of several ways:

* By using one of the selection generating tools, the Rectangular Selection tool, the Oval Selection tool, or
the Lasso tool

® By creating a mask and converting it to a selection (choosing the View Selection Visibility button)
* By using the Magic Wand.

You may not create a selection inside a floater. You can get around this restriction by copying the floater to a
temporary image and dropping it there.




Using The Selection Tools

You may use the Rectangular Selection tool, the Oval Selection tool, or the Lasso tool to create selections.
The Rectangular and Oval Selection tools

Choose the Rectangular or Oval Selection tool on the Tools palette.

The Rectangular or Oval Selection tool icon “pops up” to let you select the other version. You may also switch
between the tools using the icons on the Controls palette: Selection tools.

Position the cursor in the image and drag diagonally. When the selection is the size you want, let up. Hold
down the Shift key to constrain to a circle or square. The Controls palette provides information on the size
and location of the selection you create.

After creating a rectangle, you can move any corner by holding down the Control key (Macintosh) or the
CtrlI+Alt keys (Windows) and clicking on the corner point you want.

See also:

Using the Lasso tool



Using the Lasso tool
Choose the Lasso tool on the Tools palette.
The Controls palette: Lasso tool offers three modes for creating selections:
New—Each path you draw creates a new selection, while disabling any previous selection.
® Add to Selection—Each path you draw is added to the current selection.

® Subtract from Selection—Each path you draw becomes a negative selection path, which voids any portion of
the current selection that it overlaps.

With the Lasso tool, you can draw freehand around the area you want. When you let up, Detailer closes the
path and converts it to a selection.



Converting a Mask to a Selection

In some cases, you might prefer to use masking tools to create a mask, then convert it to a selection. The
many methods of creating a mask are covered later in this chapter. After creating a mask, you can convert it
to a selection by choosing the View Selection visibility mode. Refer to * Drawing and Visibility Modes,” earlier in

this chapter for more information.




Creating a Selection Using the Magic Wand

Pixels come in related groups of colors based on hue, saturation, and value. The Magic Wand allows you to
select an area based on color similarity. You can adjust Painter to accept a narrow or wide range within one or
several color groups.

To select part of an image with the Magic Wand:
1 choose Edit menu> Magic Wand. The Magic Wand dialog appears and the cursor becomes a Magic Wand.

21In the image window, click or drag the Magic Wand over the color group you want to select. The HSV
sliders in the Magic Wand dialog box change, reflecting the range of selected colors. The Magic Wand
selection will now be displayed as a colored mask.

You can add to the selected area in two ways:
* Hold down the Shift key and click or drag over additional areas in the image.

Adjust the HSV sliders to increase the range of colors. The colored regions of the HSV sliders describe each
selected range. You can drag the limits of a range in either direction. As you work, the mask shows your
changes to the selection.

By default, the Magic Wand selects only contiguous areas in the image. If you want to find all pixels of a color
group, select the area with the Rectangular Selection tool before using the Magic Wand.

3When you’re satisfied with the masked area, click OK. Painter selects that area.



Masking
The canvas has a mask layer, and each floater carries its own mask. These masks have four main functions:

®* The canvas mask protects areas of the canvas from brush strokes. This function depends on the drawing
mode—Masked Inside, Masked Outside, or Mask Disabled. See “Drawing and Visibility Modes,” at the
beginning of this chapter, for more information.

* The canvas mask can also be used to control the visibility of floaters. By setting options for a floater, you
can use the canvas mask to conceal or reveal parts of the floater. In this way, you can interweave floater
images with the background. See “Floaters,” for more information.

® The canvas mask can be converted to a selection by choosing the View Selection visibility mode. This
enables you to float the masked area or apply effects to it. Detailer’s sophisticated masking tools make it
easy to create complex selections.

* The floater mask controls what portion of the floater is visible. See “Eloaters,” for more information.

For the canvas and floater, the mask is an
8-bit “image” you can modify. By changing the mask, you can control any of the functions described above.

At any moment, there is one canvas mask. To view it, select the View Red Mask visibility icon. By default,
Detailer displays the mask in red. Un-masked areas show through to the canvas image.

When in View Red Mask mode (as opposed to Edit Mask mode), floaters cover the canvas mask. You might
want to hide the floaters to see the mask completely. To hide floaters, click the eye icon next to the floater
listing in the Floater List palette.

You may also view the mask by putting Detailer in  Edit Mask mode. Click the color spectrum icon near the
top, right corner of the image window. The icon becomes a black circle and the image window displays the
mask as a grayscale image. You may also enter Edit Mask mode by choosing Canvas menu> View Mask.
When you’re finished in Edit Mask mode, click the icon again to return to Image mode. You may also choose
Canvas menu> View Mask again.

You may also use Edit Mask mode to view an image floater’s mask. First select the floater, then click the
color spectrum icon to choose Edit Mask mode.

With a floater selected, in Edit Mask mode you can apply effects to the floater’s mask. When you’re finished,
click the Edit Mask mode icon again to view how your changes affected the floater.

See also:

Creating and Editing Masks
Creating a Canvas Mask from a Selection

Basic Masking Commands
Automatic Masking Features

Using Edit Mask mode
Painting into a Mask




Creating and Editing Masks

Detailer provides several ways to generate and modify masks. Many of the tools work in a floater’s mask as
well as the canvas mask.

When no floater is selected, you will modify the canvas mask.

When a floater is selected, you will modify the floater’s mask.

* The easiest way to set up a canvas mask is from a selection. Selections translate directly to the mask.
Selections are not allowed inside of floaters.

* You may generate or modify a mask with one of the automatic masking features.

¢ In Edit Mask mode, you may paint the mask with any brush variant and apply effects to the mask image.
* You may paint the mask manually using any Masking brush variant.

* You may fill the mask using the Paint Bucket tool.

* You may modify a mask when you paint with the Image Hose. Enable the option Add to Mask on the Nozzle
palette before painting. For more information, see “Using the Image Hose.”

* You may modify the canvas mask when you drop a floater. Enable the option Drop with Mask on the Floater
List palette before dropping.

* You can also acquire a canvas mask by opening a Detailer rendering or by opening an image created in
another program.

Ray Dream Designer renderings, Painter and Adobe Photoshop documents may contain a mask. All Detailer
renderings include a mask of the model.

When importing into Detailer, Photoshop files must be in RGB or Grayscale mode. For RGB images, Detailer
will use any mask information contained in channel 4.




Creating a Canvas Mask from a Selection

You may convert a selection to a mask.

To convert a selection to a mask:

1 use any tool or method to create a selection.

2 Set the visibility mode to View Red Mask. The selection now forms the canvas mask.

Depending on your plans, you may want to change the drawing mode to view the mask in the inverse.



Basic Masking Commands

Clearing the Mask

If you want to clear the mask, choose Edit menu> Mask> Clear Mask.
Inverting the Mask

If you want the mask inverted to change the control of your brush strokes, you can switch the drawing mode
between Masked Inside and Masked Outside.

To actually invert the mask image, choose Edit menu> Mask> Invert Mask.
Feathering a Mask

You can feather a mask to soften the transitions between masked and un-masked areas.

To feather a mask:

1 Choose the View Red Mask visibility mode. Viewing the mask isn’t necessary, but it helps by showing the
effect of your changes.

2 Choose Edit menu> Mask> Feather Mask. The Feather Mask dialog appears.

3 Enter the number of pixels you want to feather your mask, then click OK.

If the effect is not what you intended, choose Edit menu> Undo and try again with a different feathering
radius.

Measuring Mask Density

You might want to measure the density of the canvas mask at a given point.

To measure mask density:
1 select the Dropper tool and display the Controls palette.

2 Hold down the Shift key and click on the point of the canvas where you want to measure the mask.
The Controls palette: Dropper shows values for the mask at that point.
The V text field describes the mask as a percentage. Lower values correspond to a denser mask.

The RGB text fields describes the mask level. Each mask pixel is defined with 8 bits of data. This gives 256
levels (255-0) of mask density. The RGB value 255 means the sampled pixel is unmasked. Lower values
correspond to a denser mask, with zero being completely masked.



Automatic Masking Features
Auto Mask

Auto Mask creates a mask based on your choice of image characteristics. The Invert option allows you to
invert the mask you create.

To generate an Auto Mask:
1 choose Edit menu> Mask> Auto Mask. The Auto Mask dialog box appears.

2 Use the Using pop-up menu to choose which image characteristics to base the mask on. The options are
described below.

3 When you’ve chosen an option, click OK to generate the mask. Once the mask is generated, view it by
choosing the View Red Mask Visibility button.

Auto Mask Texture

Texture creates a mask using the current texture. This is useful when you apply effects based on Mask.
Image Luminance

Image Luminance creates a mask based on the current image’s light and dark areas. Luminance will
efficiently mask high contrast photographs.

Pattern Luminance

Pattern Luminance produces a mask in the current image based on the current pattern’s light and dark
areas.

Current Color

Current Color creates a mask protecting pixels of the current primary color. Enabling the Invert option means
that everything but the current color will be masked.

You might want to use the Dropper tool to pick a color from the image before using this command.
Color Mask

The Color Mask feature lets you create a mask based on a range of colors.

To generate a color mask:
1 choose Edit menu> Mask> Color Mask. The Color Mask dialog box appears.
2 Click in the image to pick up the central color of interest.

3Adjust the HSV Extent sliders to control the range of colors. The colored regions of the HSV sliders
describes the selected range. You can drag the limits of the range in either direction.

4Adjust the HSV Feather sliders to control the feathering at the edges of the color space extents in hue,
saturation, and value, respectively. This can help soften the mask edge.

Watch the effect of your slider changes in the Preview Window. Drag the image in the Preview to see other
parts of the document.

Use the Inverted option to mask everything but the color you select.

5 When the mask looks the way you want it, click OK.



Using Edit Mask mode

Edit Mask mode allows you to work in the mask as though it was a regular image. Working in Edit Mask
mode offers three advantages:

* You can see the mask of the canvas or floater as a grayscale image.
* You may use any brush variant to paint or modify the mask.
* You may apply effects to the mask image.

The only disadvantage to working in Edit Mask mode is that you can’t see the color image. To see the color
image and the mask, use the View Red Mask visibility mode.

Because of the close relationship between selections and the mask, the Rectangular Selection tool is the only
selection feature allowed in Edit Mask mode.

To use Edit Mask mode:

1if you want to work with a floater’s mask, select the floater. If you want to work with the canvas mask,
deselect all floaters.

2 Click the color spectrum icon near the top, right corner of the image window. The icon becomes a black
circle and Detailer displays the mask as a grayscale image. You may now paint in the mask and apply affects.

3When you’re finished in Edit Mask mode, click the icon again to return to Image mode.

When a map is in Edit Mask mode, the mask image appears on the object in the Model Window.

To paint into the mask in Edit Mask mode:
1 Click the Edit Mask icon to enter Edit Mask mode.

2 Choose any brush and paint. Because you can see the mask as a grayscale image, you can tell what value
color to use to paint. Paint with black to extend the dark areas of the mask. Paint with white to extend the
light areas.

To apply an effect to the mask:

When the image is in Edit Mask mode, you may use effects to modify the mask. Some of the most useful are
Effects menu> Tonal Control> Brightness/Contrast and the Focus effects.

When working in Edit Mask mode, use the Brightness/Contrast effect to increase (spread) or reduce (choke) a
feathered mask.




Painting into a Mask: The Masking Brushes

Another way to create or modify a mask for a floater or the canvas is by painting with one of the Masking
brushes. These brushes paint only into the mask layer, so Detailer automatically sets to View Red Mask when
you choose one of them.

You can paint a canvas mask in an image window or on a model in the Model Window. You cannot paint in a
floater or floater mask in the Model Window. To edit a floater mask, you must work in the image window.

* When no floater is selected, you will modify the canvas mask.
* When a floater is selected, you will modify the floater’s mask.
* The value of the primary color controls the mask density.

When you paint with a Masking brush, you use white, black, or a shade of gray as the primary color. This is
because the mask carries 8 bits of information and you need only to set a level in that range.

See also:

In the canvas mask

In a floater mask

Masked Outside
Filling the Mask



In the canvas mask

When the drawing mode is set to Masked Inside or Mask Disabled, painting in a mask with black creates
opaque areas. Painting with white erases the mask. And using a shade of gray gives you a relative level of
opacity.

Because Masked Outside drawing mode inverts the mask, it also transposes the effects of painting with black
or white. In this case, painting with black erases the mask and painting with white adds to it.



In a floater mask

In a floater, the masked region establishes the visibility of the floater. You can change the extent of a floater
image by modifying its mask. The Masking Modes on the Floater List palette affect the way the Masking
brushes behave in a floater, these modes will be discussed in the next chapter. The following example
illustrates only the default state of a floater.



Masked Outside

Masked Outside is the default state of a floater. In this mode, only the masked region of the floater rectangle
is visible. The background image shows through the un-masked regions.

Painting with black adds to the mask and reveals more of the floater rectangle, which hides more of the
background.

Painting with white erases the mask and conceals more of the floater rectangle, which reveals the
background.

The color that the mask appears in View Red Mask mode is not associated with the primary color you paint
with. The mask image appears in red by default.

To paint with a Masking brush:

1 choose a Masking brush from the Brushes palette. Detailer sets the visibility mode to View Red Mask. You
must view the mask to paint with a Masking brush.

Detailer comes with a set of masking brush variants; however, any brush can be turned into a masking tool
by changing its Method Category to Mask. The Mask brush method applies brush strokes only to the mask
layer. See Chapter 9, “Advanced Painting,” for more information on brush methods.

You may also use almost any brush when working in Edit Mask mode, without setting the method to Mask.

2 Check the drawing mode.

Use either Mask Disabled or Masked Inside if you want to start with a clear mask and paint to add the
masked area.

Use Masked Outside if want to start with a solid mask and paint to erase portions of it.

Remember that you can invert the mask. You can start in one drawing mode, then invert the mask, and
continue in the other mode.

3 Select black, white, or a grayscale value as the primary color. Paint in the image to modify the mask.

In the canvas mask, you’ll see the strokes appear in the red mask color. In a floater, you won’t see the
strokes directly; however, you will see their effect as the floater image shrinks or grows beneath your brush.

See also: Masking Pen



Filling the Mask

Most often you will fill in the mask to create special effects.

To fill in the mask:

1 choose the Paint Bucket tool.

2 In the Controls palette: Paint Bucket tool, select Mask for What to fill and choose the medium to fill with.
3 Set Detailer to the View Red Mask visibility mode or Edit Mask mode.

4 Click in the region you want filled.



Floaters

See also:
What are Floaters?

Creating Image Floaters

The Floater List

Moving Floaters

The Composite Method: A Floater’s Special Effects

Using Floaters
Floater Mask

The Floaters Palette
Working with Reference floaters
Floaters for creating WWW Image Maps




What Are Floaters?

Floaters are images, or portions of images, that float above the canvas. You can copy and move floaters
around in the document to create just the composition you want.

Each floater is a separate image, so each floater you add to a document introduces another layer of
information. Because each floater is distinct, you can move them around and edit them without interfering
with the canvas image—or other floaters. Likewise, you can work in the canvas without interfering with any
of the floaters.

This is a huge advantage when positioning imagery on your model. You can use the Floater Adjuster tool to
drag a floater exactly where it belongs on the model. Any piece of imagery—a label on a bottle or the
number on the side of a race car, should be added as a floater.

In RIFF or Photoshop 3 format, floaters stay floating even when you save the file, so you can make changes
easily. There’s no need to redo the entire composition; just
rearrange the floaters. The result is a dynamic and flexible design environment.

Because you can manipulate floaters independently, they are considered image objects. Features for working
with floaters are available from the Materials
palette: Object menu.

Detailer offers two kinds of floaters: image and reference.
See also:

Image Floaters
Reference Floaters

More About Floaters



Image Floaters

Image floaters are discrete images that float above the canvas. Image floaters are stored as pixel information
with a mask to define the image shape and opacity. You may paint and apply effects in Image floaters.

Image floaters (or “floaters™) are used primarily for compositing images—moving portions of an image within
a document, moving images between documents, and maintaining layers within a document.



Reference floaters

Reference floaters are temporary, low-resolution versions of Image floaters. You’ll convert a floater to a
Reference floater when you want to transform it (rotate, resize, slant) by dragging its handles. When you’ve
finished with such transformations, convert the Reference floater back to a floater.



More about Floaters
Image and Reference floaters have the following characteristics in common:

* They are subject to the layering hierarchy in the Floater List. This includes the related controls for
selecting, hiding, naming, and grouping.

These features are described in “The Floater List,” later in this chapter.

* They may be cut, copied, pasted, and moved in an image in the same ways.

These features are described in the “Moving Floaters,” section in this chapter.

* They obey the floater composite method, which controls how the floater interacts with underlying images.
These features are described in “The Composite Method: A Floater’s Special Effects.”

See also:

Dropping Floaters



Dropping Floaters

Floaters continue to float even when deselected. When you’re finished working with a floater and want it
merged with the canvas image, you may Drop it.

Keep your options open. Don’t drop floaters unless necessary. Save in the RIFF or Photoshop 3 format to keep
them floating between sessions.

For information on the Drop with Mask option, see “Drop with Mask,” later in this chapter.

To merge a floater or group of floaters with the background:
1 select the floater or group you want to drop.

2 Click Drop on the Floater List palette, or choose Edit menu> Drop.

To composite all floaters simultaneously:

1 click Drop All on the Floater List palette.

Floaters are designed to work in RIFF format. In Photoshop 3 format, floaters become layers. If you save the
file in any other format, the floaters will be dropped automatically.

When you save in Adobe Photoshop 3 format, floaters are assigned to appropriate image layers.

If you intend to export your model to Ray Dream Designer or another 3D application, save your map image
files in TIFF format.




Creating Image floaters

Creating a floater is a two-step process; it involves making a selection and floating it. You have several
options for accomplishing either step.

See also:
Making Selections

Floating Selections
Adding Text Floaters




Making Selections

* You may use any of Detailer’s selection tools. The Rectangular and Oval Selection tools, the Lasso tool, and
the Magic Wand are all useful.

“Selections and Masks,” provides detailed instructions for creating selections.

You must be working in an image window to create a selection. You can’t create selections in the Model
Window.

* You may also use any of the masking tools for selecting an image area: Auto Mask, Color Mask, and the
Masking brushes.

When you’ve masked the area you want, turn it into a selection by choosing the third Visibility button (View
Selection) at the bottom of the document window. The selection must be active (displayed as marching ants)
before you can float the image.



Floating Selections
With an image area selected (marching ants), you can float it.
* On the Tools palette, choose the Floater Adjuster tool. Then click inside the selection to float it.

If you don’t want to cut the selection from the background (to reveal the current paper color), hold down the
Option key (Macintosh) or Alt key (Windows) when you click. This creates the floater as a copy of the
selection.

* You may also choose Edit menu> Float.

* Another way to create a floater is by copying or cutting, then pasting. Anything you paste from the
Clipboard appears in the Detailer document as a floater.

If you need to move a floater from one document to another, you can copy and paste it. You can also put a
floater in the Floaters palette and drag it out when you need it.

® The Effects menu> Orientation commands: Rotate, Scale, and Distort, automatically float the image
selection they are applied to.

Creating a floater is just the beginning. You can move, copy, and use any of Detailer’s tools and effects to
modify a floater. You can also save a floater to a library for
later use.

More information on working with Image floaters appears later in this chapter.



Adding Text Floaters

The Text tool allows you to create floaters from Adobe Type 1 font outlines or TrueType fonts. Text floaters
support all of the features and options for working with Image floaters.

To create a text floater:
1 Choose the Text tool on the Tools palette.

2 In the Controls palette: Text tool use the Point Size slider to choose a
point size.

3In the Controls palette: Text tool choose a font from the Font pop-up menu.

Font names appearing in the Controls palette list with a “~” after are PostScript. No “*” indicates the font is
TrueType.

4 Click in the image or on the model where you want to put the text. Remember, you can move the text
floaters after you create them.

5Type the text you want.

© Press Return or Enter to type on the next line.

If you make a mistake while typing, you can press the Delete or Backspace key to remove the unwanted
letters, and continue typing, but only if you haven’t moved your insertion point.

If you have moved your insertion point, you must select the text floater with the Floater Adjuster tool and
press the Delete or Backspace key to remove it.

For organization and better control, you might want to group the floaters that make up words or phrases. If
you want to apply effects to text, you must collapse the
group first.

As you type, the text floaters are added to the list of selected floaters in the Floater List. After typing one
word or phrase, choose Materials palette: Object menu> Group. Detailer gathers the separate characters
into a group. Now, press Return or Enter to open the group’s Floater Attributes dialog. Enter the word or
phrase you just typed for the group’s floater name. Now you can easily identify and control that word or
phrase as a single item.

To convert a floater to a Reference floater:
1 select a floater.

2 Choose Effects menu> Orientation> Free Transform. Detailer converts the image to a Reference floater.

For more information on creating and transforming Reference floaters, see “Working with Reference floaters,”
later in this chapter.

The Reference floater state is just for transformations. If you try to paint in a Reference floater, Detailer
immediately commits the transform and converts the Reference floater to an Image floater.



The Floater List

The Floater List palette keeps track of all the floaters in a document and provides special features for
controlling them.

To open the Floater List palette, choose Materials palette: Object menu> Floater List.

The Floater List palette lists all of the floaters in the current document, with any selected floater highlighted
and in bold type. If no floaters are selected, everything in the list appears in plain type. The floater list is
arranged according to the layers, with the highest layer on top. The two types of floaters, Image and
Reference, have different icons next to the floater

listing.

See also:
Selecting Floaters
Hiding a Floater
Naming Floaters
Ordering Floaters
Grouping/Ungrouping Floaters
Closing and Opening a Group

Collapsing a Floater Group



Selecting Floaters
When you want to work with a particular floater, you must select it.

To select a floater, click on it with the Floater Adjuster tool. The floater selection marquee outlines the floater.
You may also click the floater’s name on the Floater List palette to select it.

To deselect a floater, click outside of it with the Floater Adjuster tool. You may also choose Edit menu>
Deselect. On the Floater List palette, you can deselect a floater by clicking in the empty space below the
names.

A deselected floater continues to float. That is, even though you don’t see a selection marquee and the
floater image appears to blend with the background, the floater is still a distinct object. Changes you make to
the background will not affect the floater. This can lead to confusion. For example: If a floater is not selected—
but you try to paint into it, your brush strokes will go fo the canvas. Because the floater is concealing that part
of the canvas, you won 't see the strokes. To avoid this, remember to select the floater before you try to paint into
it.

If you want a floater to “stop floating,” i.e. to merge with the canvas, you must Drop it.



Hiding a Floater

If you want to hide a floater, click the Eye icon next to its name in the Floater List palette. When the Eye is
shut, the floater is invisible. To see the floater again, click the Eye to open it.



Hiding the Selection Marquee

You can hide the selected floater’s selection marquee by disabling the Show Selection Marquee option at the
bottom of the Floater List palette or by pressing Command--Shift-H (Macintosh) or Ctrl+Shift+H (Windows).



Naming Floaters

As the number of floaters in a document increases, it can become difficult to track which listing refers to
which floater. Detailer lets you give the floaters descriptive names, which makes them easier to keep track
of.

To name a floater:

1 Double-click the floater’s name in the Floater List palette. You may also select the name in the Floater List
and press Return or Enter. Detailer displays a Floater Attributes dialog.
2Entera descriptive name and click OK.

The Floater Attributes dialog also gives the location of the top, left corner of the floater. You can move the
floater to a specific location by changing the Top and Left values in the attributes dialog.



Ordering Floaters

The Floater List palette provides a way to organize and track the many floaters in an image. It lets you
change the ordering of overlapping floaters and allows you to group floaters so that you can move them as a
single floater.

All floaters appear in the Floater List. In the document, the floaters are displayed in order—that is, a floater
higher in the list appears in front of the ones below it. Floaters that overlap in the document are layered—the
foreground floater obscures the one behind it.

By changing the ordering, you can control the composition of the several floating objects. There are two
ways to do this—using the Floater List palette or with the Controls palette: Floater Adjuster tool.

To change the order of floaters using the Floater List palette:

1 Drag the name of the floater to the location in the list that reflects the order you want in your image. For
example, if you want the floater on top of the other images, drag it to the top of the list.

To change the order of floaters using the Controls palette: Floater Adjuster tool:

1 select the floater.

2 Use the Front, Back, and Arrow buttons on the Controls palette: Floater Adjuster tool to change the
selected floater’s level in the hierarchy.

3 Click Front or Back to send the floater to the top or bottom layer; or click one of the arrow buttons to move
the floater one layer at a time.



Grouping/Ungrouping Floaters

Group floaters whenever you want to control them as a unit. You can move a closed floater group in any of
the ways you’d move a single floater. For example, after creating text floaters, you might want to group the
words.

Grouping does not allow you to apply brush strokes or effects across a set of floaters. To do these operations,
collapse the group first.

You can ungroup the floaters any time. If you like, you can copy a group using Option-click (Macintosh) or
Alt+click (Windows) and save it in a floater library.

To create a group:
1 Hold down the Shift key and click each floater on the Floater List palette that you want in the group.

2 Click Group. A selection marquee surrounds the floaters in the image window. The names of the floaters
appear under a group name in the Floater List. Detailer names groups Group 0, Group 1, and so on, by
default. You can rename groups if you like.

To change a group’s name:
1 bouble-click the group’s name. The Floater Attributes dialog box appears.

2Type a new name and click OK or press Return or Enter.

To add a floater to the group:

1 brag its name into the group. To remove it from the group, drag it back out.

You can add a group to anther group in the same way—by dragging the group name into the group. Drag a
floater out of a group to make it an individual floater again.

To ungroup floaters:
1 on the Floater List palette, click the group name.

2 Click Ungroup.



Closing and Opening a Group

Before moving a group, you must close it. When a group is open, the floaters in the group are treated
individually. When a group is closed the group is treated as one single floater.

To close a group, click the arrow to the left of the group name. When the arrow points to the right and the
names of the group members are hidden, the group is closed.

If you want to edit individual floaters in a group or move them separately, you must open the group.

To open a group, click the triangle to the left of the group. The arrow turns down, opening the group and
revealing the names of its members. You may now select and work with them individually



Collapsing a Floater Group

If you want to unite the group as a single floater, click the Collapse button on the Floater List Palette.
Collapsing reduces the group to a single floater. You cannot isolate the original group members after
collapsing.



Moving Floaters
See also:
Dragging with the Floater Adjuster Tool

Moving a Floater to a Specific Location in the Image
Copying Floaters



Dragging with the Floater Adjuster Tool

Once a floater is selected, you can drag it anywhere in the image with the Floater Adjuster tool. You can also
nudge the selected floater one pixel at a time by pressing the Arrow keys on your keyboard.

You can select and drag floaters in either the image window or right on the object in the Model Window.

If moving a floater leaves an unwanted hole in the canvas, choose Edit menu> Undo, then hold down the
Option key (Macintosh) or the Alt key (Windows) before dragging. This copies the floater.



Moving a Floater to a Specific Location in the Image

You can set the exact coordinates for the upper left corner of a floater. If you were creating screens for a CD-
ROM, you might want to render different models, but have each model appear in the same position on each
screen. Detailer makes this easier by providing fields to enter these coordinates.

To set a floaters position:

1 Double-click the floater’s name in the Floater List palette. The Floater Attributes dialog box appears.
The Top and Left boxes show the floater’s location with respect to the top, left corner (0,0) of the image.

The reference point for the floater or group is the top, left corner of the floater’s rectangle (or the group’s
selection marquee).

2 Enter the new values in the Floater Attributes dialog box. Increasing the Top value moves the floater down.
Increasing the Left value moves the floater to the right.

Positive and negative values that place the floater partially, or wholly, outside of the image are allowed.

3 Click OK. The floater moves to the specified location.



Copying Floaters

You can copy the selected floater to the Clipboard, then paste as many copies as you like. You can also move
to another document and paste the floater there.



The Composite Method: A Floater's Special Effects

When a floater is above another image—either the canvas or another floater—Detailer can use the
overlapping color information to create special effects.

The effects are variations of the floater’s Composite Method. Each floater may have its own method. You can
change the Composite Method any number of times without actually changing the images. This gives you the
freedom to experiment without risking an unwanted, permanent edit.

To change a floater’s composite method:

1 select a floater. The floater should have some kind of image behind it. If the next layer is merely black or
white, the effects will be limited.

2 Choose one of the Composite Methods from the pop-up menu on the Controls palette: Floater Adjuster tool.
If you don’t like one effect, choose a different one.

See also:
Default Floater
Gel

Colorize

Reverse-Out

Shadow Ma

Magic Combine
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Default Floater

In the Default method, the floater covers (hides) the underlying image.



Gel

The Gel method tints the underlying image with the floater’s color. For example, a yellow floater gives the
underlying image a yellow cast.



Colorize

The Colorize method replaces the hue and saturation of the canvas pixels with the hue and saturation of the
floater pixels.

You can use this feature to convert a color image into grayscale and vice versa. A black floater turns the
underlying color image into a grayscale image. A colored floater adds color to an underlying grayscale
image.



Reverse-Out

In the Reverse-Out method, the floater inverts the colors behind it. Reverse-Out is a great way to drop out
type. Place a floater over black type and the type turns white.

A color’s inverse, also known as its complement, is the color on the opposite side of the color wheel.

With Reverse-Out, the colors in the floater are not considered—only the area it
covers.



Shadow Map

Shadow Map blocks light, letting you create shadows without changing the image.



Magic Combine

Magic Combine combines the floater with the underlying image based on luminance. The parts of the floater
that are lighter than the underlying image appear within the bottom image.

One way to use this command is for filling type. With a photograph as the top floater and black type as the
underlying image, choosing Magic Combine fills the type with the image.



Pseudocolor

The Pseudocolor method translates the floater’s luminance into hue. You can use this method to turn a
grayscale floater into a spectrum of color.



Normal

The Normal method is Photoshop’s default mode. It behaves the same as the Default composite method.



Dissolve

Dissolve makes pixels in the floater transparent based on the opacity of the mask.



Multiply

Multiply combines colors by multiplying RGB values to create a darker color.
Multiply is very much like combining
two transparencies.



Screen

Screen combines colors to create a
lighter color.



Overlay

Overlay combines colors while preserving the highlights and shadows of the
image color.



Soft Light

Soft Light darkens or lightens colors depending on the luminance of the
floater color.



Hard Light

Hard Light multiplies or screens colors, depending on the luminance of the
floater color.



Darken

Darken takes the darker of the image or floater color and uses that color.



Lighten

Lighten takes the lighter of the image or floater color and uses that color.



Difference

Difference subtracts one color from the other, depending on which color has a greater brightness value.



Hue

Hue creates a color by combining the luminance and saturation of the image color with the hue of the floater
color.



Saturation

Saturation creates a color by combining the luminance and hue of the image color with the saturation of the
floater color.



Color

Color creates a new color by combining the luminance of the image color and the hue and saturation of the
floater color.



Luminosity

Luminosity creates a new color from the hue and saturation of the image color and the luminance of the
floater color. This is the opposite of Color.



Using Floaters

You’ll use floaters to move image selections around in a document and to move images to other documents
S0 you can composite them. In fact, whenever you copy and paste image selections, they come in as
floaters. This is handy because you can easily drag the floaters where you want them.

You can use floaters for manipulating masks. For example, you can use a floater to modify a canvas mask or
to move the mask from one document to another.

You can also use floaters to create Image Hose Nozzle files. See “Using the Image Hose,” for more
information.

See also:

Working with Floaters

Trimming a Floater

Expanding a Floater
Using the Controls Palette: Floater Adjuster Tool

Editing Floater Images




Working with Floaters

Because each floater represents a separate image (above the canvas), you’ll need to let Detailer know which
image you intend to work in. As you work, you’ll switch layers—first working on the canvas, then in one
floater, then in another, then on the

canvas again.

When you want to work with a particular floater, you must select it.

To select a floater, click on it with the Floater Adjuster tool. The black and yellow selection rectangle outlines
the floater. You may also click the floater’s name on the Floater List palette to select it.

You can hold down the Shift key and click on another floater to add it to the selection. You can move a multi-
floater selection, but you cannot paint across them.

To deselect a floater, choose Edit menu> Deselect. On the Floater List palette, you can deselect a floater by
clicking in the empty space below the names in the list.



Trimming a Floater

When Detailer creates a floater, it captures a larger, rectangular region, then masks it down to the shape of
the selection. The larger rectangle gives you room to work and allows you to feather the image beyond the
original selection.

The margin between the selection and the rectangle is a default setting called the Floater pre-feather. You
can change it in Edit menu> Preferences> General.

Trimming reduces the floater’s dimensions to the minimum rectangle that will contain the masked image.
Trimming floaters is good housekeeping, but don’t do it until you’re satisfied with the feathering. Your options
for modifying the floater image and mask are reduced after trimming.

To trim a floater, select a floater, then click Trim on the Floater List palette.



Expanding a Floater

Expand does the opposite of Trim. It enlarges the selected floater’s rectangle. Expanding adds blank image
area, so it won’t help if you want to increase the feathering beyond the pre-set distance.

To expand a floater, select the floater, then click Expand. Detailer displays a dialog that lets you specify the
number of pixels and direction to expand the floater.



Using the Controls Palette: Floater Adjuster Tool

The Controls palette: Floater Adjuster tool is displayed when you’re using the Floater Adjuster tool. The
palette describes the selected floater’s rectangle and provides several editing options.

You can decrease opacity to hide a floater but it is faster to click the eye icon on the Floater List palette.

See also:

Opacity
Feather



Opacity

Drag the Opacity slider to change the selected floater’s visibility. Decreasing Opacity allows underlying
images to show through.



Feather

Feathering controls the softness at the edge of the floating image. Feathering works by blurring the border of
the mask.

To feather the edges of a selected floater, move the Feather slider in the Controls palette: Floater Adjuster
tool.

How much you can feather a floater is determined in the General Preferences dialog box. Choose Edit menu>
Preferences> General. Notice that the Floater Pre-Feather is preset to 16 pixels, making this the default
setting of the Feather slider. You can change this default to any number up to 50.



Editing Floater Images

Nearly all of Detailer’s brushes and effects work with floaters. You can paint in a floater, change its opacity,
feather its edges, and enhance its image with commands from the Effects menu.

You can also edit the floater by modifying its mask. By changing the mask, you’ll reveal or conceal parts of
the floater. You may paint on a floater with a Masking brush or use any of the advanced masking features,
like Auto Mask.

See also:

Painting in a Floater




Painting in a Floater

To paint in a floater, select a floater and start painting. Your brush strokes appear only in the floater and will
not affect the canvas.

You may use any of Detailer’s brushes to paint or draw in a floater, with the exception of the Water Color
brushes—a floater doesn’t have a wet layer.

You can move a floater to a temporary document, drop it with its mask, and use the Water Color brushes
there. Because you dropped the floater with its mask, you can easily re-float the modified image to bring it
back.

You cannot paint across a floater group. If this is something you want to do, you need to Collapse the group
into a single floater.

The drawing mode (in terms of the floater mask) is controlled by the drawing mode icons on the bottom of
the image window. You can paint across the entire floater rectangle, or within the mask area.

To paint on the canvas, deselect all floaters before you start painting. When no floaters are selected, your
brush strokes go to the canvas.

This can be “interesting” if a floater covers the area where you’re painting. In this case, you might not see
the brush strokes. You’ll need to deal with the floater by moving, hiding, or dropping it to see what you’re
painting.



Floater Mask

The floater mask is created when you float a selection. The mask defines the area of the color layer that is
visible.

To view a floater’s mask:
1 select the floater.

2 Choose Canvas menu> View Mask. You may also click the color spectrum icon near the top right of the
image window.

To return to image display, choose Canvas menu> View Mask or click the color spectrum icon again.
See also:

Floater Masking Modes

How the canvas mask interacts with a floater

Editing a Floater Mask
Restoring a Floater Mask

Drop with Mask




Floater Masking Modes

A floater mask will be in one of three modes: Disabled, Masked Inside, or Masked Outside. By changing the
mode, you change how the floater appears.

To change a floater’s mask mode:

1 select the floater you want to change.

2 In the Floater List palette, click the icon for the masking mode you want. The icon for the current mode is
outlined.

Masking Disabled

With Masking Disabled, Detailer ignores the mask and displays the entire floater rectangle.

Masked Inside

Masked Inside inverts the floater mask—masked regions of the floater rectangle are rendered invisible.
Regions outside the mask are visible.

Masked Outside

Masked Outside uses the floater mask to reveal only the shape of the floating image. The unmasked regions
are invisible. This is the default mode for a floater.



How the canvas mask interacts with a floater
You can use the canvas mask to conceal or reveal parts of a floater.

The floater/canvas mask interaction will be in one of three modes: Disabled, Masked Inside, or Masked
Outside. By changing the mode, you can immediately alter the composition.

To change the floater/canvas mask interaction:

1 select the floater you want to change.

2 In the Floater List palette, click the icon for the mask interaction mode you want. The icon for the current
mode is outlined in red.

The attribute for interacting with the
canvas mask is contained in the floater,
so each floater may use a different
interaction mode.

Masking Disabled
The floater isn’t affected by the canvas mask. This is the default mode for a floater.
Masked Inside

The canvas mask reveals the floater. Only regions of the floater that coincide with masked canvas regions
are visible.

When Masked Inside is selected, painting with white in the canvas mask reveals more of the floater. Painting
with black conceals more of the floater, while revealing the canvas.

Masked Outside

The canvas mask conceals the floater. Only regions of the floater that coincide with
un-masked canvas regions are visible.

When Masked Outside is selected, painting with black in the canvas mask reveals more of the floater.
Painting with white conceals more of the floater, while revealing the canvas.




Editing a Floater's Mask

By modifying a floater’s mask, you can change how much of the image is visible. The most useful way to
modify a floater mask is with a Masking brush or by working in Edit Mask mode.

By painting with a Masking brush in a floater, you change the extent of its mask, revealing or concealing
more of the floater image layer. When you conceal more of the floater, you reveal more of the canvas.

All of the Masking brushes and commands—except Magic Wand—are available for modifying a floater mask.

For more information on modifying a floater mask, see Chapter 10, “Selections and Masks.”



Restoring a Floater Mask

If you modify a floater’s mask, but then decide that you don’t like the changes; you can return the floater to
its original condition.

To restore the floater mask, click the Restore button on the bottom of the Floater List palette.



Drop with Mask

The Drop with Mask option at the bottom of the Floater List palette lets you decide what to do with the
mask of a floater you drop. When this option is disabled, only the floater image merges with the image on
the canvas.

When Drop with Mask is enabled, the floater images merge with the canvas image and the floater’s mask
merges with the
canvas mask.

There are a number of ways Drop with Mask can be useful. For example, if the canvas mask is clear
(Command-U or Ctrl+U), the dropped floater’s mask becomes the canvas mask. You can use this technique to
move a mask from one document to another.



The Floaters Palette
The Floaters palette is a convenient place to store floaters you’ll want to use again.

To display the Floaters palette, choose Materials palette: Object menu> Floaters.

To add a floater to the Floaters palette:

1 Using the Floater Adjuster tool, drag the floater from the image window into the Floaters palette.

As the floater enters the palette, you’ll see the selection marquee shrink to icon size.

2 When you drop the floater in the palette, Detailer will give you an opportunity to rename it. If you haven’t
already given the floater a descriptive name, do so now.

To use a floater from the palette:
1 pisplay the Floaters palette.
2 Locate the icon for the floater you want. You may also use the pop-up to select it by name.

3 Drag the icon into your image.

You must drag a floater from the library to an image window. Do not attempt to drag a floater to the Model
Window.

You can create your own custom libraries to organize floaters by category. When you’re creating a library,
keep in mind that the smaller the library, the easier it will be to see its contents at a glance.



Working with Reference floaters

A Reference floater is a special kind of floater. It gets its image information from an external source—a
reference image.

The Reference floater is a low resolution, stand-in for the original image. Because it is low resolution, a
Reference floater can be quickly transformed in ways that would otherwise be prohibitively slow.

Working with a Reference floater allows you to transform a floater in an image by dragging its handles.
Possible transformations include resizing, rotating, and skewing. Transformations happen immediately.

After transformations, you can convert the Reference floater to a floater. During conversion, Detailer refers to
the original image to improve the resolution. This makes the image cleaner.

Editing the image—with a brush or effect—is not allowed in a Reference floater. When you’ve finished
transforming the floater, you can convert it to a floater, which you can edit.

Reference floaters (and the transformations they allow) are particularly useful when compositing high
resolution images.

See also:

Creating a Reference floater

Transforming a Reference floater

Set Transform

Converting a Reference floater to a Floater




Creating a Reference floater

* Create a Reference floater by converting a floater.

To convert a floater to a Reference floater:

1 select a floater.

2 Choose Effects menu> Orientation> Free Transform.



Transforming a Reference floater

A selected Reference floater has eight handles on its selection rectangle—one on each corner and one on
each side. You’ll drag these handles to transform the floater.

To select a Reference floater, click on it with the Floater Adjuster tool or click on its name in the Floater List.
Floater: Free Transformations
You may resize, rotate, and slant a Reference floater by dragging its handles.

Choose the Floater Adjuster tool and select the Reference floater you want to
manipulate.

Floater: Resizing

Drag a corner handle in the direction you want to resize.

To maintain proportions, hold down the Shift key as you drag.

To resize in one dimension only, drag a side handle.

Floater: Rotate

Hold down the Command key (Macintosh) or Ctrl key (Windows) and drag a corner handle.
Floater: Slant (Skew)

Hold down the Command key (Macintosh) or Ctrl key (Windows)and drag a side handle.
Notice the cursor change as you position the floater over a handle.



Floater Set Transform

After creating a Reference floater, the Set Transform dialog allows you to perform numerical transformations.
Set Transform is useful for returning the floater to its original condition.

1 select a Reference floater.
2 Choose Effects menu> Orientation> Set Transform. Detailer opens the Set Transform dialog.

3 The Set Transform features are described below. When you’re finished with them, click OK. Detailer
transforms the Reference floater accordingly.

See also:
Transform: Scale
Transform: Rotate
Transform: Slant

Transform: Retain Mask

Transform: Quality

Transform: Reference Image
Converting a Reference floater to a Floater



Transform: Scale

The Horizontal and Vertical Scaling values describe the scaling relationship between this floater and its
reference original. You can change the scaling by entering new values.

If the scaling is low, 33% for example, and you increase it, Detailer refers to the reference original to get
more pixel data.

If you want to alter the proportions, disable the Constrain Aspect Ratio option. This allows you to apply
different scaling factors in the Horizontal and Vertical dimensions.



Transform: Rotate

The original rotation value is 0j. Enter a new value to rotate the Reference floater. Positive values rotate the
Reference floater counter-clockwise. Negative values rotate clockwise.



Transform: Slant

The original slant value is 0j. Enter a new value to slant the Reference floater.



Transform: Retain Mask

The Retain Mask option is enabled by default. If you want to ignore the mask information, you can disable
this option.



Transform: Quality

The Quality options allow you to choose the level of sampling between the Reference floater and the original
image.

Fast sets a high sampling ratio, which produces a low resolution Reference floater. A low resolution Reference
floater contains less information, so it can be transformed quickly.

Remember that when you convert a Reference floater to a floater (with Effects menu> Orientation> Commit
Transform), Detailer re-samples the original reference image to produce the best possible transformed
image. This means that you can work fast without sacrificing image quality.

Clean sets the sampling ratio at 1 to 1, which produces a Reference floater of the highest possible resolution
—up to that of the original. This shows a better image as you work, but takes much longer to calculate
transformations.



Transform: Reference Image

The resolution of the original reference appears at the bottom of the Set Transform dialog. You might find this
information

useful.



Converting a Reference floater to a Floater
When you are finished with transformations, you can convert the Reference floater back to an image.

If you try to apply an effect or paint on a Reference floater, Detailer automatically converts it to a floater.
1 select the floater you want to convert.

2 Choose Effects menu> Orientation> Commit Transform. Detailer converts the Reference floater to a floater.
This may take a few moments.

During the conversion, Detailer examines the reference original and brings the best pixel data possible to the
transformed floater. For this reason, you’ll see the image quality improve.

Notice that the floater’s icon in the Floater List changes.



Floaters for creating WWW Image Maps

Thei mage map is a World Wide Web

feature that allows a client to hyperlink to different locations by clicking on specific areas within an image. In
a Detailer image, you can specify a floater as a “clickable” region. Then, when you save the file in JPEG
format, you can ask Detailer to

automatically create the image map description file.

To set a floater clickable region:

1 Open the image you want to work with.

2 Select the region you want clickable.

3 Float the selection.

40pen the Floater List palette and Trim the floater.

5 Double-click the floater in the Floater List palette and Detailer displays the Floater Attributes dialog.

At the bottom of the dialog, enable the WWW Map Clickable Region option and select Rectangle, Oval or
Polygon.

6 In the Notes field, enter the hypertext reference and URL. For example
http://www.fractal.com/.

7 Close the Floater Attributes dialog.

8 When you save the document as a JPEG file, enable either the NCSA or CERN Map File check box in the
options dialog.

Detailer will automatically write out a text-based “map” file that defines the hyperlink areas.



Introducing the Image Hose

The Image Hose is a milestone in the evolution of art tools. Instead of painting with color, the Image Hose
paints with images; and not just one or two images at a stroke, but a variety of changing images.

The images flowing from the hose change as you make a brush stroke. Detailer gives you complete control of
the image output. For example, by increasing stylus pressure, you can hose larger images—or more colorful
ones. Or by changing the direction of the stroke, you can change the angle of the images. This is just a
sample of the possible controls. By creating your own sets of images, anything is possible.

The Image Hose deposits 24-bit images with an 8-bit mask. The mask enables you to layer the images
gently, without aliased edges or artifacts.

You can load the Image Hose with leaves, bark, grass, stones, people—images of any description. When you

paint with these image elements, you can build them into coherent shapes—a tree, a hill, a cobble stone
street, a crowd of people.

See also:

How it works



How it works

The Image Hose is a brush. To use it, you must first load it with images. The images are kept in special nozzle
files.

A nozzle is what you attach to a garden hose to control the flow of water. So a nozzle is what you attach to
the Image Hose to control its medium—images.

A nozzle file may contain any number of images. Usually, the images are similar and form a logical series—
that is, the images progress along some order. For example, the images might increase in size, or advance in
angle.

It is not necessary that images progress in a logical series, but the Image Hose is more powerful when they
do. Progression allows you to control the images that flow from the hose.

The images are indexed so that Detailer can locate and hose specific images on request. As you paint with
the Image Hose, you can request specific images from the nozzle index by varying your input. Increasing an
input value takes images from later in the series. For example, you can set up the nozzle so that by pressing
harder with a pressure sensitive stylus, you paint with larger images.

“Indexing” refers to the method Detailer uses to select particular images from the many images in a nozzle
file.

You control which input factor to use for indexing on the Nozzle palette. You can hose images sequentially, at
random, based on pressure, stroke direction, and several other factors.

You control the images themselves in the nozzle file. If you want more variety in the images, create more
images in the nozzle file. Designing and creating nozzle files is covered later in this chapter.

As your Image Hose requirements become more exacting, you can create complex nozzles that involve mwo
progressions—for example, images get larger and change angle. In this case, you’ll use one input factor, to
determine image size, and use a second factor to determine image angle. This creates a 2-Rank Nozzle.



Using the Image Hose

The Image Hose is easy to use and provides a number of options for the behavior of “nozzle spray.”

To use the Image Hose:

1 choose the Brush tool.

2 Choose the Image Hose brush from the Brushes palette.

3 Choose Brushes palette: Nozzle menu> Nozzles. Detailer displays the Brush Controls: Nozzle palette.
4 select a nozzle from the Nozzle palette.

5 Choose an Image Hose variant, and make a brush stroke in your document.
See also:

Getting a Nozzle

Choosing an Image Hose Brush Variant

The Controls Palette: Brush Tool




Getting a Nozzle

You may choose a nozzle from the Nozzle palette or load a separate nozzle file.

To choose a nozzle from the palette:

1 Display the Brushes palette.

2 Choose Brushes palette: Nozzle menu> Nozzles. Detailer displays the Nozzle palette.
3 Open the drawer of the Nozzle palette.

4 Click the icon for the nozzle you want or use the pop-up menu in the drawer to select one.

To load a nozzle file:

If you’ve created a separate nozzle file that isn’t part of a library, you can load it.
1 choose Brushes palette: Nozzle menu> Load Nozzle. A directory window appears.

2 Open a nozzle file by double-clicking its name in the directory or highlighting the file name and clicking
Open.

The first time you load a nozzle, Detailer may ask for some information on the image’s construction. This is
covered in the section on creating nozzle files, later in this chapter.

Keep nozzle files in the Nozzle directory/folder (in the Detailer application folder) for easy retrieval.



Choosing an Image Hose Brush Variant

After loading a nozzle file, all you have to do to start painting is choose the Image Hose brush and one of its
variants.

About the Variants

Like Detailer’s other brushes, the Image Hose has several variants. These built-in variants combine nozzle
control factors with brush settings to create different hose effects.

The following descriptions will give you an idea of the effect of each variant.

Small, Medium, and Large refer to image spacing. Small variants space images closely. Large variants space
images widely. See “Controlling the Image Hose Brush,” in this chapter, for more information on spacing
images.

Random, Sequential, Directional, Pressure, and (Source) Luminance refer to the indexing rule by which
images are selected from the nozzle file. See “Controlling the Nozzle,” in this chapter, for more information.

Spray and Linear refer to the placement of images in relation to the stroke. Spray variants scatter images.
Linear variants place images directly on the stroke path. See “Controlling the Image Hose Brush,” in this
chapter, for more information.

You can use these variants as a starting point, then adjust the brush and nozzle controls to hose the images
just as you want them.



The Controls Palette: Brush Tool

You can use the sliders on the Controls palette: Brush tool to adjust the opacity of nozzle images and to mix
them with the secondary color.

The Opacity slider allows you to make
nozzle images semi-transparent. If you move the slider all the way to the left, the images become invisible.

The Grain slider allows you to mix the secondary color with the nozzle images. If the slider is set to 100%,
the nozzle images remain pure. As you move the slider to the left, more of the secondary color appears in
the images. If the slider is set to 90%, Detailer mixes 10% of the secondary color to 90% of the image. This is
a handy way to adjust the shading of image elements.

See Chapter 7, “Image Materials,” for information on selecting the secondary color.




Controlling the Image Hose
;Ihe Image Hose has three components of control: The Image Hose brush, the nozzle controls, and the nozzle
e.
* You’ll adjust the brush to determine the placement of images in the stroke.
* You’ll use the Nozzle palette control sliders to change the scale and to set the rules for indexing.
* You’ll create your own nozzle files to determine the image content and dimensions of progression.
See also:
Controlling the Image Hose Brush
Controlling the Nozzle
Nozzle Options



Controlling the Image Hose Brush

Brush controls for the Image Hose primarily affect where the images appear in the stroke. For example,
whether the images are scattered or closely spaced.

See also:
Spacing Images
Randomizing placement



Spacing Images

You control the space between images with the Size/Spacing slider on the Brush Controls: Spacing palette.
Moving the slider to the right increases the spacing between image elements.

Because spacing is based on the diameter of the brush, the Size slider in the Brush palette: Controls menu>
Size palette also affects image spacing. Increasing the brush size adds space between hosed images.

The Size slider does not affect the size of the image elements themselves. For this control, use the Scale
slider on the Nozzle palette.



Randomizing placement

You control the proximity of images to the stroke path with the Dab Location Placement slider on the
Advanced Controls: Random palette. When the slider is all the way to the left, images are hosed directly in
the stroke. Moving the slider to the right increases the scattering of the images.



Controlling the Nozzle

You can control the size of the nozzle images and the rules for delivering them with the sliders in the Nozzle
palette.

See also:

Nozzle: Scale

Nozzle: Indexing



Nozzle: Scale
Using nozzles in the current library, the Scale slider lets you control the size of image elements delivered by
the Image Hose.
Drag the slider to the left to shrink the images. Drag it to the right to grow them. At 100%, the images equal
their size in the nozzle file.



Nozzle: Indexing

As you paint with the Image Hose, Detailer selects images from the nozzle file based on one or more rules.
This selection process is called indexing. The Nozzle palette lets you change the rules for indexing the
images.

Image nozzle files may be created with one, two, or three image progressions called “ranks.” Detailer offers
these three dimensions of progression, so each nozzle file can be identified as a 1, 2, or 3-Rank nozzle.

Learn more about the rank system in the section, “Creating Nozzles for the Image Hose,” later in this chapter.

The Rank-1, Rank-2, and Rank-3 sliders set the rules for indexing in their respective dimensions. This
indexing determines which images from the many in the nozzle file are delivered from the Image Hose.

To ch ange the indexing rule:

1 Move the slider to the control factor you want for that rank. The control factors are described below.

Because a 1-Rank nozzle has no second or third rank, the Rank-2 and Rank-3 sliders do nothing for a 1-Rank
nozzle.

See also:
Nozzle: Sequential
Nozzle: RandomNozzle: Source
Nozzle: Bearing
Nozzle: Tilt
Nozzle: Pressure
Nozzle: Direction

Nozzle: Velocit
Nozzle: None



Nozzle: Sequential

Sequential indexes images in the order they appear in the rank—moving left to right, and top down, just as
you read English.



Nozzle: Random
Random selects images from the rank at random.

Randomness can add irregularity of color and texture to the areas you paint with the Image Hose. This
contributes to the aesthetics of the painting. Minor irregularities occur in natural structures.



Nozzle: Source

Source delivers images based on the luminance of pixels in the current pattern. As the luminance decreases,
Source delivers images from later in the rank.

To take advantage of this feature, you may want to create a special pattern image for the single purpose of
controlling the Image Hose. If the pattern tile is smaller than the image you’re working on, the pattern is
repeated over the area. This might be what you want, or you might need to make the pattern the same size
as the image. See “Working with Patterns” in Chapter 7, “l/mage Materials,” for more information.

For controlling the Image Hose, the pattern may be grayscale. Remember, Detailer only uses the luminance
values.

To see how the pattern you’ve selected corresponds to the image, fill the image with the pattern. Choose Edit
menu> Undo to get the image back.




Nozzle: Bearing

Bearing indexes images based on the bearing of the stylus. Not all stylus models convey this information.
This control does not work with a mouse.



Nozzle: Tilt

Tilt indexes images based on the tilt of the stylus. Not all stylus models convey this information. This control
does not work with a mouse.



Nozzle : Pressure

Pressure only works with pressure sensitive tablets. Pressure indexes images based on stylus pressure.
Greater pressure selects images from later in the rank.

Pressure is a great control for requesting images from a nozzle. For example, if you set up your nozzle file to
progress from small to larger images, heavier strokes deliver larger images.



Nozzle :Direction

Direction indexes images from the rank based on the direction of the stroke. A left-to-right, horizontal stroke
delivers the first element in the rank. As the stroke direction progress counter-clockwise, the Image Hose
delivers subsequent images from

the rank.

Detailer uses the direction of the stroke in the image window—not in the Model Window.

The number of elements in the rank determines the directional change required to index a different element.
For example, a nozzle file that contains 72 images at progressive angles delivers a different item at every
5; of stroke direction (360i/72=5j).

The first item in the rank matches to a left-right stroke (toward 3 o’clock). Keep this in mind when designing
a directional nozzle.




Nozzle :Velocity

Velocity is often used with a mouse to mimic pressure. Velocity indexes images from the rank based on the
speed of the stroke. A faster stroke delivers elements from later in the rank.

Velocity can be difficult to control. For this reason, you might want to use it in a rank with few elements.



Nozzle : None

None returns one element only— the last in the rank.



Nozzle Options

The Brush Controls: Nozzle palette has two check box options for the Image Hose— Use Brush Grid and Add To

Mask.



Use Brush Grid

When Use Brush Grid is enabled, the Image Hose places images in a regular grid pattern. The grid size
follows the grid in the nozzle file.



Add to Mask

When Add to Mask is enabled, the images you paint with the Image Hose are painted to the mask layer as
well. That is, the mask of each nozzle image is added to the mask layer:



Creating Nozzles for the Image Hose

See also:
Designing Nozzles: 1, 2 or 3 ranks

Preparing Images
Creating a 1-Rank Nozzle from a group of floaters
Creating a 2-Rank Nozzle on a Grid

Creating a 3-Rank Nozzle
Nozzle Libraries



Designing Nozzles: 1, 2, or 3 ranks

A nozzle file contains a series of images arranged in a regular grid. Usually, the images are progressive in
terms of size, shape, angle, or color. Progression is not necessary, but it increases the sophistication of the
Image Hose. For example, a nozzle file with images progressing in size, can be set up so that greater stylus
pressure paints incrementally larger images.

What if you want a two-dimensional progression? For example, image elements increasing in size and/or
changing angle. To do this, you’ll need to set up your images as a 2-Rank Nozzle file. Painting with a 2-Rank
Nozzle, you can control where your image comes from in terms of both progressions. In this case, you use a
different input factor to control the location in each rank.

In the example of the cube transforming into an oval, Rank 1 is a progression in shape. The image below
shows Rank 2 as a progression in size. It would make sense to use pressure to control Rank 1 and direction to
control Rank 2.

For information on setting the control factor for each rank, see “Controlling the Nozzle,” in this chapter.

You can extend the nozzle to a third progression, creating a 3-Rank Nozzle. Again, you use a separate input
factor to control the location in each rank.

If you use one input factor to control two ranks, some image elements become unavailable.

Consider the way you will control each rank before building a nozzle. The way you lay out the images can
limit the ways you can control the indexing.

Before you begin building a nozzle, you’ll need to decide what rank level you need.
You’ll need to have an idea of how many elements you want in each progression.
See also:

Understanding the Ranking System

Preparing Images



Understanding the Ranking System

A 1-Rank indexing system is simply a numbered sequence. You can locate any element in the sequence by
giving its number. For example, “ltem 3.”

In Detailer, you locate items by varying input—for example, by pressing harder with the stylus or changing
the direction of the stroke. See “Controlling the Nozzle,” earlier in this chapter, for information on the input
factors you can use to control indexing.

A 2-Rank indexing system uses two perpendicular indexes. The first rank extends horizontally and the second
extends vertically. Again, you’ll vary input to locate an item for either rank. You can think of indexing in the
two ranks as “selecting a column” and “selecting a row.” The Image Hose delivers the image from the nozzle
where the selected column and row intersect. In order for this to work properly, you’ll need to use different
input factors for selecting in

each rank.

A 3-Rank indexing system extends the 2-Rank model. The third rank is created by repeating the 2-Rank “set.”
In this case, you index in the third rank by varying input to locate which set you want. Within the selected
set, the one and 2-Rank indexing (described above) is used. In order for this to work properly, you’ll need to
use different input factors for selecting in each rank.

A 3-Rank indexing system is used with calendar dates. Any day, in the past or future, can be located, given
the month, day, and year. For example, “February 25, 1962 (2/25/1962).”

In the example above, another dimension has been added to the nozzle. Rank 3 is a progression in color. You
might control this final rank with randomness, velocity, or source—depending on your plans in the image.



Preparing Images

Regardless of the rank level of the nozzle you are making or the method you use to build it, the following tips
will help you develop the individual images.

Each element in an Image Hose nozzle must be masked. The mask allows you to paint with images of
irregular shape. Only what is inside the mask will flow from the
Image Hose.

You might want to work by creating a silhouette of the image shape with a mask, then fill in the color
information later.

With soft edges to the mask, you can hose images that are automatically anti-aliased. This improves the
continuity across an area of hosed images.

You can create Image Hose nozzles from floaters. As you create image elements, turn them into floaters. If
the floater looks good when dropped on different backgrounds, the image will look good as a nozzle element.
Building a nozzle from floaters offers advantages in convenience as well.



Creating a 1-Rank Nozzle from a group of floaters

To create a 1-Rank nozzle from floaters:

1 create the image elements of the nozzle you want as floaters.

You might want to name your floaters. You also might create a new floater library and add these floaters to it
by dragging them into the Floaters palette.

You can display the Floaters palette by choosing Materials palette: Object menu> Floaters...

Refer to Chapter 11, “Floaters,” if you need more information on working with floaters.

2 When you’ve created the images, float all of them in the same file. It doesn’t matter where the images
float in the document.

3 Open the Materials: Floater List palette and inspect the list of floaters.

The top floater on the list will be the first element in the nozzle sequence. Moving down the list advances
through the progression.

4 Drag the item for each floater to arrange the list according to the progression you want in the nozzle.
5if any of the floaters is a group, click the name of the floater to select it. Then click Collapse to turn the
group into a single floater.

Detailer can make a nozzle from a group of floaters, but not from a “group of groups.”

6 Hold down the Shift key and select each item in the list. You may also choose Edit menu> Select All when
the Floater Adjuster tool is selected. Then click Group. All the items are now part of the same group.

7 Close the group by clicking the triangle at the left of the group listing in the Materials: Floater List palette.

A 1-Rank Nozzle doesn’t mean the images must be in one line. Detailer will wrap images onto several lines to
create a document of reasonable shape. This follows how printed words of a sentence may wrap from one
line to the next, moving down the page.

The wrapping of words on the page doesn’t damage the sentence—you know when it ends by your
knowledge of language and the rules of punctuation. Likewise, Detailer follows a mathematical rule in
reconstructing the rank of images. This rule is contained in the Nozzle Definition. You’ll learn more about this
in the next section.

8In the Floater List palette, click Trim. This shrinks the bounding box region around each floater to its
minimum size.

9 Choose Brushes palette: Nozzle menu> Make Nozzle From Group. Detailer creates a new, untitled image.
This is your nozzle file.

Y2Choose File menu> Save. Give the file a descriptive name and save it as a RIFF file. Keeping your nozzle
files in one place makes them easy to locate.

To load your nozzle and add it to the current library:
1 choose Brushes palette: Nozzle menu> Load Nozzle.
2 Choose Brushes palette: Nozzle menu> Add Nozzle to Library.

3 Name the nozzle and click OK.

You can now paint with your nozzle.



Creating a 2-Rank Nozzle on a Grid

Nozzles of two and three ranks cannot be created from a floater group. You must build these nozzles
manually.

The indexing system requires the nozzle images to fit in a regular grid. You can create a nozzle file by setting
up a grid and placing an image element at the center of each cell.

To determine the grid cell size:

The cell size is based on the smallest rectangle that will hold the largest image element (including its mask).
1 Float your largest image element.
2 In the Floater List palette, click Trim. This reduces the selection to the minimum rectangle.

3 With this one floater selected, choose Canvas menu> Canvas Size. Detailer displays the floater’s width and
height in pixels. Make a note—you’ll want to use slightly larger values as the grid size. Click Cancel to close
the dialog.

For this example, the grid size will be 50 by 50 pixels.
4 Determine the number of elements you want in each rank.

In this example, we’ll be using angle as the progression in the first rank. We want the images to advance in
angle by a 30j increment. Dividing 360j by 30j, we get 12. This nozzle should have 12 items in the first rank.

For the second rank progression, we’ll use size. The different sizes in the nozzle allow you to control the
image size within a stroke. We’ll use 6 sizes. This nozzle should have 6 items in the second rank.

5 Multiply the number of items in Rank-1 by the cell width. This value is the image width.
For this example, 12*50=600 pixels.

6 Multiply the number of items in Rank-2 by the cell height. This value is the image height.
For this example, 6*50=300 pixels.

7 Create a new document that has the appropriate width and height dimensions.

For this example, the image is set to 600 pixels wide by 300 pixels high.

8 Choose Canvas menu> Grid> Grid Options. Detailer displays the Grid Options dialog.
Set the Horizontal and Vertical Spacing to the values of the cell width and height. Click OK.
For this example, the spacing is 50 by 50.

9 Display the grid by clicking the Grid button above the vertical scroll bar on the image window. The grid
should describe the number of elements you want in each rank—Rank 1 horizontally, and Rank 2 vertically.

See also:

Build the Nozzle



Build the Nozzle

To build a nozzle:

1 Place one image element in the center of each grid cell. Follow an appropriate progression, based on your
intentions for controlling this nozzle.

21f you bring image elements into the grid as floaters, they will bring their mask with them. If you drop
floaters, make sure the Drop with Mask option at the bottom of the Floater List palette is enabled. Each
image element must be masked.

3As you work down the second rank, you might be able to take advantage of advanced copy and transform
techniques to speed the process.

4 when you’ve filled each grid cell, save the file in the RIFF format. You can now load the nozzle into the
Image Hose.

Remember to drop all floaters, using Drop with Mask, before saving the file.

5 The first time you load the nozzle file, the Nozzle Definition dialog box appears asking you for some
important information. By providing it, you inform Detailer of the math you did when you created the file—
the size of each cell and how many image elements there are. Detailer needs this information to index
images correctly.

Iltem width and height describe the cell grid size. Enter the values you set in the nozzle file.
In this example, the size is 50 by 50.

Index rank describes the number of progressions. Enter 2 for a 2-Rank Nozzle.

In the columns on the right, enter the number of image elements in each progression.

This example has 12 items in rank 1 and 6 items in rank 2.

6 When you’re done with the Nozzle Definition dialog, click OK.

If the values you enter do not describe the file, Detailer will not accept them. In other words, the “number of
items” multiplied by the “item size” must equal the dimensions of the nozzle file.

Remember, you’ll still need to set the sliders in the Nozzle palette to describe the control factors for each
rank.



Creating a 3-Rank Nozzle
You can create a 3-Rank Nozzle using the grid method described above.

The following suggestions should help you build a 3-Rank Nozzle with a minimum
of fuss.

To create a 3-Rank Nozzle:

1 Build the first two ranks using the grid method described above. Open this file.

For this example, we’ll continue the
2-Rank Lizard Scales Nozzle we created earlier.

The lizard scales nozzle file has 12 items in rank 1 and 6 items in rank 2. Each item is 50 pixels wide by 50
pixels high.

2 Determine the number of elements you want in the third rank.

In this example, we’ll use a change in shape of the scales. Minor irregularities in the detail across a painted
surface contribute to a natural appearance.

We’ll use 3 variations to build the third rank. This nozzle will have 3 items in the third rank. Each item in the
third rank will be a set of images—the 2-Rank
Nozzle.

3 Check the height of the current nozzle file. Press on the information “i” at the bottom of the window.

4 Multiply the number of items in the third rank by the height of the file. The result you get will be the height
of your 3-Rank Nozzle file.

The 2-Rank Lizard Scales Nozzle we created is 300 pixels high. 3*300=900 pixels.
5 Choose Edit menu> Select All.
6 Choose Edit menu> Copy.

7 Choose Edit menu> Paste> Into New Image.
This command creates a new image of the same size and content as the original file.
Now you must extend this file vertically to accommodate the items in the third rank.

8 Choose Canvas menu> Canvas Size.
Add the correct number of pixels (to the bottom) to set the canvas to the height of your 3-Rank Nozzle.
The example file is currently 300 pixels high, so we’ll add 600 pixels to the bottom to make it 900 high.

Now you can develop imagery for each item (set) in the third rank.
9 The 2-Rank image should still be in the Clipboard. Choose Edit menu> Paste.

YaPosition the pasted floater in the area you added. The images should be centered in the grid cells.

The Canvas Grid overlay should be turned on and set to the dimensions of your largest floater. Refer to the
instructions for creating a 2-Rank Nozzle for more information.

To add the Third Rank:
1 The 2-Rank image should still be in the Clipboard. Choose Edit menu> Paste.
2 Position the pasted floater in the area you added. The images should be centered in the grid cells.

3 Modify the images in this floater according to the third rank progression.

Using color as the third rank progression is by far the easiest change to implement. You can change the color
for a floater or selection using Effects menu> Tonal Control> Adjust Colors.

4 we used a change in the shape of the scales in this example. You might choose some other progression.
Keep in mind that you’ll use a different input factor to control image delivery in each of the three ranks.



5 Display the Floater List palette and make sure the Drop with Mask option is enabled.
6 Drop all floaters.
7 You might want to view the mask to make sure that each image element is masked.

8 save the file in RIFF format.

You will define this file as a 3-Rank Nozzle when you load it the first time. Refer to the description in “Creating
a 2-Rank Nozzle on a Grid,” earlier in this chapter.

Your sample file has items with a width of 50 pixels and a height of 50 pixels. It is a 3-Rank Nozzle with 12
items in rank 1,
6 items in rank 2, and 3 items in rank 3.



Nozzle Libraries
Nozzle libraries let you save and retrieve sets of nozzle files.

Refer to Chapter 1, “Getting Acquainted with Detailer,” for information on loading alternate libraries, creating
new libraries, and moving items between libraries.

To a dd a nozzle to the library:

1 Create and save a nozzle file.

2 Choose Brushes palette: Nozzle menu> Load Nozzle.

3 Locate your nozzle file in the directory and click OK.

4.f necessary, enter the values to define the number of elements, their size and rank.

5 choose Brushes palette: Nozzle menu> Add Nozzle to Library.

To check out a nozzle:
1in the Nozzle palette, choose the nozzle you want to work with.

2 Choose Brushes palette: Nozzle menu> Check Out Nozzle. Detailer opens the nozzle file in an image
window.

3 You may edit the file if you like.

470 put it back in the library, choose Brushes palette: Nozzle menu> Add Nozzle to Library.



Applying Effects
See also:
Image Editing and Effects

Image Orientation

Image Effects
Tonal Control

Surface Control

Focus

Esoterica



Image Editing and Effects
Many of Detailer’s effects are inspired by traditional artistic methods.

Detailer’s effects will be useful as you create map images. Effects are also used for making the finishing
touches to rendered images.

The Effects menu offers features for electronic retouching, sharpening and softening focus, and color
adjustment. Orientation effects include rotate, scale, and flip.

Special effects include glass distortion, embossing, posterizing, color overlay,
and warping.

In this chapter you’ll learn about these effects and how to take advantage of them.

Additional effects may be available as plug-ins. See “Making Plug-Ins Available to Detailer” in Chapter 1,
“Getting Acquainted with Detailer,” for information about how to access third party plug-in effects.

Most of Detailer’s effects are applied by making a selection, choosing a command from the Effects menu,
setting options, and clicking OK. If you do not make a selection, the effect will be applied to the entire image.

See also:
Selecting Where to Apply Effects

Effects and Open Palettes
Using Fade to Partially Undo Effects

Recently Used Effects Commands




Selecting Where to Apply Effects
You can apply an effect to a selection, to a floater, or to the entire image.

¢ |f you want to apply an effect to a region of an image, select that area before choosing an effect command.
You may use any of Detailer’s selection tools.

¢ |f you want to apply an effect to an image floater, select that floater before choosing an effect. Detailer
applies the effect to the entire floater.

Detailer automatically applies an effect to the entire image if no part of the image is selected.




Effects and Open Palettes

You can use all of the Materials palettes while the Effects dialogs are open. For effects that use color or
texture, you can change those Materials while you are experimenting with the effect, and see your changes
update interactively in the

Preview.

Suppose, for example, you are adding a Color Overlay to an image. The overlay effect depends on a selected
texture and the primary color. If you open the Materials: Texture palette and the Color palette when you
choose Effects menu> Surface Control> Color Overlay, you can select and/or change textures and colors.
These changes will be displayed in the Preview of the Color Overlay dialog. If necessary, you can open
texture libraries while the Color Overlay dialog remains open.

You can move Effects dialogs out of the way, if necessary, for full access to other palettes.



Using Fade to Partially Undo Effects

The Fade command allows you to undo any percentage of your last effect. This is a great way to achieve just
the right amount of an effect.

To fade an effect:
1App|y an effect to your image. To experiment, try one of the Tonal Control effects.
2 Choose Edit menu> Fade. The Fade dialog appears.

3 Drag the Undo Amount slider and watch the preview image change between the “before” and “after”
states.

4 When the preview shows the level of the effect you want, click OK.



Recently Used Effects Commands

The Effects menu consists of several submenus. Sometimes while you are working, you want to use the same
effect multiple times. Detailer makes this easy.

As you work, you’ll notice that the menu items for the last effects commands you’ve used are available at
the top of the Effects menu. This makes it easy to choose the commands again.

Shortcut: Detailer provides keyboard shortcuts for the two most recently used effects:

e Choose the last effect used
by pressing Command-/ (Macintosh) or Ctrl+/ (Windows).

® Choose the second to last effect used by pressing Command-; (Macintosh) or Ctrl+; (Windows).



Image Orientation
You can manipulate part or all of your image’s orientation by rotating, scaling, or flipping horizontally or
vertically.

These commands are located in the Effects menu> Orientation.
See also:

Rotate
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Rotate

You can rotate all or part of an image.

To rotate:
1 select the part of the image you want to rotate. To rotate the entire image, do not select anything.
Rotating the entire image floats the image and rotates the floater.

2 Choose Effects menu> Orientation> Rotate. The Rotate Selection dialog appears.

3You can rotate visually by dragging the corner of the selection. The Rotate Selection dialog reflects the
numerical value of the angle after you release the mouse or stylus. You can also rotate by entering the
desired angle in the dialog. A positive number rotates counterclockwise. A negative number rotates
clockwise.

4 Click OK or press Return or Enter. When you rotate an image, Detailer first turns the image into a floater
and then rotates it. The image will remain a floater until you drop it.



Scale

The Scale command lets you change the dimensions of part or all of an image.

To scale:
1if you want to scale only part of the image, select that part.

2 Choose Effects menu> Orientation> Scale. The Scale Selection dialog appears, and there are selection
handles on the selected area

3You can drag the handles on the image, or you can enter the percentages by which the size is increased or
decreased.

4 Choose from the Options—Constrain Aspect Ratio and Preserve Center:

Check Constrain Aspect Ratio to maintain the selection’s proportions. Unchecking this item lets you change
horizontal and vertical measurements independently.

Check Preserve Center to keep the item anchored in its location.

5 Click oK or press Return or Enter. When you scale an image, Detailer first turns the image into a floater and
then scales it. The image will remain a floater until you drop it.



Distort

You can distort the shape of an image or part of an image.

To distort:
1if you want to distort only part of the image, select that part.

2 Choose Effects menu> Orientation> Distort. Handles appear around the selection, and the Distort
Selection dialog appears.

3 Drag the handles to reshape the selection.
4 Choose the distortion method you want: Perspective or Bilinear.
5 Drag the handles to reshape the selection.

6 Check the Better (Slower) box to get a more accurate rendering of your changes. The Better method is
preferred when the distortion factor is particularly high.

7 Click OK or press Return or Enter. A progress dialog appears. Your selection will remain floating until you
drop it.



Flip Horizontal

Flipping an image horizontally creates the mirror image across an imaginary vertical axis down the center of
the image.

To flip an image horizontally:
Lif you want to flip only part of the image, select that part.

2 Choose Effects menu> Orientation> Flip Horizontal.



Flip Vertical

Flipping an image vertically creates the vertical mirror image of itself flipped across a horizontal axis.

To flip an image vertically:
1if you want to flip only part of the image, select that part.

2 Choose Effects menu> Orientation> Flip Vertical.



Transform Features

The transform effects are for Reference floaters. For complete descriptions, see the section on Reference
floaters in, “Floaters,”

Free Transform

Free Transform converts an Image floater into a Reference floater. This enables you to resize, rotate and slant
it by dragging the handles.

Set Transform
Set Transform lets you perform these same transformations numerically.
Commit Transform

Commit Transform converts the (transformed) Reference floater back into an Image floater.



Image Effects

Detailer’s Image Effects fall into several categories. Here are some of the tasks you can accomplish with the
many options of the Effects menu.

Tonal Control lets you adjust brightness/contrast, adjust color values (HSV) for an entire image or part of it.

Surface Control refers to changing surface textures, embossing, adding color overlays, applying lighting
effects, and warping.

The Focus commands let you soften or sharpen the focus, add glass distortion or motion blur effects.
Esoterica consists of the Highpass and Grid Paper features.

See also:

About the Using pop-up menus



About the Using pop-up menus
In many of Detailer’s Image Effects dialogs, you’ll see a pop-up menu named Using.

This menu lets you specify the source that Detailer uses as the control for applying an effect. The control
source determines how much of the effect to apply to different areas of the image.

The Using options vary between effects. They include Texture, Mask, Image Luminance, Pattern Luminance
and Uniform. These are described in the sections explaining the different effects.

In most cases, you can see the results of choosing different options in the Preview of an effect’s dialog. The
best way to see how these commands affect your images is to try them. You can always choose Edit menu>
Undo or Edit menu> Fade if you aren’t satisfied with the result.



Tonal Control
The Tonal Control commands in the Effects menu let you adjust or alter colors in an image.
See also:

Adjust Colors

Adjust Selected Colors

Brightness/Contrast

Equalize

Negative
Posterize



Adjust Colors

The Adjust Colors command lets you control the hue, saturation, and value of an image in much the same
way as you would adjust your TV.

To adjust colors:

11 adjust colors for only part of the image, select that part. If nothing is selected, the entire image will be
adjusted.

2 Choose Effects menu> Tonal Control> Adjust Colors. The Adjust Color dialog appears.

3The Using pop-up menu lets you control where and how much to apply the color adjustment. In all cases
other than Uniform Color, pixels assigned higher luminance from the Using source receive the greater color
adjustment.

4Adjust the sliders to control the overall hue, saturation, and value levels in the selection. You can see
changes in the Preview. You can pan the Preview by dragging if you want to.

5To return the image or selection to the way it was press, Reset. This resets all of the sliders.

6 When you are satisfied with the way your changes look in the Preview, click OK or press Return or Enter.



Adjust Selected Colors

Adjust Selected Colors is similar to the Adjust Colors effect, but it works only on a specified range of colors
within an image. You choose a color in an image and adjust colors within a range of that color. You could, for
example, turn yellow peppers to red peppers.

You can adjust colors that are exactly the same as the color you select, or you can choose colors within a
range, based on proximity (on the color wheel or color space) to the selected color.

To adjust selected colors:
1 Choose Effects menu> Tonal Control> Adjust Selected Colors.

21In the image window, click the color you want to adjust.

When you pick a color, the Color palette updates to your choice.

3 Choose an option from the Using pop-up menu to determine what Detailer uses as the source for the color
adjustment. For example, Image Luminance uses the brightness of the image to control the color adjustment.

4 Adjust the Extents and Feathers sliders.

Use the Extents sliders to specify the extent of the HSV color space around the selected center color. Move
the Extents sliders to the right to increase the size of the color range that is affected by the command.

Adjust the H Extents slider to control the range of hues affected. The percentage you choose means that only
hues within that fraction of hues on the color wheel will be affected.

Adjust the S Extents slider to control the range of saturation affected. Only saturations within this range will
be adjusted.

Adjust the V Extents slider to control the range of values affected.
The Feather sliders affect the softness at the edge of the selected colors.

5 Adjust the sliders accordingly to control the overall hue, saturation, and value levels. Watch the results in
the Preview. You can pan the Preview to see different parts of the image.

6 When you are satisfied with the way your changes look in the Preview, click OK or press Return or Enter. To
remove your changes from the Preview and return your image to the way it was, press Reset.



Brightness/Contrast

The Brightness/Contrast effect adjusts the brightness and contrast of the overall image in the RGB color
space. Alternatively, the Adjust Dye Concentration command (described later in this chapter) converts the
image to a dye density domain and adjusts it there.

To adjust RGB brightness and contrast:

1 To adjust brightness and contrast of only part of the image, select that part. If nothing is selected the entire
image will be adjusted.

2 Choose Effects menu> Tonal Control> Brightness/Contrast.

3 Drag the upper slider to adjust image contrast. Drag the lower slider to adjust image brightness. The
image is redrawn when you let up on your mouse or stylus.

4.f you want to reset the sliders to normal, click Reset.

5 When the adjustments are the way you want them, click Apply to save the adjustments.



Equalize

The Equalize effect improves contrast by adjusting black and white points and distributing the brightness
levels throughout the entire range of available levels. To achieve this, Detailer creates a histogram showing
the number of pixels for each brightness level value. Equalize allows gamma adjustment, which lightens or
darkens an image without changing highlights or shadows.

To equalize:
11 adjust only part of the image, select that part. If nothing is selected, the entire image is adjusted.

2 Choose Effects menu> Tonal Control> Equalize. The Equalize dialog appears. When you initially bring up
the Equalize dialog, Detailer automatically adjusts the image so that the lightest color is white and the
darkest color

is black.

3 Click OK or press Return or Enter to automatically equalize the selection.

You can adjust contrast manually by setting the black and white points in the
histogram.

To set the white and black points manually:

Linthe Equalize dialog, drag the small white point marker under the histogram to the left and drag the
black point marker to the right.

Now, any values in the image located to the right of the white marker become white; any values to the left of
the black marker become black.

2 Click OK to apply changes.

Changing the gamma adjusts only the midtones of an image and leaves the white and black areas
untouched.

To adjust the image’s gamma:

1 move the Brightness slider to the right to increase gamma, which makes the image  darker. Move the
slider to the left to decrease gamma, making the image lighter. Your changes will be apparent while you’re
still in the dialog.

2 Click OK to apply changes.

To cut down on the time it takes to compute a histogram in the Equalize dialog, you can select an area of
your image that represents the range of grayscale shades in the entire image. If you are happy with the
results, check the Apply to Entire Image checkbox, click OK and Detailer will equalize the entire image. Do
not check Apply to Entire Image and click OK to equalize the selection only.



Negative

Choose Effects menu> Tonal Control> Negative to turn part or all of your image into a negative. The
Negative effect will simply invert all the colors in your image.



Posterize

Posterizing changes the number of color levels in the image.

To posterize an image:

11 posterize only part of the image, select that part. If nothing is selected, the entire image will be
posterized.

2 Select Effects menu> Tonal Control> Posterize. The Posterize dialog appears.
3 Enter a number of levels. The lower the number you enter, the more dramatic the effect will be.

4 Click OK or press Return or Enter.

To posterize an image combined with a texture, use Apply Screen under Effects> Surface Control. To
posterize to two levels and adjust the threshold level, use Equalize.




Surface Control

Some of Detailer’s most unusual image-editing effects are in the Surface Control submenu of the Effects
menu. You can manipulate texture, color, and light to produce a variety of interesting visual effects. Many of
these effects will allow you to add texture to an image, which can give the illusion that it was created on
canvas or paper.

See also:
Apply Lighting
Customize Lighting
Apply Screen
Apply Surface Texture
Color Overlay
Dye Concentration
Express Texture
Image Warp
Quick Warp



Apply Lighting
Apply Lighting is a 2D effect that lets you shine one or more light sources on part or all of your image.

Apply Lighting is a 2D Effect for working on images. It has no connection with the Light palette used to
illuminate your 3D model. You may want to use Apply Lighting to enhance a finished rendering.

Apply Lighting is comparable to hanging your artwork in a gallery and adjusting colored spotlights to
illuminate it.

You can choose different lighting effects from a library provided, or you can create your own effects by
defining brightness, distance, color, and other characteristics. Once you have achieved a lighting effect you
like, you can save it in a library for use with other images.

To apply lighting effects from a library:

1if you want to apply lighting to only part of the image, select that part. If nothing is selected, the entire
image is affected.

2 Choose Effects menu> Surface Control> Apply Lighting. The Apply Lighting dialog appears.

The scrolling list contains preset lighting effects in the library. When you first open the dialog, the first effect
is selected (it has a box around it), and its name appears under the scroll bar.

Open the Lighting Mover by choosing Command-Shift-L (Macintosh) or Ctrl+Shift+L (Windows).

3 Click a lighting effect in the scrolling region to see the effect in the Preview. Use the scroll bar to see and
select other effects.

4 after you choose a lighting effect, click OK or press Return or Enter.



Customizing Lighting

You can use the controls in the Apply Lighting dialog to achieve other lighting effects. The Preview shows
your changes, so you can experiment and see the results.

Setting the Light Source

The Preview shows one or more light indicators. You can add and delete lights if you want. The small part of
the indicator points in the direction that the light is shining; the large part shows where the light actually is.

Standard camera-based principles apply to editing lighting. For example, if you turn up the lights, you may
need to adjust exposure.

* To move the indicator, drag its large end.

* To change the light source direction, drag its small end.

* To create another light indicator, click anywhere else in the Preview.

* To delete an indicator, click the indicator to select it. Then press Delete or Backspace.

* To change the settings for a light, click on the indicator to select it. Then adjust the sliders to set the light
as described below.

Use the following guidelines to adjust the sliders:

® Brightness is like a dimmer knob. Moving the slider to the left turns down the light source, moving it to the
right increases the selected light’s brightness.

* Distance controls how far the light is from the image. If you move the light source closer, you may have to
change the image’s exposure (see below).

® Elevation sets the light’s angle in relation to the canvas. At 90; the light is shining straight down, and at
1; it’s very shallow.

e Spread sets the angle of the light cone.

® Exposure is the image’s brightness as in photography. Moving the slider to the left (decreasing exposure)
darkens the image as a whole. Moving the slider to the right (increasing the exposure) lightens the image as
a whole.

* Ambient is the surrounding light in an image. If you had no individual lights in your image, the ambient
lighting would govern the overall lightness of the image. Moving the slider to the left darkens the overall
lighting; moving it to the right increases the light.

Setting the Light Color

Click the Light Color square and choose a color for the selected light source in the Color Picker. Then click OK
or press Return or Enter.

Setting the Ambient Light Color

Click the Ambient Light Color square and choose a color for the surrounding light in the Color Picker. Click OK
or press Return or Enter.

Saving Lighting Effects

When you have adjusted lighting and created an effect you like, you can save it. In the future, your saved
lighting environment will be available in the library at the bottom of the dialog.

To save a specific lighting effect:
1 After making your changes, click Save.
2Type a name for your new lighting effect.

3 Click OK or press Return or Enter. It is now a choice in the list and you can apply it to any image.

When you have finished making changes in the Apply Lighting dialog, click OK or press Return or Enter or
Enter.

Creating Lighting Effects Libraries

You may create your own lighting library. Click Library. Detailer displays a dialog that lets you create a new
library or load an existing one.



To access the Lighting Mover, close the Apply Lighting dialog and press Command-Shift-L (Macintosh) or
Ctrl+Shift+L (Windows).



Apply Screen

Apply Screen is another way to add texture to an image. It combines luminance, the current texture, and the
three colors you pick in the Apply Screen dialog to add a three-color screen to an image.

To use Apply Screen:
1 select an area. If nothing is selected, the effect applies to the entire image.
2 Choose Effects menu> Surface Control> Apply Screen. The Apply Screen dialog appears.

3 Click each square to call up the Color Picker. Select the color you want to use, then click OK or
press Return or Enter.

4 Move the Threshold 1 slider to determine how much of the right and middle squares’ color will be in the
image. Moving the slider to the left increases the amount of the right color. Moving the slider to the right
increases the amount of the middle color.

5 Move the Threshold 2 slider to determine how much of the left square’s color will be in the image. Moving

the slider to the left decreases the amount of the left color. Moving it to the right increases the amount of the
left color.

6 The Using pop-up lets you specify what to base the screen on. Choose an option from the Using pop-up:

e Texture produces a screen using the current texture. If the Texture palette is open, you can choose
different textures while the Apply Screen dialog is open.

. Image Luminance creates a screen based on the image’s brightness. It is similar to a three-level
posterization.

e  Pattern Luminance creates a screen based on the current pattern’s brightness.

® Mask creates a screen based on the mask’s brightness.

7 Click OK or press Return or Enter.



Apply Surface Texture
Detailer lets you add a three-dimensional surface texture to your image.

Apply Surface Texture is a 2D effect for developing imagery. It is not related to the texture map or bump
map. The current texture in the Texture palette is one option for controlling the Apply Surface Texture effect.

The Reflection feature lets you map a separate image onto the surface. This gives the effect you’d expect to
see in objects made of glass or polished metal, like the chrome bumper of a classic car.

If you want, you can apply a texture when you first create an image, then paint or draw over it. But the
texture is erasable, so you might not end up with the same texture across the document surface. Generally,
youw’ll add the surface texture as the last step in producing artwork.

Brush variants with “Grainy” methods reveal the texture automatically in their strokes. See Chapter 9,
“Advanced Painting,” for more information.

To Apply Surface Texture:

1vou may create a selection area or select a floater if you want to apply the effect to less than the entire
image.

2 Choose Effects menu> Surface Control> Apply Surface Texture.

3The adjustments for working with surface texture are described below. When you’ve set them, click OK to
apply the effect.

See also:
Using
Material
Light Control
Reflection Maps



Using
The Using pop-up lets you specify where to get the texture.

* Texture applies the current texture. If the Texture palette is open, you can choose different textures and
change their scale. The Preview automatically updates to texture changes.

* Mask produces surface texture using the canvas mask or the selected floater’s mask. The effect is an
embossing around the edges. The Softness slider controls the accentuation of the effect.

Image Luminance uses the current document’s luminance to determine where to add surface texture. If
brush strokes appear in your image, this will give them depth.

e Pattern Luminance uses the current pattern’s luminance.
If you want to change the direction of relief, click the Inverted check box.

* The Softness slider lets you control the transitions in texture. Increasing softness creates more
intermediate steps, which produces a smoother distortion. If you experience aliasing or stair stepping, try
increasing Softness.

It is the nature of JPEG images to sometimes produce blocky patterns when using Apply Surface Texture.




Material
Set the Material sliders to describe the texture you want.

* Move the Amount slider to control how much surface texture is applied to the image. Moving the slider all
the way to the right applies the maximum amount.

* The Picture slider controls the amount of color in the picture. At 100% the full color of the picture shines
through. Turn the Picture slider down and color is removed to black, leaving only the shine.

* Move the Shine slider to control the highlights. More Shine creates an aluminum-foil effect.
* The Reflection slider maps the current pattern onto the surface based on the reflection percentage.

The Preview shows how the options look on your image.



Light Control
You may have multiple colored lights active to produce different textural effects.

This light control applies only to the Apply Surface Texture effect.

The lighting preview sphere shows all possible surface angles and how the lights illuminate them.

You may either use the basic positions, offered by the direction radio buttons, or you may create custom
lighting by working in the sphere.

The Show Light Icons check box lets you hide or show the light icons.
* To create a new light, click on the sphere. A new light icon (small circle) appears where you click.
* To change a light’s angle, drag its icon on the sphere.

* To select a light, click in its icon. Notice the selected light has a thicker, dark icon. You may change the
selected light’s color and other characteristics.

* To choose a new color for the selected light, click the Light Color box.
* To delete the selected light, press the Delete or Backspace key on your keyboard.

The Light Direction control should be used only as a starting point to develop more complex lighting. If you
have developed complex lighting with several lights of different colors and you decide to use the basic Light
Direction control to change a light’s direction, it will restore the default to one light and reset the color

to white.

® Brightness indicates the amount of contribution of the light to the overall lighting color.
® Conc (concentration) adjusts the spread of the light’s shine over the surface.
® Exposure globally adjusts the overall lighting amount from darkest to brightest.

* Display affects the lighting preview only. If you have a darker color for the display, it can be easier to see
subtle lighting adjustments.

Set light positions in the Preview sphere.

When the Preview shows the image is the way you want it to be, click OK or press Return or Enter.



Reflection Maps

The Reflection slider in the Apply Surface Texture dialog maps the current pattern onto the 2D surface at an
adjustable percentage.

This section describes reflection mapping as part of the Apply Surface Texture effect. The functionality is
similar to the reflection mapping used on objects.

To take advantage of reflection mapping, a few steps are required.

To use 2D reflection mapping:

1 Create the image you want to use as the reflection. Because the reflection describes the environment
around the reflective surface, the image used is sometimes called an environment map. You’ll probably want
to warp the image to approximate the reflection from a curved surface.

You may want to use the environment images provided on the Detailer CD-ROM for your reflection
environment.

2 Capture the reflection image as a pattern.

3 Create a floater to apply the effect to. You will be using the mask to control the placement of the reflection.
A floater simplifies the process because its mask matches the shape of the reflection area exactly.

4 select the floater. When a floater is selected, effects apply only to the floater.
5 Open the Effects menu> Surface Control> Apply Surface Texture dialog.

O1n the Using pop-up, choose Mask.

7 Set the Reflection slider to describe the amount of reflection you want.

8Adjust the Softness slider to control the mapping from the edges of the floater image. Increasing Softness
gives a rounder, more three-dimensional look to the surface.

9when you have set the other sliders and are satisfied with the preview, click OK.



Color Overlay
Use the Color Overlay command to simultaneously add color and texture effects to an image.

You may want to have the Color and Texture palettes open.

To apply a Color Overlay:

1 select the area you want to affect. If nothing is selected, the effect applies to the entire image.
2 Select the color you want to use.

3if you want to base the color on a texture, set the Using pop-up to Texture and select a texture in the
Texture palette.

4 Choose Effects menu> Surface Control> Color Overlay.

5 Choose between a Dye Concentration and Hiding Power overlay.

* Dye Concentration means the paper absorbs the color.

e Hiding Power means the color covers what’s beneath it.

6 Move the Opacity slider until the preview reflects your preferred opacity.

7 Choose a command from the Using

pop-up:

L Uniform Color adds a flat tint to the image.

. Texture overlays color using the current texture.

® Mask uses the values in the mask as the model for the color overlay.

. Image Luminance uses the image’s brightness as the model for the color overlay.

. Pattern Luminance uses the luminance of the current pattern as the model for the color overlay.

8 Click OK or press Return or Enter.

If you are overlaying in an image that is associated with a model, the overlay effect will appear on the model.



Dye Concentration

The Dye Concentration effect adjusts color intensity and adds surface texture by adjusting pigments. You can
use it, for example, to lighten an underexposed photo or to darken an overexposed one.

To adjust Dye Concentration:

Lif you want to adjust only part of the image, select that part. If nothing is selected, the entire image is
affected.

2 Choose Effects menu> Surface Control> Dye Concentration. The Adjust Dye Concentration dialog appears.

The Materials: Texture palette can be used while the Dye Concentration dialog is open.

3 Choose a command from the Using

pop-up:

. Uniform Adjustment adjusts color uniformly.

U Texture adjusts color using the current texture.

. Mask uses the values in the mask as the model for the dye concentration.

. Image Luminance uses the image’s brightness as the model for the color adjustment.

. Pattern Luminance uses the luminance of the current pattern as the model for the adjustment.

When you choose Uniform Adjustment, moving the Maximum slider above 100% increases color density. A
value below 100% decreases it. Moving the Minimum slider has no effect. With the other Using pop-up
commands selected, both sliders are operable.

If you think of texture as peaks and valleys, the Maximum slider controls the dye on peaks and the Minimum
slider controls dye in the valleys. You can set Maximum as high as 800%. The lower you set Minimum, which
can be as low as 0%, the higher the contrast will be between peaks and valleys. The higher the Minimum
slider, the flatter the texture will appear.

4 Click OK or press Return or Enter.



Express Texture

Express Texture generates a high contrast version of an image in grayscale. With this feature, you can
create a visual effect similar to a custom halftone screen, like a mezzotint or line screen. It is also the best
way to create bump maps from a texture.

Express Texture is similar to Apply Screen with anti-aliasing built in.

To use Express Texture:
1 choose Effects menu> Surface Control> Express Texture. The Express Texture dialog appears.

2 Make a selection from the Using pop-up menu.

You can base the effect on the current Texture, Mask, Image Luminance or Pattern Luminance.
3 Adjust the sliders:

® Gray Threshold determines where the threshold is, between pure black and pure white.

* Grain determines how deeply the texture penetrates the surface.

e Contrast determines how many levels of black and white there are. For example, low contrast generates
pure gray, medium contrast produces levels of grayscale, building up to a high contrast black and white
screen.

If you want to add color back in after using this effect, try using the Edit menu> Fade command. This will
bring back the original colors of the image.



Image Warp

The Image Warp command lets you distort the surface of an image as if it were a sheet of pliable film. With
this command, your images can look as though they’re reflected in a fun house mirror.

To warp an image:
Lif you want to warp only a part of an image, select that part.
2 Choose Effects menu> Surface Control> Image Warp. The Image Warp dialog appears.

3 The Size slider controls the size of the area affected by dragging the cursor. The higher the percent, the
smaller the affected area.

4 Choose a warp method:
® Choose the Linear radio button to pull the selected area as if you were pulling from the top of a cone.
® Choose the Cubic radio button to pull a flat surface.

® Choose the Sphere button to pull a surface as if it were a lens.

5 Drag the cursor over the Preview to distort the image. A circle appears as you drag, denoting the area
affected.

© When you have finished warping the image, click OK or press Return or Enter.



Quick Warp

The Effects menu> Surface Control> Quick Warp feature lets you easily create some of the basic distortions.
These distortions are useful in preparing images for environment maps.

Quick Warp applies to the entire canvas—not to selections or floaters.

* The Amount and Angle Factor sliders control the warp effects.

® Sphere warps the image spherically, like a reflection on a polished silver ball.

* Bump warps the center of the image toward you, making it appear convex.

* Valley warps the center of the image away from you, making it appear concave.

* Swirl distorts the image in a spiral. The Angle Factor controls how many times the image spirals.

* Ripple distorts the image in concentric rings, like a reflection in a pool of water when you drop in a stone.



Focus

The Focus commands in the Effects menu let you create glass distortion, motion blurring, sharpening and
softening effects.

See also:
Glass Distortion
Motion Blur
Sharpen

Soften

Super Soften



Glass Distortion

Glass Distortion offers powerful tools for distorting an image. You can use it to put your image behind the
pebble glass of a shower door, or you can distort your image beyond recognition.

A myriad of effects are possible with Glass Distortion. So many, in fact, that you’ll probably want to
experiment for a while before settling on the effect you like.

Glass Distortion works by relocating the pixels of the image. Detailer lets you control the rules used for
relocating the pixels. The primary controls are the displacement map type and what information it uses to
create the map.

To use Glass Distortion:

1 You may create a selection area or select a floater if you want to apply the effect to an area smaller than
the entire image.

2 Choose Effects menu> Focus> Glass Distortion. The adjustments for working with glass distortion are
described below. As you make changes, the Preview shows their effect. When you’re satisfied with the
settings, click OK to apply the effect.

3The Using pop-up lets you specify the basic information the displacement map begins with. The amount of
displacement depends on the value assigned to the image pixels from the Using source.

e Texture uses the current texture. Texture is good for creating the pebbled glass effect. Unless you want
frosted glass, you’ll probably want to increase the scale of the texture using the Scale slider on the Texture
palette.

* Mask uses this image’s mask data. This is a good choice for a controlled distortion map. For example,
gradations in the mask lead to a progressive distortion effect. Shapes in the mask distort in the fashion of
their shape.

* Image Luminance uses the current document’s luminance.

e Pattern Luminance uses the current pattern’s luminance.
4\f you want to work with an inversion of the Using information, click the Inverted check box.

5 The Softness slider lets you control the transitions between displaced colors. Increasing Softness creates
more intermediate steps, which produces a smoother distortion. If you experience aliasing in a glass
distortion, try increasing Softness.

6 The Map pop-up lets you choose the type of displacement to use:

e Refraction displaces pixels like an optical lens bends light. This is the best map type for distortions you’d
expect from looking though glass.

e Vector Displacement moves pixels in a specific direction.

* Angle Displacement moves pixels in different directions.

7 The following sliders give you precise control over the “glass.”

* The Amount slider lets you control the degree of displacement. Increasing the Amount distorts your
image more.

* The Variance slider lets you create multiple variations in the neighborhood of the displacement. The
result of increasing Variance depends on the type of image and other settings.

* The Direction slider lets you control the direction of displacement. Three o’clock corresponds to 0j.
Refraction is not dependent on direction.

8 When you like what you see in the preview click OK or press Return or Enter.



Motion Blur

This effect makes an image appear as if it has been blurred by movement.

To apply Motion Blur:
11 adjust only part of the image, select that part. If nothing is selected, the entire image is blurred.
2 Choose Effects menu> Focus> Motion Blur.

3 Use the following guidelines to set the sliders.

. Radius sets the amount (distance) of blur. Moving the slider to the right makes the image look like it’s
moving faster.

U Angle sets the direction in which the image seems to travel. Zero degrees blurs in the direction of 3
o’clock.

] Thinness blurs the image in a direction perpendicular to the angle you choose with the Angle slider.

4 Click OK or press Return or Enter.



Sharpen
This effect heightens contrast by intensifying highlights and shadows.

To sharpen focus:

11 adjust only part of the image, select that part. If nothing is selected, the entire image is adjusted.
2 Choose Effects menu> Focus> Sharpen.

3 Use the following guidelines to set the sliders.

. Radius determines how much of the edge of an element is affected. The farther the slider is to the right,
the wider the affected area will be.

U Highlight determines the intensity of the bright areas. The farther the slider is to the right, the brighter
the highlight will be.

. Shadow determines the depth of the shadows. The farther the slider is to the right, the darker the
shadows will be.

4 when you like the focus, click OK or press Return or Enter.



Soften

This effect increases the transition from one part of your image to another, enhancing the anti-aliasing
of strokes.

To soften focus:
1 o adjust only part of the image, select that part. If nothing is selected, the entire image is adjusted.
2 Choose Effects menu> Focus> Soften. The Soften dialog appears.

3Adjust the Radius slider. The farther the slider is to the right, the more steps there will be between one
image element and another, which will mean more blurring.

4 Click OK or press Return or Enter.



Super Soften

Super Soften is a faster form of Soften. Super Soften’s Wrap Around feature is particularly useful for
developing seamless maps and pattern tiles.

To super soften:

11 adjust only part of the image, select that part with the Rectangular Selection tool. If nothing is selected,
the entire image is adjusted.

2 Super Soften is available only as a keyboard command. Choose Command-Shift-S (Macintosh) or
Ctrl+Shift+S (Windows). Detailer opens the Super Soften dialog.

3 Enter a value for the softening Radius. A larger a value means more blurring.

4 Enable the Wrap Around check box if you want the image to maintain seamless tiling.

The Wrap Around feature softens the pixels on one edge with those on the other. This ensures the image will
tile seamlessly.

5 Click oK or press Return or Enter.



Esoterica
Esoterica holds specialized effects.
See also:

Highpass

Grid Paper



Highpass

Highpass suppresses low frequency areas containing gradual or smooth transitions of brightness levels. This
leaves high
frequency areas, or just the edges of an image, containing stark shifts between brightness levels.

You can make the highpass more pronounced by using the Equalize command.

To use Highpass:
1if you want to affect only a part of an image, select that part.
2 Choose Effects menu> Esoterica> Highpass. The Highpass dialog appears.

3 Move the Radius slider to determine the amount that the low frequency areas will be suppressed. This
value defines a radius in pixels around each pixel in the selected image area. Moving the slider to the left
suppresses larger amounts of low frequency information. Moving the slider to the right suppresses smaller
amounts of low frequency information.

4 Click OK or press Return or Enter.



Grid Paper

Using Grid Paper, you can add horizontal or vertical lines or a grid to part or all of your image. The lines
become part of the image, and therefore are an element in your design.

Unlike the Grid Overlay, a transparent layer that floats above your image as a reference, Grid Paper becomes
part of your image.

Grid Paper is an excellent guide to use when you are unsure about the mapping mode or map aspect. The
regularity of the grid clearly demonstrates the mapping and distortion.

To add Grid Paper:
1if you want to apply Grid Paper to only a part of an image, select that part.
2 Select Effects menu> Esoterica> Grid Paper. The Grid Options dialog appears.

3 set the following:

®  Grid Type determine whether your grid will have rectangles, vertical lines, or horizontal lines.
* Horizontal Spacing determines the amount of space between horizontal lines.

* \Vertical Spacing determines the amount of space between vertical lines.

. Line Thickness sets the width of grid lines.

®  Grid Color changes the color of grid lines. Click the color square to display the Color Picker. Choose a
color in the Color Picker, then click OK or press Return or Enter.

. Background changes the grid’s background color. Click the background color square to display the Color
Picker. Choose a color in the Color Picker, then click OK or press Return or Enter.

4 Click OK or press Return or Enter.



Printing

You can print Detailer images on many kinds of printers including PostScript, QuickDraw, Windows GDI
printers and high-resolution imagesetters.

Although your final goal may be to print high-quality color prints, it is a good idea to first print proofs on any
printer you have available.

You can use a black and white printer to check page size and placement of images on the page. If you have a
color printer, you can print proofs to get a general impression of what your image looks like. Keep in mind
that the proof will not be an accurate representation of a final product produced by an offset printing
process. The print process, inks, and paper types all affect the final output.

See also:
Color Matching
Page Setup (Macintosh) and PostScript Setup (Windows

Using the Print Dialog

Printing Tips




Color Matching

In an ideal world, each color on your monitor would match the respective color on the printed page. Due to
the number and kinds of things that affect the color at each point in the process (from a monitor adjustment
to the mixing of inks, to the porosity of the paper) a perfect match of all the colors used is unlikely.
Nevertheless, it is important to adjust those elements that you can control.

See also:
Color Calibration

Trial and Error



Color Calibration

Color calibrators are hardware devices that use software to balance the color and gamma (brightness and
contrast) of your monitor.

Calibration software can be used to adjust your monitor to reflect what your printed piece will look like. This
is done with printer profiles that are either packaged with a software program or created with the program.
Some image-editing software packages, such as Photoshop have color calibration capabilities built in.



Trial and error

In the final analysis, calibration is a matter of trial and error. If you have no calibration software, but you do
have access to the output device, you can print your file, hold it up next to your monitor and see how closely
the match may be. Use the brightness and contrast controls on your monitor to make adjustments. If you
have software that can adjust the RGB values of your monitor, use them to get an even closer match.



Page Setup (Macintosh) and PostScript Setup (Windows)

Options for setting up your file for printing depend on several factors—the output device, color versus black
and white printing, and whether or not you are printing separations.

Macintosh options are in the File menu > Page Setup dialog.
Windows options are contained in the File menu > PostScript Setup dialog.

The features offered in the Macintosh and Windows dialogs are the same. If you don’t have a PostScript
printer selected, the PostScript options won’t appear.

See also:
Miscellaneous printing options
Halftone Screen Setting for PostScript Printers

Options for Files Saved as EPS
Saving in EPS for Printing




Miscellaneous printing options
These options are available in all printing situations:
See also:

Size to Fit Page

Printer/Press Dot Gain

Monitor Gamma



Size to Fit Page

Choose this option if you want Detailer to shrink an image that is larger than a selected page size. For
example, when this option is checked, a 12” x 12” image would be resized to fit on an 8 1/2” x 11” page.
Detailer resizes the image to fit the page.

If an image is larger than the page size and you haven’t checked Size to Fit Page, you see an alert message
when you print. Click Continue, and the image will be clipped to fit the page. Click Cancel to stop printing.
You can then open the Page Setup (Macintosh) or PostScript Setup (Windows) dialog and choose Size to Fit
Page.



Printer/Press Dot Gain

Your print shop should be able to tell you what the dot gain will be for a specific job. Dot Gain is the amount
any halftone dot grows when it is printed. Depending on the type of printing press, paper, and ink you use,
halftone dots may grow, causing an image to become darker than you wish.

To account for this dot gain, Detailer allows you to enter a percentage of dot gain that will adjust halftone
dots so they print at the size you intended. For example, if a 50% dot on film grows to 70% after it is printed,
the dot gain is 20%. If the dot gain setting is too high, the printed results will be too light. If the dot gain
percentage is too low, the printed results will be too dark. Typically, web offset presses have dot gains of
around 25% and sheetfed presses have dot gains of 5% to 10%.



Monitor Gamma

The gamma, or brightness, of your monitor and the printing gamma must be the same to get the printout to
match what you see on your monitor.

If you haven’t used a third-party optical hardware calibration device to change your monitor’s gamma, you’re
pretty safe leaving the Monitor Gamma at 1.8. If you do use one of these calibration devices, we recommend
that you set it to 1.8. If, however, you’ve set your monitor to another gamma, change the Monitor Gamma in
Page Setup (Macintosh) or PostScript Setup (Windows) dialog to the same number.



Halftone Screen Settings for PostScript Printers

When you select a PostScript printer, several other factors are available in the setup dialog—Screen
Frequency, Angle, and Spot Type. These options affect halftones.

A halftone is an image composed of a series of dots of various sizes. In grayscale printing (newspapers), the
varying dot sizes suggest different shades of gray to the eye. In process color printing (cyan, magenta,
yellow, and black), varying dot sizes and screen angles give the illusion of millions of colors. Keep in mind
that a halftone dot is composed of pixels. The dots are arranged on an imaginary grid, called the halftone
screen.

See also:
Screen Frequency
Halftone Angle
Spot Type



Screen Frequency

Screen Frequency represents the fineness of the halftone screen, which is made up of rows of dots. The
spacing between halftone dots is referred to as lines per inch or Ipi. The paper porosity and the type of press
determines the viable halftone frequencies. Newspapers, for example, are very porous and usually print at
85 Ipi. A high-quality magazine on glossy paper will print at 150 Ipi.

If you are printing a separation, Detailer lets you set the screen frequency for the four process colors: cyan,
magenta, yellow, and black.

Be sure to consult with your service bureau for specific recommendations on screen frequency.



Half Tone Angle

This is the angle at which your halftone screen “rests” on your image. When printing separations, these
angles can be set for each of the process colors.



Spot Type

The Spot Type pop-up menu gives you options for the shape of the dots that make up your halftone screen
grid. For an explanation of these spot shapes and how to make a Custom spot, see the following section.



Options for Files Saved as EPS

Detailer files that have been saved as EPS files conform to the Desktop Color Separation format ( EPS-DCS
5-file format). Remember, when you save a file as EPS-DCS, Detailer uses the Printer Settings file (Macintosh)
or PRINTER.STG (Windows) in your Detailer folder to make the separation files. If you want to use the screen
angles and frequency specified in the Page Setup (Macintosh) or PostScript Setup (Windows) dialog, check
the box next to Use Page Setup settings in the EPS Options dialog.



Saving in EPS for Printing

Detailer’s EPS files conform to the Desktop Color Separation format (EPS-DCS 5-file format). Although
Detailer save files in EPS-DCS, it can’t read EPS-DCS. If you plan to save an image in EPS-DCS, it’s a good
idea to save it in another format first so you will have a copy of it that you can reopen in Detailer.

When you save a file in EPS-DCS, you’ll see the EPS Options dialog.

Although you can save your images as 5-file CMYK EPS separations, Detailer can’t open or edit CMYK files.

See also:
Hex (ASCII) Picture Data
Suppress Dot Gain
Suppress Screen Angles
Use Page Setup Settings
Halftone Dot Type
Save PostScript data into File



Hex (ASCI) Picture Data

This is just another way of storing PostScript information. Some programs require that this option be
checked. The file size will be approximately twice as large when the file is saved with this option.



Suppress Dot Gain

Detailer provides controls for dot gain in its Page Setup (Macintosh) or PostScript Setup (Windows) dialog. You

may, however, prefer to set dot gain in your page-layout program. To disable Detailer’s dot gain adjustments,
check the box next to Suppress Dot Gain.



Suppress Screen Angles

Like dot gain, screen angle can be designated in Detailer’s PostScript Setup dialog. To disable Detailer’s
screen angle adjustment, check the box next to Suppress Screen Angles.



Use Page Setup Settings

Detailer includes a file called  Printer Settings file (Macintosh) or PRINTER.STG (Windows), which is
calibrated for an imagesetter at 133 Ipi, standard screen angles, and a dot gain of 16%. If you wish to
override these settings and use your own settings in the Page Setup (Macintosh) or PostScript Setup
(Windows) dialog, click the box next to Use Page Setup settings.



Halftone Dot Type

The Halftone Dot Type pop-up menu gives options for the shape of the dots that make up your halftone screen
grid. Most of the shapes listed in the pop-up menu, such as Dot, Line, and Ellipse, are self-explanatory. The
Custom setting lets you create your own spot shape using a PostScript command. You’ll have to know the
PostScript language to do this. In a text file, write the PostScript equivalent of the spot you want to design.
For example, here’s how to describe a shape that resembles a diamond:

180 mul sin exch 180 mul sin add 2 div

Next, name the text file Custom Screen and place it in your Detailer folder. Now go back into Detailer and
choose Custom from the Halftone Dot Type pop-up menu. Detailer will access this Custom Screen document
and make your dots resemble diamonds. If you create a few PostScript spot shapes, each will have its own
text file, and you’ll use them one at a time, renaming each file Custom Screen so Detailer can find it.



Save PostScript data into File

To save a printable preview of an EPS-DCS document, check  Save PostScript data into preview file. The two
radio buttons under Preview Options tell Detailer whether the preview data should be saved in black and
white or color.

If you have an older laser printer, you may have to use the black and white preview to print these files on
your laser printer. Although the preview or display is black and white, the color information remains intact.



Using the Print Dialog

Once you have chosen options, you are ready to print.

To print an image:

1 choose File menu> Print to open the Detailer Print dialog. The top half of the dialog contains the standard
print commands.

2 Select one of the four printing methods Detailer supports.

For Macintosh only, check Color QuickDraw if your printer uses color or black-and-white QuickDraw. (A
common color QuickDraw printer is the Hewlett-Packard PaintJet.) You cannot print separations to QuickDraw
printers. The Page Setup options of Spot Type and screen frequencies have no effect on printer output.

For Windows only, check GDI Printing if your printer is not a PostScript printer. Some common examples are
the Hewlett-Packard Desk]et, the Canon Bubblejet, and the Epson Stylus. You cannot print separations to
non-PostScript printers. The PostScript Setup options of Spot Type and screen frequencies have no effect on
printer output.

Check Color PostScript if you plan to print to a color PostScript device. (The QMS ColorScript and Tektronix
color thermal printer are examples of PostScript printers.) PostScript printers take advantage of the Spot
Type, Screen Frequency, and Angle options in the Page Setup (Macintosh) or PostScript Setup (Windows)
dialog.

Check  Separations to print separations. The output consists of four pages, one each for cyan, magenta,
yellow, and black. You can print separations from Detailer with any PostScript device, including high-
resolution imagesetters. Good separations depend on the right screen frequency and angle. Printer/Press Dot
Gain and Spot Type are also crucial for producing quality color separations. Check with your imagesetting
service bureau about the kind of setup that is necessary for the kind of equipment you are outputting files to.

For Windows—Although Detailer uses the PostScript Setup dialog information for screen angles and
frequency, Detailer still uses the color separation data in the PRINTER.STG file.

When you save a file as EPS-DCS, Detailer uses the PRINTER.STG file in your Detailer folder to make the
separation files. If you want to use the screen angles and frequency specified in the PostScript Setup dialog,
check the box next to Use Page Setup settings in the EPS Options dialog.

Detailer places a color bar, registration marks, and color name on each of the four separated plates. If you
wish to print negatives of your separation, check the Invert Image box in the Macintosh Printing Options
dialog or check the Print As Negative Image box in the Windows Print Setup> Properties> Graphics dialog. If
you are using a service bureau to print your separations, check with them on the proper setup for their
equipment.

Check the Black and White box if you are printing on a black-and-white PostScript laser printer.



Printing Tips
See:
Size and Orientation

Print Quality from Windows




Size and Orientation

Most printers cannot print across the entire page. Any given printer has a maximum printable area, which is
largely determined by the paper handling mechanism. For example, the maximum printable area on an 8 1/2
x 11” sheet of paper may be

7 1/2 x 10™.

You can visually confirm if your image fits by clicking and holding on the “i” icon in the lower left corner of
the image window. This will display a print preview box. The rectangle with the “X” in it represents your
image. The white box is the printable area of the page, and the gray border is the non-printable area. If your
image is too large to fit, you have several options:

* Use the Canvas menu> Resize command. Enter a lower value for either the width or the height. For this
purpose, it’s easiest to set the measuring units to inches or centimeters, not pixels.

® Change the printer page orientation from portrait to landscape or vice-versa. This is done in the File
menu> Page Setup (Macintosh) or File menu> Print Setup (Windows) dialog. Depending on your image
dimensions, changing the orientation may allow your image to fit. The new orientation will be visible when
pressing the “i” icon.

® Use the Size to Fit Page option under File menu> PostScript Setup. Selecting this option will always make
your image fit the maximum printable dimensions. This means that if your image is large, Detailer will shrink
it to fit. And if your image is small, Detailer will enlarge it to fit.



Print Quality from Windows

If you are not satisfied with the quality of your output, we recommend you take a close look at your printer
settings. To access these settings from within Detailer, choose File menu> Print Setup. Click the Properties
button.

The settings you find here vary, depending on what make and model of printer you have. For non-PostScript
printers, you’ll usually find controls for color, brightness, and dithering. Refer to your printer documentation
for details.

Microsoft maintains a large library of Windows-related printing information that is available on the World
Wide Web. Connect to the Microsoft Knowledge Base at—
http://www.microsoft.com/kb

For Windows, Detailer includes a PRINTER.STG file that contains color calibration information for obtaining a
quality color separation on a high-resolution imagesetting device.

The Printer Settings Dot Gain is set to 16%, Screen Frequency for all four process colors is 133 Ipi, and Angle
is set to 15j for cyan, 75i for magenta, 0j for yellow, and 45; for black.




Keyboard Shortcuts

Detailer uses a variety of keyboard shortcuts to help you work efficiently. To locate the keyboard shortcut for
a particular command click the appropriate subtitle below.

Shortcuts: Palettes

Shortcuts: Choosing Tools

Shortcuts: Keyboard Commands
Shortcuts: Model Window Navigation
Shortcuts: Image Window Navigation
Shortcuts: Drawing and Visibility Modes
Shortcuts: Painting and Materials
Shortcuts: Paint Bucket Tool

Shortcuts: Virtual Trackball Tool
Shortcuts: Dropper Tool

Shortcuts: Selection Tools

Shortcuts: Floaters

Shortcuts: Apply Lighting (2D Effect
Shortcuts: Magic Wand

Shortcuts: Imported Model Adjustments



Shortcuts: Palettes

Tools

Brushes

Materials

Controls

Hide/Display Palettes

Ctri+
Ctri+
Ctrl+
Ctrl+
Ctrl+

T hWNPR



Shortcuts: Choosing Tools

Object Selection*
Virtual Trackball**
Magnifier
Dropper

Brush

Paint Bucket
Text

Light*

Selection

Lasso

Floater Adjuster

- —=S " nNnoa3zy<o

*Model Window must be in front.
**In an image window, the Virtual Trackball functions as Rotate Page.



Shortcuts: Keyboard Commands

File

New Model

Open Model/Image
Close

Save

Print

Quit

Edit

Undo

Redo

Cut

Copy

Paste

Paste in Register
Drop Current Floater
Select All
Deselect/Reselect
Auto Mask

Clear Mask

Invert Mask

Effects

Last Effect
Second-To-Last Effect
Fill

Edit Gradation
Equalize

Adjust Colors

Super Soften

Quick Warp

Canvas
Resize Image

Ctri+
Ctrl+
Ctrl+
Ctrl+
Ctrl+
Ctrl+

Ctri+
Ctrl+
Ctrl+
Ctrl+
Ctrl+

OovTwnsoz

0O X < N

\Y

Shift+Ctrl+V
Shift+Ctrl+D

Ctri+ A
Ctri+ D
Shift+Ctrl+M
Ctrl+U
Shift+Ctrl+I
Ctrl+ /
Ctri+ ;
Ctri+ F
Shift+  Ctrl+
Ctrl+ E
Shift+  Ctrl+
Shift+  Ctrl+
Shift+  Ctrl+
Shift+ Ctrl+R
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Shortcuts: Model Window Navigation

Rotate Model View Space Bar+Alt+Drag
Rotate Model (lights remain fixed) Space Bar+Alt+Shift+Drag
Pan View Space Bar+Drag

Zoom in Space Bar+Ctrl+Click
Zoom out Space Bar+Ctrl+Alt+Click

Define Magnification Area Space Bar+Ctrl+Drag



Shortcuts: Image Window Navigation

Zoom in

Zoom Out

Zoom in

Zoom out

Pan image

Center Image

Rotate Page

Constrain rotate to 900
Un-rotate Page

Define magnification Area
View Selection

Shift Pattern

Shift+Ctrl+=

Ctri+-

Space Bar+Ctrl+Click
Space Bar+Ctrl+Alt+Click
Space Bar+Drag
Space Bar+Click
Space Bar+Alt
Shift+Alt+Space Bar
Space Bar+Alt+Click
Space Bar+Ctrl+Drag
Shift+6

Space Bar+Shift+Drag



Shortcuts: Drawing and Visibility Modes

Drawing Modes
Mask Disabled
Masked Inside
Masked Outside
Visibility Modes
Clear View

View Red Mask
View Selection

Shift+1
Shift+2
Shift+3

Shift+4
Shift+5
Shift+6



Shortcuts: Painting and Materials

Brush Controls

Resize Brush

Build Brush

Constrain to 450

Adjust opacity in 10% increments
Load Nozzle

Cloners Brushes

Set Clone Source

Water Color Brushes

Diffuse Wet Layer

Dry the Wet Layer

(Save the image)

Color Set

Add current color to color set
Replace current color in set
Gradations

Edit Gradation

Adjust spirality - spiral gradations

Ctrl+Alt+Drag
Ctrl+B
(straight-line mode)
1 -0 keys

Ctrl+L

Shift+Click
Shift+D
Ctrl+S
Shift+Ctrl+K

Alt+ Dropper Tool

Shift+Ctrl+B

Ctrl+Drag in angle ring

Shift



Shortcuts: Paint Bucket Tool
Limit fill extent Click-and-drag Paint Bucket



Shortcuts: Virtual Trackball Tool
Rotate model (lights remain fixed) Shift+drag in the Model Window



Shortcuts: Dropper Tool

Dropper access
Brush Tool

Measure mask density
Replace current color in set
Set Object Color

Ctrl

Object Selection Tool Ctrl
Paint Bucket Tool Ctrl
Rectangular Selection Tool Ctrl
Floater Adjuster Tool Ctrl
Shift+Click

Alt+Click

Alt+Click on Object



Shortcuts: Selection Tools

Constrain to square/circle Shift
Adjust current selection rectangle Control+Alt+Click/Drag

Edit rectangular selection Shift+Ctrl+E



Shortcuts: Floaters

Group selected floaters
Ungroup

Floater Adjuster

Duplicate

Move floater by one screen pixel
Hide/Display marquee

Delete selected floaters

Adjust opacity in 10% increments
Select floater in image

De-select all floaters in image
Set Transform (selected floater)

Floater List

Attribute dialog box for selected floater
Floater layer order

Select/Deselect

Attribute dialog for current floater

Ctrl+ G
Shift+Ctrl+G
Shift+Ctrl+U

Alt+Click/Drag

Arrow Keys
Shift+Ctrl+H
Backspace

1-0 Keys

Click on Floater

Click outside Floaters
Shift+X

Double-Click Item
Drag Iltem
Shift+Click Item
Enter



Shortcuts: Apply Lighting (2D Effect)
Lighting Mover Shift+Ctrl+L



Shortcuts: Magic Wand

Add color to selection Shift+Wand
Find all instances in area Selection+Wand



Shortcuts: Imported Model Adjustments

Invert Normals Shift+Ctrl+)
Repair Normals Shift+Ctrl+K
Smooth Normals Shift+Ctrl+N









